[INACTIVE][MECH] EekRunes v1.4.0.19 - Runecraft Port (Now reads magic.dat!)

Discussion in 'Inactive/Unsupported Plugins' started by Eeketh, Jan 23, 2011.

  1. Offline


    The latest version can always be downloaded from here:

    Code can be obtained from https://github.com/Eeketh/EekRunes

    I am attempting to port the below to Bukkit, because there's a lot of functionality I've been missing.
    (Note: the original Runecraft mod is by Superllama. He doesn't intend to port anything until Notch releases the API, so it looks like this will be the only Runecraft for Bukkit)

    So far, only the 7 below runes have been ported:
    • Secret Passages
    • Waypoints/Teleporters
    • Compass
    • Oracle
    • Freezer Rune
    • Chrono Trigger
    • Power Tool (power pick/shovel)
    Runes can also be loaded/unloaded using the following commands:
    • /eekRuneAdd <name>
    • /eekRuneDel <name>
    • /eekRuneReload <name>
    • /eekRuneList will list all the loaded runes
    Please note that the rune name when loading is case sensitive.

    Runes can be switched on/off by editing the settings.ini file created when you first run the plugin.
    If more runes are added after you have run the program, they will be added to your settings.ini file as disabled.

    Note: There are some slight differences with the way my hidden passages work:

    1) The keystone is always used as the "ink". Whatever the keystone is made of, the entire door will be made of.
    (note: I believe the previous system either used it as ink, or a key you needed to use, depending on how rare the block was. Nobody I know uses keys, so I didn't think it important)
    2) The door activation can now be triggered by redstone.
    3) If you right-click the keystone while holding a redstone torch, you will ONLY be able to open the door with redstone - right-clicking will not work.
    (this is to keep secret doors harder to find)

    Superllama - Original Runecraft creator.
    @MRH - code to read from Runecraft's data file.
    @Herr Riz - NotRunecraft code
  2. Offline


    I believe the rule for official Runecraft is that signature blocks can't match the blocks that the rune is made of.

    So, for example, an obsidian teleporter couldn't be used to link to a location where one of the signature blocks is obsidian, as that would that the signature blocks matched the construction type.

    This prevents excessive rune matching.

    There was a funny example, where someone had built a chessboard-like floor out of obsidian and smooth stone. This triggered the compass rune if anyone clicked on it :).
  3. Offline


    Yeah, good point! That should be fixed too, maybe this is the cause of death of the server.

    EDIT: plug-ins that we have also installed:


    maybe there are some undesirable interactions with other plugins

  4. Offline


    This is great Eeketh.

    One Issue so far: Creating an waypoint without keyblocks also makes a compass rune, the resulting waypoint is reconfigured but still functional.
  5. Offline


    One Question:
    Are You Intrestted in the Sourcecode to read the magic.dat from Runecraft?

    It is written in C#. But C# and Java are quite similar :)
  6. Offline


    [​IMG]The server i use this on crashed when i make a second teleporter with too much distance between them.
  7. Offline


    Apologies for not looking into it today guys, too much going on!

    Would love to! Thanks.

    The server itself crashed, or just the client? if the server crashed, maybe I need to force the chunks to load before teleporting? I think there was a method for that? Will give it a try tomorrow.

    Disallowing signature to be all air will fix this, but you can then still remove the signature after it's been created, leaving compass... I guess I'll have to check that the block isn't currently used for any other runes :)

    Odd. I'll shove everything in their own threads to try and prevent the server being affected by anything - should speed things up - and I'll do more investigation to see why it happens to begin with...

    Ah, ok, I stopped you from having *all* signature blocks being the same - didn't realise you couldn't have any of them!
    HrpDrp likes this.
  8. Offline


    Nice! Runes rule.

    Unfortunately for the teleporter, it does not activate for me. Tried with obsidian at first, then tried with wood and planks, but only the waypoints activate.

    On build 135 for craftbukkit.

    Anyone else tested waypoints on a recent build?

    --- merged: Jan 27, 2011 12:01 AM ---
    I would like that as well, if you don't mind sharing? But no biggy if you can't for whatever reason ;)

    Also Eeketh, can I request Power PickAxe and Power Shovel implementation as the next 5th rune? That tool is invaluable in making the Minecraft experience less chore-like when building/mining. I would appreciate any efforts made at porting it over to your mod.

    Thanks for the Rune power in Bukkit, it is great. I am tempted to stay with MC standard server just because of the power pick/shovel ... hehehe.

  9. Offline

    Herr Riz

    Cool. I'd like to get NotRunecraft ported, but I'm still waiting on chrisinajar to port HeyRunes.
    What's your rune recognition like? I'd be happy to work together if you don't mind blatantly ripping off the original.
    HrpDrp likes this.
  10. Offline


    Is there any way to port the current waypoints from a Runecraft server to this plugins format?
  11. Offline


    I run into the problem that the server stops working when using a teleporter over long distance.
    The server does not give an error, nor does it crash, it simply stops working, no comands can be entered and no actions will be saved.
  12. Offline


    We're running with Outi the same server. After second thinking that may not be true. We could test this for sure, but if our issue is with bug "long distance teleports", we do not need to test this. If something after that fix comes out, we will get you know.
  13. Offline


    Eeketh, can you put the sources on github or something? Maybe we can provide some usefull contributions to the code :)
  14. Offline


    Here is the SourceCode:

    The Comments are in german.
    But i hope, that is no problem ;)

    But, if u use it, please add me to the Credits ^^

    PS: This is the Source of my C# Libary.
    So, if you are intressted in a allready Compiled Version, click here :)

    (Mit freundlichen Grüßen (german ^^))
  15. Offline


    This plugin is in dire need of an update. Using Craftbukkit 156, whenever someone uses a TP rune over long distance the server commits suicide, giving a memory.heap error and shuts down. :( A damn shame, my server loves Runecraft and people were pumped as hell when I told them the news about eekrunes. Don't give up though!
  16. Offline


    Just letting you know I'm here - currently working on the code ^_^

    Probably will do once I've made code a bit neater and more commented - it's a bit embarrassing at the moment ;)
    --- merged: Jan 27, 2011 9:05 PM ---
    Bug fixed.
    finding the block above/below a block when a chunk's unloaded does not return correctly.
    teleporting attempts to find a safe place to land by going up to a place with enough air, then going down until you reach the floor - so because it didn't return correctly, it ended up as an infinite loop trying to find a safe location.
    --- merged: Jan 27, 2011 10:23 PM ---
    Added MRH's magic.dat reader.
    I have no magic.dat, so no way to test.
    Please can someone give this a go? **BACK UP FIRST**

    --- merged: Jan 28, 2011 12:00 AM ---
    Hidden Doors now work horizontally
  17. Offline


    @Eeketh downloaded the latest version. I'm running bukkit build 135. Teleports seem to be broken. I can create the waypoint, but when I try to do a teleport or personal teleport, I get no feedback and nothing happens.

    EDIT: when I first create a permanent teleport rune, it says "teleport created" but activating does nothing.
  18. Offline


    Well it's cool that we got something till runecraft gets portet =\ .. the only problem i have now our members can dupe diamond blocks etc as much as they like using hidden passages; any ideas how to fix this?
  19. Offline


    get better members :)
    any of our server players did that, they would be in for a ban
  20. Offline


    You can try my new plugin, HiddenDoor. It's make hidden passage work exactly like in Runecraft, and have also the capability to load the doors list from the magic.dat file.
  21. Offline


    How's that? destroying 1 block in the door should destroy them all :s
    --- merged: Jan 28, 2011 9:10 AM ---
    Those not able to use teleporters, please download the latest version of craftbukkit.
    It includes a new method to load a chunk before you teleport, so if you're on an old version it won't work.
  22. Offline


    are the Personal teleporters missing?
  23. Offline


    With the newest version of craftbukkit this is finally working perfectly for me. I'd like to point out a couple things that differ from the original Runecraft plugin.

    • In Runecraft, you can have all four sig blocks the same, with the exception of air. You can not leave all four sig blocks as air. In EekRunes, I can't currently activate a teleport or waypoint where all four sig blocks match.
    • As Raphfrk mentioned earlier in the thread, in Runecraft, you cannot build a teleport or waypoint run where the "ink" block matches any of the sig blocks. It seems like Eeketh misunderstood this to mean that you can't have 4 matching sig blocks.
    It would be useful to have the ability to match all four sig blocks. My users are interested in personal teleporters, and they'd like to set up commonly used teleporters with all matching sig blocks so they're easy to remember.

    If this causes problems with the compass rune, I'd suggest making the compass rune requirements more exacting. You could, for example, make it a 5x5 rune, where all the edges have to be air, the X in the center, and blank spots between the X have to be air as well.
  24. Offline


    Teleports should already be able to have 4 of the same - but not 4 tier 0 blocks.
    I've changed this to just not be 4 air blocks now.

    @outi they're working fine for me, just tried it... you need to right-click the redstone in the center
    --- merged: Jan 28, 2011 2:31 PM ---
    compass can now be activated by tools & empty hand only - so waypoints don't have issues.
    no longer get an error printed out if there's no .doors.list file
    left&right of top of door is no longer inked, it just goes back to air - this is so you can't dupe blocks. mining part of the door itself will destroy the door, leaving just 1 block of that type - which you used as the keystone.
  25. Offline


    You're right about the tier zero blocks, but I just dropped in your update, and I still can't activate a waypoint with 4 dirt as the sig.
  26. Offline


    Sorry, only updated teleport rune, warp rune needed updating too.

    Apart from that, are there any bugs left, or do I work on more runes?
  27. Offline


    Yeah you're right i had the // pickaxe enabled so it didn't destroy the hidden door
    but you can still dupe.

    for example: place 1 diamond block in the middle then right click => you get 3 diamond blocks at the top layer..
    smash em all and do it again.. so you get diamond BLOCKS for iron ORES....

    well we trust our members but we'd still like to be able to controll this; could you create a restricion list for hidden door stones or smth like that? would be nice!

    or to just turn the middle block of the top layer into the door's block so you have to change the others manually if you want to ; this way you couldn't ever dupe anything o;

  28. Offline


    That's one of the fixes I did at lunch today ^_^
  29. Offline


    I didn't find any glaring issues with this release, so on to more runes! Though, honestly, you've covered all the runes from Runecraft that I'd say are important.
  30. Offline


    Could not save doors list - the location may be write protected

    file has RW permissions...
  31. Offline


    Try downloading again? it'll show what the error is this time, so I can debug?

Share This Page