[INACTIVE][MECH]CommandSigns v0.4 - Issue commands using signs [672]

Discussion in 'Inactive/Unsupported Plugins' started by Edward Hand, Feb 22, 2011.

  1. Yeah... it seems this update forces users to follow the permissions that they have... any way to fix this?
    (example, as admin, if i do the command "/time day" on a sign, i can use it, but someone else cannot). I am attempting to make it so that no matter what is on the sign, anyone can perform that command.
    also, redstone activation doesn't appear to work
  2. Offline


    So 551 is the latest recommended build? Ohh no its not.
  3. Offline

    Edward Hand

    There are instructions in the first post on how to bypass the permissions with signs. (It's something of a fudge as permissions isn't really bypass-friendly but it works)

    Also, point to the bit where I say redstone works [​IMG]
  4. are you talkin about adding "#CommandSigns" to permissions? (If you include the #, it acts as a comment, and without it, it doesn't make a difference... says i dont have permission) I even added #CommandSigns and CommandSigns as OP.

    Also, i had tried redstone, with 1 redstone path to the sign, with a button. When i pressed the button, it didn't do anything. when i right-clicked the sign, it performed the command. (also tried lever and floor plates)
    Also, as i think it was stated above, on any signs that use an operation (stargates, craftbook, etc etc), it says "You do not have permission"... however, the operation is not impared as far as i can see (lifts are usable, as well as stargates)
  5. Offline


    I have the exact same problem.
  6. Offline


    You can't add #CommandSigns into the permissions file because # comments the line out, making him invalid.
    Oh good, I wasn't sure what mod that was, as I installed quite a few at once. Didn't want to check them one by one either.
    But yea, I'm having that as well.
    Oh, but that's only when I right click a sign (even a blank one) that isn't a [command] sign. Those all work without the Permissions error.
  7. Has anyone got redstone to be working? (just curious, so i can see what i'm doin wrong :S )
  8. Offline

    Edward Hand

    I never said I added redstone (which is because I haven't yet).
    Bukkit only added the stuff for making that work a few days ago.
    @Amin Azman

    Please redownload. The problems should now be fixed.
    (note that #CommandSigns is now /CommandSigns (and it is case sensitive))
  9. Offline

    Amin Azman

    Thanks, so we need to change the virtual player for command signs from #CommandSigns to /CommandSigns?
  10. Offline

    Edward Hand

    Correct. '/' is one of the few characters YAML doesn't take exception to.
  11. Offline


    Hey. I just got this nice plugin. However, the [command] line shows up in red (not green) and the sign doesn't work at all. What did I do wrong ?

  12. Rofl... hahaahaha. (oops).
    Re-downloaded, and it all appears to be working well :) i'll post back if anything goes crazy
  13. Offline

    Edward Hand

    Make sure you've given yourself permissions for commandSigns.create
  14. Offline


    Tried 0.3 and get "Insufficient Permissions" messages every time when right-clicks on sign
    Going back to 0.15 :confused:
  15. Offline

    Edward Hand

    I fixed that within the last 24 hours. Please re-download to fix this issue.
  16. Offline


    This plugin will fulfill all of my hopes and dreams when it has redstone triggering <3
  17. Offline


    iconomy suport? it would be nice for a comand shop :D
  18. Offline


    Thanks for the player variables! However, I can't get /give to work. I've tried /give @Player 50 64, but it doesn't give me torches. Not sure how the /command is supposed to work at all. /give /command 50 64? I need variables specifically for the give command so anybody walking up to it can right click and get the item.
  19. Offline

    Edward Hand

    it would be:
    /*give <NAME> 50 64
    (exactly like that)
  20. That would only work if that player had permissions for /give, right? (you would need to do /*give <NAME> 50 64 , and give "/CommandSigns" permission for that command.

    i'm with the rest of the world... in waiting on redstone activation :D (This shall be epic :D )
  21. Offline

    Edward Hand

    oops! That's what I meant to type...
    I've corrected my original post. Thank's for catching that.

    As for redstone, there are a number of concerns I have with implementing it (opinions welcome). The main one is that there is no way of tracing who triggered the redstone. That gives the problems of what do you do with player specific commands as well as the bigger problem of permissions. What's to stop someone who shouldn't be able to use command signs just hooking up a bit of wire and a torch and using the sign anyway?
  22. Offline


    how did you create your rules!?! what command or plugin or folder do i need to make it show my rules?

    (i'm new to this)
  23. Offline

    Edward Hand

    That comes with the Essentials plugin I believe.
  24. Offline


    You could simply make redstone activation ignore non /* commands, or run them using the closest player. (same with <name> etc...)
  25. Offline

    Edward Hand

    Not a bad idea, but the point I was trying to make was what about players who don't have the permission commandSigns.use? They would still be able to use signs with redstone
  26. Offline


    For some reason I cannot for the life of me set up /CommandSigns with permissions. It comes back as "you lack permissions" every time I try to fire off any command. :X

    Also I get this problem all over with certain signs as well.
  27. Offline


    Can we have multiple commads for a single sign? It would be an alternative for iconomy built-in suport, as we could put the commads and the /money take <name> money thingy.
  28. Hmm... i can see where you're coming from, if redstone wont look at permissions.
    I can tell you what i am looking for.
    I have it setup so that only admins can setup signs (tbh, the only place i'll use this is during server-oriented events throughout the server... and will be using /*command the entire time). However, a lot of it is using redstone to activate something, to perform actions on the player who activated it (such as teleport player to a location, add item to player inventory, kill player >:D )... if redstone cant pass that data, it'll screw up my plans :S
    On the permissions/abuse problems, its not a problem for MY situation, because sign placement is restricted on my server.
  29. Offline


    Here is what I have tried, and what has failed no matter how I type it... Anyone know what i'm doing wrong?

    The moderator has all required nodes listed above it, and I have also tried making commandsigns an admin without luck by using "Admins"

    Note: I have ensured the formatting (spacing) is correct, so it's not that.

    When I click a sign with all the settings set up correctly for a "server command" via /CommandSigns, this is the error I get:
    I am on recommended Bukkit build 531, with Commandsigns 3.0

    Note: After reading these forums backwards and forwards, and seeing on the terminal that "
    #CommandSigns" is not authorized, I realized that the author changed the code without changing the version to amend the error with the # and /. I had to redownload to fix it. Please update the version next time as that issue led me to troubleshoot pointlessly for hours -.-

    While the signs work for things like giving items, they seem to fail when I attempt to tie them in to AutoRepair, here is the log... Any chance for a resolution?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  30. Offline


    Got the give command to work, but only for single digit items. When I type in "/*give <NAME> 50 64", the line ends at 5. I have to drop down to the next line for the "0 64". The console then prints out "[INFO] /CommandSigns tried command: give punchin 5 0 64" and nothing happens. I changed it to 1 instead of 50 and it worked properly. It needs to not put a space on linebreaks unless it's a new command.

Share This Page