[INACTIVE][GEN] General 2.2.11 (Chernobyl) -- A plugin for general commands [860]

Discussion in 'Inactive/Unsupported Plugins' started by cjc343, Mar 2, 2011.

  1. Offline


    I fully recommend that you use Celtic Minstrel's General and cease to use this version.

    Celtic Minstrel's General (and Bukkit) now support command aliasing in a form that makes this version of General redundant. I am working on a final release which will attempt to upgrade existing 2.x users to the new version, but it will be faster to switch yourself (and potentially easier as well) rather than wait for this to be available.

    When switching, you should be aware that your existing configurations will not have an effect. You should take some time to familiarize yourself with the new config options available, as well as making sure that you copy in the new config files.

    If you have localized your items.db, you will need to transfer this to the new format.

    Sorry for the slow movement on this, I have been moving, on vacation, and then starting a new job and it has left my days quite full for some time now.

    Show Spoiler

    General 2.2.11 [Chernobyl] (Requires CraftBukkit 818-860+ & Permissions 2.x or 3)
    Zip File (Contains items.db, general.help, general.motd, config.yml)​

    This fork of General provides basic commands while allowing other plugins to override them automatically. If another plugin registers a command, General will not use it. This allows you to replace only specific features with a different plugin simply by adding the other plugin as well. General will notify you at start-up when it gives a command to another plugin.

    General is a fork of Nijikokun's original General plugin, without which, this plugin would never have been possible.

    1. /afk | away (message) -- Set you AFK or set your AFK status.
    2. /playerlist | online | who (player) -- List players or info about a player.
    3. /spawn -- Return to spawn.
    4. /setspawn -- Change spawn to current location.
    5. /time help -- Provides more info about changing the time.
    6. /tp | teleport -- Teleport players or to a player. Type /tp for more info.
    7. /tphere | s (player) -- Teleports a player to you.
    8. /i | give | item [item ID | name in items.db] (amount) -- Gives an item by name or ID#.
    9. /msg | tell [player] [message] -- Send a message to another online user.
    10. /compass -- Direction reading.
    11. /getpos -- Detailed location information.
    12. /motd -- Re-display the MOTD.
    13. /reloaditems | rlidb -- Reload items.db.
    14. /help | ? (page) -- Prints help file.
    Permission Nodes:
    1. general.items: Controls /i, /give, /item

    2. general.spawn: Controls ability to use /spawn

    3. general.spawn.set: Controls ability to use /setspawn

    4. general.teleport: Controls ability to use /tp, /teleport

    5. general.teleport.here: Controls ability to use /tphere, /summon

    6. general.teleport.to: Controls ability to use /tp * [destination]

    7. general.teleport.silent: Prevents notifications when teleporting.

    8. general.time: Controls ability to use /time

    9. general.player-info: Controls ability to use /playerlist, /online, /who

    10. general.reloaditems: Controls ability to use /reloaditems, /rlidb

    Functions Available:
    +dname | +d​
    Player display name.​
    +name | +n​
    Player name.​
    +location | +l​
    Player location.​
    +health | +h​
    Player health.​
    Player iConomy balance.​
    Player IP address.​
    # of online users.​
    Color Codes (Put either '&' or '§' in front of the color code):
    0: Black​

    1: Dark Blue​

    2: Dark Green​

    3: Teal​

    4: Dark Red​

    5: Purple​

    6: Gold​

    7: Light Grey​

    8: Dark Gray​

    9: Light Blue​

    a: Light Green​

    b: Turquoise​

    c: Light Red​

    d: Pink​

    e: Yellow​

    f: White​

    Config Files:
    items.db -- Goes in the root directory with your server.properties. On most setups, this will be the same folder as the CraftBukkit jar. If you are using MineOS, this is the 'one' 'two' or 'three' folder. A template for this file, and the other config files, is available in the ".zip" download.​

    general.help -- Contains general's help information.​

    general.motd -- Contains the Message of the Day. Leave blank for no message.​

    config.yml -- Allows you to change playerlist settings.​

    Change Log:

    Change Log:

    Version 2.2.11
    - Proper isCancelled checks.​

    Version 2.2.10
    - Fixed case-sensitivity issue with dynamic commands​

    Version 2.2.9
    - Built against Permissions 3​

    - Added support for 1.6 items​

    Version 2.2.8
    - iConomy 5 support.​

    Version 2.2.7
    - Added silence support to primary teleport case.​

    Version 2.2.6
    - Added general.teleport.silent Permission node.​

    Version 2.2.5
    - Updated items.db in zip file​
    - Added sapling variants​
    - Added TP messages​
    - Added check for command aliases that conflict with General​

    Version 2.2.4
    - Updated for 594+​
    - Added dependency to plugin.yml​
    - Fixed command checking for plugins loading before General.​

    - Fixed Permissions loading​
    - Changed iConomy loading method​

    Version 2.2.3
    - Changed Permissions loading method.​
    - Added 'general.teleport.to' permission node.​
    - Fixed error when using /who for an offline or nonexistent player.​
    - Updated example items.db to demonstrate 'damage' attributes, as mentioned (and implemented?) by Celtic Minstrel.​

    Version 2.2.2
    - Properly cancelled events that actually happen.​

    Version 2.2.1
    - Changed the way General checks other plugins for commands.​

    Version 2.2
    - Code Refactoring​
    - Uses new method to set spawn​
    - Eliminates direct access to CraftBukkit​

    - Fixed loop when permissions not present.​
    - Other small fixes and optimizations that I don't remember​
    - Old code cleanup​
    - Actually uploaded to github

    Version 2.1.2
    - Actually fixed iConomy (4.0) support.​
    - Fixed MOTD not appearing from some version​

    - Added support for 454+​
    - No longer throws NPE if config isn't present​

    - Fixed setspawn​
    - Fixed iConomy 3.0 iirc.​

    Version 2.1.1
    - Added Permissions 2.1 support.​

    Version - By Tatsu-Kan
    - Added Beta 1.3 items.​

    - First release of "Unofficial General"​
    - Built for build 432+​

    Version 2.1 and Earlier are by Nijikokun with contributions from Celtic Minstrel, verrier, OniTux, and others? Celtic Minstrel has also created a fork of General. I will use it myself and stop updating this once Bukkit provides any interface for overriding other plugins. One method of achieving this is currently a low priority issue for the Bukkit team.

    Darkspear and Tazzernator like this.
  2. Offline


    Are you sure you gave them 'general.items' permission? Those commands are working fine for me.

    Please post your server startup log + attempting to use command + permissions config if you continue to have trouble.

    MCDocs and Celtic Minstrel's General offer this function. If you can provide a reason neither of those will work for you, I'll look at adding an option to the MOTD.
  3. Offline


    yes, they have :S Would it be possible that another plugin blocks the commands? Because todays morning all commands work very well, but after I updated some plugins to 733 they won't...
  4. Offline


    That would be possible if only because General does not display any "You don't have access" messages.

    If it happened after you updated other plugins, try removing the ones you updated and seeing if it goes away. If it does, you know one of them is causing it.
  5. Offline


    okay, I will try it tomorrow. If I find the blocking plugin, I'll post it ;) Thank you :)
  6. Offline



    Is there a way to hide the message when you teleport to a player? Its hard to spy on bad players when they know your watching after teleporting to them.
  7. Offline


    Yes, in about 3 minutes there will be a new permission node "general.teleport.silent" which will make your teleports silent. You'll need to re-download to actually use it of course :Þ

    There'll be an EDIT here shortly after...

    EDIT: cPanel tried to crash my computer sorry. Finally made me bother to set up the connection in WinSCP and I had to look up the connection info. Uploaded now. Updating post.
  8. Offline


    Hi, I'm running 2.2.6 On CB 740 but the permission node: 'general.teleport.silent' doesn't seem to be working for me. Any suggestions? Am I the only person with this issue?
  9. Offline


    @cjc343 Are you going to program commands for weather ? and also if could give a command to spawning animals that used to be an option we had in Hmod as a base command ?
  10. Offline


    Same here...
    Admins have - '*' permissions and Mods the 'general.teleport.silent' permission node,
    but when they teleport the message appears.
  11. Offline


    I forgot I added the notification in two places -- and only put the permission node in the less-used case. Thanks for catching that guys. It's fixed now.

    Both of these features are built in to Celtic Minstrel's General. I plan to eventually transition all users to that version once dynamic command registration of some form is present in bukkit, so if you're looking for them now, I'd suggest switching.
  12. Offline



    Is it possible to prevent a user from teleporting to me? A command i type or node i give myself so people cant just teleport to me.
  13. Offline


    The comment is a bit vague to me, will this plug-in be dropped in the near future? Or do we need to switch to Celtic Minstrel's General plug-in? I want to get rid of the bloated Essentials plug-in and I'm looking for a replacement.
    I like the simplicity of this mod, every command is being used and no bloated things. In the General version of C. Minstrel I can already see the plug-in growing in unnecessary features such as kits and weather. All features which have already been implemented by other plug-ins such as:
    If people want these features, they can easily use these plugins. If General 3.3.x is going to implement these features (such as weather and kits), we will get the Alternative Essentials plug-in, in which not only General commands are available, but also a whole range of other commands (already filled by other plug-ins). My point is that adding as much commands as possible might break the plug-in from working with others as we can see what has happened to Essentials (-> http://forums.bukkit.org/threads/ed...uild-from-far-away-709.62/page-85#post-264570)
    Please maintain this plug-in, I love it! It's simple, it does what it needs to do and there are no bloated/obsolete commands which there are tons of other plug-ins for. Simple, clean and effective! I can already see the General plug-in from C.M. drifting from this idea.
    Also, as a suggestion: very simple feature (with permissions) that allows an obsidian portal to teleport (by default) to the nether, I haven't yet seen a simple plug-in which does this
  14. Offline


    This is pushing into the realm of a dedicated tp plugin at this point. You may want to take a look at Tele++ or other [TP] plugins. There shouldn't be any issues with General compatibility, and they'll include advanced features like that.

    This plugin will probably exist still for some time. Celtic Minstrel's General is the future, but it lacks a feature I love: dynamic command registration. This makes it so that yml editing is needed in order to allow another plugin to override a registered command.

    Once some method of peacefully resolving command conflicts is available in bukkit, I will be working towards moving users of this version to Celtic Minstrel's version. It is unknown when these features will be available.

    I will attempt to make the transition as clean as possible, but it is highly likely that users will need to fix permission nodes for General.

    I understand your concern, however, I do not believe it will be an issue once bukkit support is present.

    Many plugins provide MOTD, set/spawn, playerlist, time, teleport, and give functions. None of those are very unique.

    So I should only bloat in the direction you want? Nether will be SMP in 1.6.x
  15. Offline


    Ohh no, I didn't mean to push you in any direction. After your explanation I get it, I was just afraid that this plug-in would be dropped very soon. And with the suggestion, I didn't mean to just rant but also give some feedback. I figured a nether feature would be neat to add but as that is coming in MC1.6 then there is no problem ;)
    Thanks again and umm, does General 2.2.7 hook into iconomy? I think Iconomy v5 and General 2.2.7 are conflicting with eachother, I'm working this out and will post some logs soon.
  16. Offline


    I heard something about iConomy 5 breaking with iConomy 4. I'm almost certain I need to update to add support for it. I'm leaving in a few minutes, but will try to get that working once I'm home again.
  17. Offline


    Two questions. I'm using bukkit 740.

    Question 1: How do I give my mods kick and ban permisisons? I can't find them anywhere.
    Question 2: When I use the +balance for the message of the day, it says we have "35 Coins Coin." How do I get rid of the extra coin?
  18. Offline


    General doesn't offer kick and ban. This can be done via whitelisting, the built-in /kick command, or via kick/ban plugins such as mcbans, or one of the other ADMIN plugins that provides k/ban.

    2.2.8 is just released and provides iConomy 5 support. iConomy 4 users shouldn't upgrade.
  19. Offline


    23:54:28 [SEVERE] javax.script.ScriptException: sun.org.mozilla.javascript.internal.EcmaError: TypeError: Cannot call method "getSettings" of null (<Unknown source>#28) in <Unknown source> at line number 28
    2011-05-06 23:54:28 [SEVERE]     at com.sun.script.javascript.RhinoScriptEngine.invoke(Unknown Source)
    2011-05-06 23:54:28 [SEVERE]     at com.sun.script.javascript.RhinoScriptEngine.invokeFunction(Unknown Source)
    2011-05-06 23:54:28 [SEVERE]     at nickguletskii200.SpyerAdmin.CustomHandling.who(Unknown Source)
    2011-05-06 23:54:28 [SEVERE]     at nickguletskii200.SpyerAdmin.SpyerAdmin.onCommand(Unknown Source)
    2011-05-06 23:54:28 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-05-06 23:54:28 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    2011-05-06 23:54:28 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:677)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:640)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:634)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    2011-05-06 23:54:28 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  20. Offline

    Celtic Minstrel

    I have added some new features, yes. I think I added maybe four new commands (kits, weather, mobspawn, items) unless I've forgotten something. I have no intention of adding any more commands; rather, I'll just work on improving the existing commands. The intention is to give access to basic forms of each command. Want more advanced teleportation? Try Tele++. Want to specify where lightning strikes instead of it being "random nearby location"? Try MotherNature or CraftRepo's WeatherControl. (There's also WeatherGod, but sadly that'll conflict with General.) Want more control over mob spawning? I'm not sure if there are plugins that do this better than General at this point; SpawnMob does offer more options, but also lacks some options that General has. Better MOTD? Try MCDocs.

    Compare this to Essentials. Yes, I've added stuff. Yes, Essentials has added stuff. I've added a handful of things that don't largely depart from the basic idea of the plugin, which is to provide general commands. Essentials has added nearly everything they can think of. 90% of Essentials is not essential. That's why I consider Essentials to be horribly bloated, and why I don't feel General is bloated.
    RaCooN likes this.
  21. Offline


    Thank you for the effort you make on General. I also like that you cjc343 and CelticMinstrel are on good terms (it seems), even though you are working on different versions of a mod from the same source. That is the sort of "harmony" I like seeing in developer communities. Thank-you to both of you.

  22. Offline


    22:23:24 [SEVERE] Could not pass event PLAYER_COMMAND_PREPROCESS to General
            at com.nijiko.permissions.Control.getGroup(Control.java:535)
            at com.nijiko.permissions.Control.permission(Control.java:308)
            at com.nijikokun.cjcfork.bukkit.General.iListen.onPlayerCommandPreproces
            at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.ja
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:640)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:634)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    22:23:24 [INFO] Minhyme issued server command: tp
    I get this error when I try any of the commands. I tried, same issue.
  23. Offline


    General does not appear to be the issue here. If there is a conflict, I need more info than 'Why?' is really old. You shouldn't be using that unless you're running a really old server. What server version are you running and what version of Permissions are you using? Could you paste a log of your server startup?
  24. Offline


    146 recipes
    16 achievements
    22:57:58 [INFO] Starting minecraft server version Beta 1.5_02
    22:57:58 [INFO] Loading properties
    22:57:58 [INFO] Starting Minecraft server on *:25565
    22:57:58 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-706-
    gf53e007-b740jnks (MC: 1.5_02)
    22:57:58 [INFO] Preparing level "Minhyme's Server"
    22:57:58 [INFO] Preparing start region
    22:57:59 [INFO] [Permissions] (Phoenix) was Initialized.
    22:57:59 [INFO] [iConomy] Logging is currently disabled.
    22:57:59 [INFO] [iConomy] v5.0 (Eruanna) loaded.
    22:57:59 [INFO] [iConomy] Developed by: [Nijikokun]
    22:57:59 [INFO] [Permissions] version [2.7.3] (Phoenix)  loaded
    22:57:59 [INFO] [iConomy] hooked into Permissions.
    22:57:59 [INFO] [General] version [2.2.8] (Chernobyl) loaded
    22:57:59 [INFO] [General] hooked into Permissions.
    22:57:59 [INFO] [General] hooked into iConomy.
    22:57:59 [INFO] Done (0.110s)! For help, type "help" or "?"
  25. Offline


    I tried this configuration and am unable to reproduce the error. Could you paste your Permissions file?
  26. Offline


            default: true
                prefix: ''
                suffix: ''
                build: true
                - 'general.spawn'
                - 'general.time'
                - 'general.player-info'
                - 'iConomy.rank'
                - 'iConomy.list'
                - 'iConomy.payment'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - 'general.items'
                - 'general.teleport'
                - 'general.teleport.here'
                - 'general.teleport.to'
                - 'iConomy.bank.access'
                - 'iConomy.bank.main'
                - 'iConomy.bank.main.view'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Moderator
                - 'general.spawn.set'
                - 'general.teleport.silent'
                - 'general.reloaditems'
                - 'iConomy.admin.grant'
                - 'iConomy.admin.set'
                - 'iConomy.admin.reset'
                - 'iConomy.admin.hide'
                - 'iConomy.admin.account.create'
                - 'iConomy.admin.account.remove'
                - 'iConomy.admin.stats'
            group: Admins
                - '*'
  27. Offline


    The error is occurring because your group is set to "Admins" and you have no group by that name.

    Aside from that, when giving out '*' permissions, you should not inherit any other permissions. Instead, create a group such as "Owner" with no inheritance and then set that as your group and remove the '*' permission node from your name.
  28. Offline


    Wow... I can't believe I missed that. Thank you though!
  29. Offline

    timmy silesmo

    When i write the command /t spawn when i want to use it for towny it does not hand over the comand to towny instead it tell me /tell [player] [message]
    can you help me?
  30. Offline


    /t is not a command that General uses. It does attempt to use /tell, but that is not the message it displays when /tell is used improperly. You likely have another plugin that is implementing /t.
  31. Offline


    i gave players the general.spawn permission yet they can still not use /spawn. help?
    version: 2.2.8
    craftbukkit: 740

Share This Page