[INACTIVE][FUN/TP] PressurePorts v1.3- Step on a Pressure Plate, Warp [818]]

Discussion in 'Inactive/Unsupported Plugins' started by Wurstfabrik, May 20, 2011.

  1. Offline


    Pressure Ports - Step on a Pressure Plate, Warp
    Version: 1.3

    Since i started working with java some days ago and announced this to my server users it didn't took long till the first requests came. One was simple enough for my skills and sounded funny (and it is, oh lol!), so i started working on the idea.

    It is simple: You step on a pressure plate and get teleported somewhere. Due to the mass of pressure plates on my server i decided to add a required block (lapis) under it. So here is how you set up the PressurePlate:

    Place a Lapis-BLock​
    Place a Stone Pressure Plate on it​
    Walk somewhere, enter /ppset​

    Now everybody can step on your awesome PressurePort and get ported to somewhere else :D

    For everyone who doesn't get the text, dubstein made a short but cool explanation video:

    (Thanks bro!)
    Please ignore the "kid", i am 23 years old. :D

    Let's you create an automatic Warp system without using portals or commands for your users.

    PressurePorts v 1.3
    Source Code is a mess at the moment, maybe i will make it public for later versions.

    Things to know (open)

    Config File:
    The config file is generated automaticly when running the plugin the first time. If you have any problems create a file called config.yml in the PressurePorts-Dir and fill it with the following text:

        PlateType: STONE_PLATE
        BlockType: LAPIS_BLOCK
        Player: true
        Mobs: true
        Minecarts: true
            Break: true
            Create: true
            Use: false
    Short explanation of the settings:
    PlateType MUST be STONE_PLATE or WOOD_PLATE, everything else will be overridden with STONE_PLATE by the plugin.
    BlockType MUST be a placeable block, everything else will be overridden with LAPIS_BLOCK by the plugin.

    Legal BlockTypes (open)

    You CAN NOT use Block-IDs as a BlockType. So using 42 for Iron Blocks for example will reset the config to LAPIS_BLOCK. Here is a list of what can be used as BlockType:


    The ShowErrors decide wether or not there will be an error message shown if the user doesn't have the permission. I suggest to take the standard-settings, so your users can still use PressurePorts as regular Pressure Plates without being annoyd.

    Permission Nodes:
    I am now using the modern technology "permissions". Every player in the ops.txt can still perform every action, everybody else can be edited using the following permission nodes:

    PressurePort.Use - Wether or not the player might use PressurePorts.
    PressurePort.Break - The user can Break PressurePorts.
    PressurePort.Build - The user can build and set PressurePorts.
    Since this is my first work with permissions and i felt a little bit lost during the process there might be bugs. I tested everthing that came to my mind and it all worked, but maybe you find something that shouldn't happen. Please excuse and report those bugs!

    Version 1.3
    • Fixed a bug where PlateType: WOOD_PLATE would be treated as illegal config.
    • Fixed a bug where entering anything than a legit Material would crash the plugin
    • Fixed a bug where not using Permissions would crash the plugin.
    Version 1.2
    • Fixed a bug when that crashed the plugin when creating the config-file
    • Added support to warp mobs :D
    Version 1.1
    • Fixed a bug where people with PressurePort.Build couldn't use the command.
    • Fixed a bug where placing an illegal material in the config crashed the plugin.
    Version 1.05
    • Added configuration file
    • Added permission support
    • Added Multiworld support
    Version 1.0
    • Release, yeah!
    To come:
    • different store format
    • use exisiting warps from various warp-plugins as target
    • iConomy-Support (working on this)
    • Warp Minecarts & Mobs.
    • your suggestion here
    Known Problems:

    • When creating some plates in row, where you get ported from 1 to 2 to 3 and so on you might get kicked because of flying.
    • Sometimes, when warping away, the plate stays pressed. For me, this seems to be lagrelated, but i'm not sure.
    Support me:
    I am looking for the storeage-files for the following warp-plugins:
    • Warpz0r
    • Essentials Warp
    If you use one of them, please upload the file somewhere and message me or write in the thread. Also, if i'm missing some important warp-plugins, feel free to tell me!

    (BIG thanks to my awesome mate 4treyu who wasn't annoyed by my ton of java-related questions :D and to Leonlas for the idea)
    Leavy, MrTofuhero and kahlilnc like this.
  2. Offline


    I love this plugin and my server is full of them everywhere, but I hate using permissions. I downloaded the Op-fix one and it still says 'you are not allowed to use pressure ports' when i stand on them
  3. Offline


    I seem to be having a problem with mine, I put the lapis and pressure plate, it says go to location and type /ppset, i do this and it then says pp stored but when i stand on plate nothing happens. Has anyone else had this problem? And if so a fix?
  4. Offline


    I have this same issue, i dont have a fix. i was hoping someone would and also, when i don't have permissions set i get "You are not allowed to use PressurePorts" and i am Op... and when i set the Permission: Op i dont get any error message, it just doesn't work. Help please! I really want to use this plugin because it sounds cool and I have a lot of ideas for it.
  5. Offline


    Same issue, use Permissions 2.x. And tried the Op thing.

    Get "You are not allowed to use PressurePorts". Too. Fix? Come on. I really want this in my server...
  6. Offline

    James Smith

    Ok just done a quick test on my test server and i place the lapis and the plate walk somewhere and did /ppset all messages showed everything to be ok but nothing happens when i step on the plate....

    However if you place the lapis and the plate it will ask you to walk somewhere and type the command, Don't do this, walk onto the pressure plate first then walk\warp to wherever you need the destination to be and it will work. For me it did bukkit version 860, I can repeat this as many times as i want and its the same every time, I have to basically step on the plate first before i go to my destination and type /ppset, Hope this helps others who are having the same problem.

    Also what is the best way to get rid of that annoying moved wrongly message.

    Ok so I have been testing this on my live server and had the same problem all messages showed everything was ok but nothing happend when I stepped on the plate, I enabled error message and it said I didn't have permission to use the portal. Soooo I checked out what was the difference between my local server and my live server.

    Turns out it was the essentials plugin (specifically the group manager module), I never thought to change the world name or remove the lines related to the worlds, Once I had done this everything started working as advertised, Just another solution to someones problems. Still have to step on plate first on local server don't know why yet though.

    I also enabled flight through my servers admin panel and I still get the wrongly moved, Anyway to stop this. I don't get booted but I don't like warnings and errors in my logs.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  7. Offline


    Having the same issue as most people.

    My users get the "You don't have permission to use this" message, but its not defaulted to ops only. Its working for admins with all permissions or '*'. So i'm not sure what the problem is. EVERYONE has the PressurePort.use node. So unless theres another node that i'm not aware of. This dosen't make any sense.

    I am an op and admin on the server...So I can use them, but my other admin can use it and he's not an op.

    It looks as if the author of this plugin has given up on the thread. I really hope to use this again. I've completely designed our world around these pressure ports. Please help :(
  8. Offline


    Hey im still having problems wit the Plugin. I do everything that im supposed to do but when i try to use the tele pad it teleports me 1 or 2 blocks away. Everything is running like it should and this plugin sounds really cool so could you please try to fix this. Thanks.
  9. Offline


    Where are you standing when you type /ppset ? Sorry if I'm stating the obvious, but you have to stand at the point you want it to teleport to before you type that.
  10. Offline


    Well i went somewhere other than 1 to 2 blocks from the pressure plate and type in the command but the same thing still happens and its kinda anyyoing because this looks like a really cool plugins. I just want someone to figure out why this is happening so i can use it!
  11. Offline


    If you didn't break and replace the pressure plate first, typing /ppset doesn't do anything. It only works on the last plate you placed, and only works the first time you type it after placing a plate.
  12. Offline


    Yeah well i placed a plate and tried to do /ppset before breaking it and trying again but it just wont work! I placed the Lapis Block and then the pressure plate and then i went somewhere else and tried the command but the same thing happened. I just want to be able to use this plugin!
  13. Offline


    Does this work on the newest RB
  14. Offline


    wtf you can try and see the result ?? yes with work well here im using craftbukkit 956
  15. Offline


    What do you do when you step on the pressure plate but it doesnt tp you to the place????
  16. Offline


    permission problem ?
  17. Offline


    Ok, i am having a problem which doesnt at all make sense to me.
    i do everything, place lapiz block, put pressure plate, it gives me the correct message,
    i walk somewhere and do /ppset, it gives me correct message,
    but when i go to walk back on the plate, it doesnt do anything, Help?
    i am currently running bukkit ver for 1.7.2
  18. Offline


    Using /ppset multiple times on one pressure plate will create a randomized warp. Going through will send you randomly to one of the set locations.

    Or does it already do that? I haven't actually put the plugin on my server yet since I'm not at home.
  19. Offline


    This is probably the bug everyone else is experiencing who doesn't use Permissions. The solution, according to other posts above, is to start using Permissions. I don't personally know that this works, because I have no other use for Permissions, so I won't install it.
    The programmer hasn't been active here for a while, so who knows when this will be fixed. He mentioned real life obligations he had to attend to and disappeared right after releasing the bugged version.

    Edit: If you are using Permissions, and still have this problem, then I have no idea.
  20. Offline


    This was an awesome plugin WHEN IT WAS UPDATED. Does anyone know if it works with CB Build 1000?
  21. Offline


    Hi, I am having trouble with this plugin and would really appreciate some help. I am new to craftbukkit and dont know much about coding.

    My problem is that (i think) when I try to use a pressure plate, it tells me that I don't have permission to use the plate. I have no idea why however, seeing as I run the server and I am listed in the ops.txt and can use all other op commands. There is nothing in my permissions.yml, as I haven't got a clue how to even code it. I don't think I have any permissions plugins either, but when I first started the server it created a permissions.yml.

    As of now, when I start the server it gives me no errors and says "PressurePorts has been activated Permission system not detected, defaulting to OP"

    Shouldn't that mean i should be able to use the ports since I am indeed an OP? Is there another command I need to use to enable use of the ports? Btw I changed nothing in the config.yml that was created in the PressurePorts folder.
  22. Offline


    why is it that only ops can use the pressure ports is there any way to change so all players can use them?
  23. Offline


    hmm i'm put plessure plate on lapis block go to my shop type /ppset go back on plessure and nothing...
    Maybe Help ?!

    damm i'm just seen that cow teleport and to my don't work wtf ?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  24. Offline


    Essentials Warp File Format

    yaw: -269.5508(idk)
    name: <warp name>
    pitch: 6.4499984 (idk)
    z: <z position>
    y: <y position>
    world: <name of world>
    x: <x position>

    Attached Files:

  25. Offline


    Is this plugin working with Craftbukkit build `1000?? I've tried it and get the registered message and /ppset works but port does nothing, enabling error messages show im not permitted to use ports but im in ops.txt. Not sure what else to do but love the idea of this plugin. Any help will be appreciated!
  26. Offline


    I've seen a server with Build 1000 running this, however I'm having trouble with it myself. Also Permissions isn't working for me either -.-
  27. Offline


    Works perfect for me on CraftBukkit 1000, using PEX with the nodes and its perfect :) Couldn't be any better,Thanks.
  28. Offline



    I'm using permissions 2.7.4, pressure ports plugin is detecting permissions but it doesn't allow players to use it despite added "PressurePort.Use" entry.

    Easy question: why?
  29. Offline


    Please update this for bukit build 1000
  30. Offline


    Since I've seen mixed results with build 1000 I decided to give it a go despite it not having been updated yet, and sadly it didn't work for me. It just won't recognize the command, and if there is a folder with the config to be created normally, it's not doing that either. :(

    This seem to be the perfect teleportation system for my server though, as the old /warp commands are getting very stale right now :p
    So it'd be awesome if you could update this to work with build 1000 or even 1060 as people will likely start updating their bukkit to that soon.
  31. Offline


    Yes, I agree. PLEASE update this to 1060 or 1000 at least. I love this plugin, but i've started to notice sometimes it crashes my server... :'(

Share This Page