[INACTIVE][FUN] LazyRoad v0.6.2 - Make roads - GUI EDITOR [860-1085]

Discussion in 'Inactive/Unsupported Plugins' started by adreide, Jun 9, 2011.

  1. Offline


  2. Offline


    For starters you have no idea of my experience regarding anything at all so dont make presumptuous remarks based on your own limited knowledge. What I am facing is Directly related to your plugin and to be more to the Point for you to understand, My Admins can use lazyroads and I can due to the - * permission, I use group manager with a perm bridge to organise my permissions,
    Problem Description: Players not being able to use lazyroads with the permissions in their respective alottments Plugin version: 0.5.2 Bukkit version: 1000 Repeatable Problem: Yes/No Plugin List:Admcmd,chesscraft, choptree, Citizens, Clothcolor, Creative build,
    dynmap, Essentials, essentialsgroupbridge, essentials groupmanager, falsebook
    herobounty, iConomy, iConomychestshop, Jobs, Kiwiadmin, Labyrinth, Living forest, LWC
    Minebackup, Mob bounty, Mob arena, Mob rider, Mulitinv, Nocheat, NSCommand, Portalstick, pvparena
    Questioner, Simplegive, Simpletime, Spout, Supernaturalplayers, Towny, Worldedit, Worldguard
    , I Know how to run set up config and modify servers mate, I had quoted Tubbytub's post because my players get the same error message. My Permissions are working fine, I have approx 20-30 plugins 10-20 players on at any given time, ALL other plugins are working fine except yours ONLY, I and my admins can use it therefore by process of elimination ie; no error logs in my server log and your Perm being the only one in about 50 not working I would say it is on your end friend and have asked as such if you support Groupmanager? as I use this. If you do not support this I have no choice but to remove it, but I do not care for in the way in which you addressed my concern. How old are you ? how much experience do you have? Do you know how to setup and run a server? you are by far the most obnoxious and arrogant son of a female dog I have come across on bukkit to date in fact you would have to be the only one so far! You answer maybe 1 in 20 Questions and when someone has a genuine need for help you ignore them, I have read ALL the posts on your plugin so far and so far I am pretty much the only one to use your error report template.

    So just answer the question I first asked, Do you suport group manager or do you intend to?
  3. Offline


    It doesn't change the fact that it isn't a bug from LazyRoad. As I previously stated, use LazyRoad 0.5.1 for Permissions 2.x / 3.x. LazyRoad 0.5.2 uses bukkit new permission API only. A support for the old permissions was asked and debated before with @ledhead900 , it will be added back in the new 0.6 release and is in the to-do list.

    All the answers of what you need lies in those previous statements. GroupManager fakes Permission 2.x/3.x with the "bridge". It's written in the Essentials Wiki.

    I assume that people using plugins do know a little about permissions. There is actually two widely used systems which are the old "Permissions" system and the new bukkit built-in API. I'm supporting them in separate releases.

    So, yes I do make presumptuous remarks. Having someone poking me about permissions after I replied to all the permissions questions, I assumed you were a casual admin. But come on, insulting me after I just teased you for your minecraft bukkit admin skills? We may have both had a bad day, treating me as arrogant, ok, I was back there, no problem, but keeping it up insulting me etc, what's your point?
  4. Offline


    Best plugin ever and with the Designer I made custom roads so I could make lage buildings, railroads systems and many more in no time. Thank you for this plugin!!!
  5. Offline


    I know about the new bukkit builtin-API yes we may have both had a bad day as to my retaliation to an insult dont try and cover the fact about TEASING, you insulted my intellegnece and then pretty much told me to f**k off! I understand your frustration at possibly having to answer the same question over and over again, but its also my right as an Admin/player to want to use whatever plugins I choose too, Thank you for Finally answering the question I had originaly posed about other permission systems, thats all I asked for in the beginning, I will await the next release before I implement it. I apologize for calling you the son of a female dog but dont insult people to begin with.
  6. My roads won't save. i choose the directory and don't make a name for it but it won't show up in the place i saved it.
  7. Offline


    You should make a feature that protects the roads
  8. Offline


    @NeilZar humm have you tried saving in a directory other than the default one? Looking at the code, if it doesn't show any error message then either you have no road either it is an issue not handled. To minimize the problems with the save dialog in which you don't have to put a name, I made it so that if you don't select a correct folder it will switch to the default parent folder. Have you checked the parent folder and the writing rights? By this I mean if you are saving in D:\bukkitServer\plugins\LazyRoad\roads try and look at D:\bukkitServer\plugins\LazyRoad
    The saving thing should really work, or at least give you an error message. If it still doesn't work could you contact me so that this issue is resolved?

    Thanks for reporting

    @YellowFellow it's in the to-do list, it will take a while to complete as I don't have much time.
  9. Offline


    hey i need some help it says i dont have permissions why is that
  10. Offline


    pwsmooth1 likes this.
  11. Offline


    hey thanks fixed my problem just had 0.5.2 when i need 0.5.1 thanks
  12. Offline


    Well WHERE are the friggn Permissions @...
    wna copy em into ma folder

    Sorted! works a treat! :D Superb Plugin thanks alot. yay got for walks n road build@same time hahaha no more messing bnt :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  13. Offline


    Problem Description:
    Bridges arnt being built right atleast not the pillars, i set it up so that the pillars made and arc like an upside down U but kind of more spaced out, then in game it made it just ||___||___||__||
    Console Spam:
    None Tbh really
    Plugin version:
    0.5.2 Bukkit version:
    1000 Repeatable Problem: Yes

    Only thing i can see doing this is like.. voxelsniper or worldedit\guard.
    Show Spoiler
  14. Offline


    @tommygoesha in the editor, you have to set the "Max blocks to build" value to 1,2,3,etc. Open Classic5 template to get an idea. If that doesn't resolve your issue, upload your template and I'll correct that bug, be it in the template or the plugin itself.
  15. Offline


    I Love the Editor but i Can't Edit the Stairs :( .
    So That's my Suggestion for the Editor.
  16. Offline


    could you please make it work with groupmanager.
  17. Offline


    Hey, just installed this on a server...none of the standard road types seen in the videos (eg simple5) seem to exist. Solutions?
  18. Offline


    Before I updated, it used to be that the road simply stayed on the ground and only cut through if it needed to, when going up. Also, it stayed ontop of the water, and didn't go down to the very bottom.

    Why is this, and can it be changed?

    IN the air, keep the road building on the ground, and on the water, keep it on the water

    Don't know if this would be a lot of work or not..
  19. Offline


    love the plugin, but whenever I use the designer to create a road I can't seem to be able to save them. I dont enter a file name, just a directory, and they never get saved. Thanks in advance
  20. Offline


    Im getting an error with a stairs it just built with the Editor. This is what I get in Console (not full error since it doesn't give me):
    2011-08-21 17:27:12 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'road' in plugin LazyRoad v0.6.0 beta
    Caused by: java.lang.ArithmeticException: / by zero
    This is the file which I made: http://dl.dropbox.com/u/7365249/stairs.ser
  21. Offline


    I'm using 1060 and tried all versions and it doesn't work, please update this.
  22. Offline

    giggity gooo

    i cant build any bridges at all:(:(:(:(:( it just doesnt do anything at all!!!
  23. Offline


    Yeah I hope he updates. :(

    Are you going to fix/update this?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  24. Offline


    I just read the posts, I will look into all the bugs you have encountered.

    @CheaaMac GroupManager, it won't be supported, try the Essentials GroupManager bridge and lazyroad 0.5.1, that should do the trick. You have to wait till I put back the old Permissions support in the beta version.

    @Londogne copy all the zip contents

    @Sethimine LazyRoad builds throw the water so that you can make water tunnels easily. You can simply go with the /tunnel or /bridge command to make roads on top of the water like you used to make.

    @Lolmewn Could you send me your template file? Thanks

    @Stephen92 I haven't tried on bukkit 1060 yet but should work since there is no changes on the API that lazyroad uses. I'll try it, but in the meantime, you can check your configuration.
  25. Offline


    Which one do you mean, the dropbox one I linked?
  26. Offline


    Oh, thanks I didn't see the link ;)
  27. Offline


    tried it and it doesnt work, my config is fine.
  28. Offline



    works for bukkit 1060, personally tested. You're doing something wrong.
  29. Offline


    hmm paste ur config
  30. Offline


    Adreide, Thanks for work and effort you've put into this plugin.

    You have appealed to my inner lazy builder.

    So far, I've created Lazy roads, bridges, tunnels, walls, roofs, floors, fences, torches, canals, and a huge block of air i use to clear the land. Took me about a day to build a 4 km Lazy road/minecart tracks to the Lazy Metropolis i'm creating, so this plugin works like it's supposed to for me.

    I like creating with the GUI, but I'd like it if I could create a road in game though. Through a series of questions maybe, and then a command to repeat the creation.
    Would need less files in the help pages that way. I've filled up my help pages with files and i have a notepad beside me now to keep track of file names.

    A way to pause the road as you build would be nice, sometimes I need to look behind me to see how i'm doing and then i have to /road stop.

    Keep up the good work. [gold]
  31. Here is a Underground Design :)

    Attached Files:

Share This Page