[INACTIVE][FUN/ADMIN] WeatherMan 6 - Control the weather! [740]

Discussion in 'Inactive/Unsupported Plugins' started by RightLegRed, Apr 22, 2011.

  1. Offline

    Archelaus

    Weather Man
    Want to control the weather? Now you can! Become a weather man with this plugin. You can set it to rain on, or off. You can clear snow and even strike people with lightening!​
    Commands​
    /weather rain <time>​
    /weather thunder <true|false>​
    /weather thunder <playername>​
    /weather clear​
    /weather rain - doesn't need a time, without it, it makes it rain for a default set time.​
    Permissions​
    weatherman.clear​
    weatherman.rain​
    weatherman.thunder​
    ChangeLog​
    Version 1 - Released!​
    Version 2 - Added ability to set rain time!​
    Version 3 - Added turning off lightning!​
    Version 4 - Removed reach of lightning!​
    Version 5 - fixed up the commands a bit.​
    Version 6 - now has the command /weather thunder <playername>






    Supports Multiworlds, Permissions and each feature is seperated. So your players can clear the rain while you fry sheep!​
    Requires Build 709!​
    I hate to do this, but I'm running out of money and this keeps me interested in developing this plugin. Donators may have their name published to the thread if they please.​
    [​IMG]
     
    Me4502, Netto Hikari, Mazer and 8 others like this.
  2. Offline

    Archelaus

    Forgot to press upload. Try again
     
  3. Offline

    panderiz

    I get the following when trying to do any commands except /weather

    I've redownloaded the plugin and CB 709 but still not such luck. Not using permissions, though it's saying it's default to OPs(which I'm in op.txt)
    Code:
    14:29:24 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'weather' in plugin WeatherMan v4
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:650)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:613)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:607)
        at net.minecraft.server.Packet3Chat.a(SourceFile:36)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:73)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler
        at com.rightlegred.weatherman.commands.ControlWeatherCommand.execute(ControlWeatherCommand.java:33)
        at com.rightlegred.weatherman.commands.CommandManager.dispatch(CommandManager.java:47)
        at com.rightlegred.weatherman.WeatherMan.onCommand(WeatherMan.java:44)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
    Caused by: java.lang.ClassNotFoundException: com.nijiko.permissions.PermissionHandler
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:264)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:332)
        ... 16 more
    
     
  4. Offline

    tiltomat

    awesome. workin!
     
  5. Offline

    Fetzz

    Exactly the same :(
     
  6. Offline

    Archelaus

    Are you using group manager or that essentials permissions thing?
     
  7. Offline

    CasioBeatz

    Hey there, I got the weather plugin fixed :)
    in the admins.txt u need to set
    user:admin
    user:admins
    and in permissions Admins:
    .
    .
    .Permissions: weather.*
    .
    .
    ..
    .
    .
    12132: admins
    .
    .
    .
    permissions: "weather.*"

    hope that helps! :D

    //EDIT:

    My permissions in detail:

    Code:
    # System is no longer used, but may become used in the future
    
    # Copies is for multiple-world support
    
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    
    #   If this file is for your default world (the one in server.properties) then you must
    
    #   leave copies blank.
    
    #  Example: copies: Derp    -  This will clone the permissions of the world Derp
    
    #
    
    # Make sure to rename this file to the name of the world that is in sever.properties under
    
    # level-name.  So if it is level-name: world  then this should be world.yml and in the
    
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    
    #
    
    # NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
    
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
    
    plugin:
    
        permissions:
    
            system: default
    
            copies:
    
    
    
    ##
    
    # AntiBuild is included with this.  To disable a group from being able to build then
    
    # set the build: flag to false (build: false).  If you want a group to be able to build
    
    # then set it to true.
    
    ##
    
    # Groups can contain inheritance.
    
    #   To make a group inherit the permissions from another
    
    #   group simply place the groups name in the "inheritance:" like so:
    
    #
    
    #   Example:
    
    #       inheritance:
    
    #           - Default
    
    ##
    
    #   All permissions including the asterisks must be placed in single quotes.
    
    #   like so:
    
    #
    
    #       - 'foo.bar'
    
    #
    
    #   Otherwise errors will happen!
    
    ##
    
    #   Globalized Permission settings:
    
    #
    
    #       If a permission contains periods (.) you can denote a globalized parameter:
    
    #
    
    #           - 'foo.*'
    
    #
    
    #       This will allow you to use all general commands.
    
    #
    
    ##
    
    #   Single Asterisk denotes all commands:
    
    #
    
    #       - '*'
    
    #   If you give a group this permissions, do not have the group inherit any permissions
    
    #   from other groups.  Any users assigned to this group should NOT be given any additional
    
    #   permissions either.
    
    ##
    
    #   To exempt a node use the - prefix like so:
    
    #       - '-foo.bar'
    
    ##
    
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    
    #   such as iChat or HeroChat in order for these to do anything.
    
    groups:
    
        Default:
    
            default: true
    
            info:
    
                prefix: ''
    
                suffix: ''
    
                build: true
    
            inheritance:
    
            permissions:
    
                - 'foo.bar'
    
        Moderator:
    
            default: false
    
            info:
    
                prefix: ''
    
                suffix: ''
    
                build: true
    
            inheritance:
    
                - Default
    
            permissions:
    
                - 'bar.foo'
    
        Admins:
    
            default: false
    
            info:
    
                prefix: ''
    
                suffix: ''
    
                build: true
    
            inheritance:
    
            permissions:
    
                - 'weather.*'
    
                - 'SuperBow.*'
    
    
    
    ##
    
    # Users denote which users are included in which group.
    
    # TheNo1Yeti is in the Admin group
    
    # Herpina is a member of the Moderator group but also has access
    
    # to the herp.derp permissions
    
    # Derpina is a member of the admin group but does not have access
    
    # to the derp.derp permission node
    
    # Users can also have a prefix and suffix as seen with Herpina
    
    ##
    
    users:
    
        CasioBeatz:
    
            group: Admins
    
            permissions:
    
                - 'weather.*'
    
                - 'Superbow.*'
    and the users.txt:

    Code:
    casiobeatz:admins
    I hope I get some diamonds :p

    Greez
     
  8. Offline

    dcgamingentral

    I get this when i type and /weather [weather] command
    im running cb709

    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:650)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:613)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:607)
    at net.minecraft.server.Packet3Chat.a(SourceFile:36)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:73)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
    at com.rightlegred.weatherman.commands.ControlWeatherCommand.execute(ControlWeatherCommand.java:36)
    at com.rightlegred.weatherman.commands.CommandManager.dispatch(CommandManager.java:47)
    at com.rightlegred.weatherman.WeatherMan.onCommand(WeatherMan.java:44)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more
     
  9. Offline

    Nate204

    The same:
    I just updated and I still receive this error:

    I'm using Permissions 2.7 and a whole plethora of plugins.
    Again, still in the OP folder. I honestly just uploaded the plugin, reloaded them and tried it. This is the ereor I get.
     
  10. Offline

    Fetzz

    Ok it works now, plugins permissions was deleted :D
    Thx guy for this plugin it's awesome.

    Edit : It works only for clear, i just needed this.
     
  11. Offline

    poop anybody

    I need help I downloaded 709 and when I do "/weather rain" nothing happens and I'm the owner of my server.
     
  12. Offline

    Archelaus

    weather rain 900
     
  13. Offline

    swedish2011

    You can do that it's snowing?

    /weather thunder /p test

    /wtp test

    [nick] test

    :D
     
  14. Offline

    jeffreylec

    This is exactly what I wanted to see in the new update! This is awesome! Thanks :D
     
  15. Offline

    panderiz

    I'm not using any. I thought it defaulted to ops.txt I will try permissions right now. Though on my actual server we use groupmanager(essentials branch)

    Using both permissions and the essentials groupmanager both give me the same error
     
  16. Offline

    PhantomGamers

    Does the Bukkit version have snow at all? Or is it there, and just not trigger-able via the API?
     
  17. Offline

    swedish2011

    thunder

    can you do to the smash things with? and fire on the :D
     
  18. Offline

    Nate204

    I feel like an idiot.... Sorry about the errors. I didn't think I had to type /weather rain xxxx <--time.
    You rock! Keep it up!
     
  19. Offline

    poop anybody

    Thank you, I got it working now.
    Hopefully, you get thunder working. :)
     
  20. Offline

    game_stailer94

    can you made that the weather is full turned off ??
    because I dont need the weather and it Destroyed my Pixelart map -.-
     
  21. Offline

    firefly_goat

    Why would you install this when CB to 1.5/1.5_01 aren't released ?!
     
  22. Offline

    kullon

    I get the same errors
     
  23. Offline

    vcazan

    So we can debug it so that when CB 1.5 is ready this will be too.
     
  24. Offline

    JayNike

    It still doesn't work! It says: An Internal error occured while doing this command :/.

    Please help me what have i do to do?
     
  25. Offline

    FIX94

    I now updated to v4 and now it works fine without errors :)
     
  26. Offline

    tiltomat

    confirm, if you use thunder on pigs you'll create two "ghosts" pigmens each pig.
     
  27. Offline

    PhantomGamers

    Just bumping this question to page 7.
    I'd like to know, because I haven't seen snow on my server at all.
    Not even in vanilla, and I stood in a snow biome for the entire IRL day.
    Just a ton of rain :\
     
  28. Offline

    Snowybearr

    Just gives me internal error, however I dont completely understand the point of doing permissions this early on, seeing as permissions wont update till RB..

    I think thats why this wont work for me, because I dont have permissions, which is screwing a lot of my plugins right now.
     
  29. Offline

    Gicon

    Thanks for the plugin.. working great! Too bad it seems the majority of these people just can't read and follow directions.. I see page after page of the same questions comments that have been answered at LEAST 10 times a piece. :/
     
  30. Offline

    Sabinno

    This plugin has no use currently.
    The commands, all except the help, bring up an Internal Server Error.
    This is not related to conflicts, as it is currently the only plugin installed on my server.
    I've singled it down by uninstalling all the others.
    So, sould you PLEASE fix this issue?
    Thanks in advance!
    -Sabinno-
     
  31. Offline

    massEntropy

    This has to be one of the funnest plugins ever. I feel like Thor! I should change my skin.

    Thanks.
     

Share This Page