[INACTIVE][EDIT] ChunkRegenerate v1.1 - Regenerate a chunk! [860]

Discussion in 'Inactive/Unsupported Plugins' started by robin0van0der0v, Apr 4, 2011.

  1. Offline


    ChunkRegenerate - Regenerate a chunk!
    Version: v1.1

    • Regenerate a chunk at the player.
    • Regenerate a chunk at the specified coordinates.

    Download ChunkRegenerate!
    Source is inside the jar file.

    How to use:
    If you want to regenerate the chunk you are standing use "/chunkregenerate" (or "/cr")
    and if you want to regenerate a chunk on a position use "/chunkregenerate x z"
    /chunkregenerate - Regenerates the chunk on your position.
    /chunkregenerate 37 -12 - Regenerates the chunk on 37,-12.
    /cr -61 -11 - Regenerates the chunk on -61,-11.

    Give the player you want this permissions for regenerating a chunk.
    Known bugs:
    None. :D

    Version 1.0
    • Release.
    Version 1.1
    • Added shortcut for the command.
    • Fixed Permissions.
    someguy817 and ksevelyar like this.
  2. Offline

    tha d0ctor

    sounds like it regenerated the chunk randomly into water...

    does this plugin fix the errors Crunk 0,1 found at 1,5 or whatever...?
  3. Offline


    I'm not sure what you are asking, but I thought this was supposed to regenerate the world back to the way it started?
  4. Offline


    Did you replaced your "level.dat" file?
  5. download link broken?
  6. Offline


    Fixed, I had a power outage. :)
  7. Offline


    @robin0van0der0v : I'm getting faulty chunks restored with this too. And undo would be really nice.
  8. Offline


    Did you touched your "level.dat" file?
    And i'm trying to add a undo command. ;)
  9. Offline


    Could it be because I use Backpack and have used it? It also touches level.dat.
  10. Offline


    Yea, my last one got corrupted due to the server crashing while some chunks weren't fully loaded. It ended up taking entire chunks out of our world, and I had to replace the level.dat to stop it from continuing to do so. I was hoping to use this to repair the damage done by the corruption, but I accidentally hit an area that was still good and this mod got rid of all the land.

    Also, the fact that I have to be standing in the chunk that is getting regenerated has caused me to die due to the sudden changes. I know we can use the coordinates, but I have to know the coordinates first. And guessing which way it moves is what caused the accidental usage on chunks that I didn't want to use it on.
  11. Offline


    It could be Backpack, try to restore your old "level.dat" from a backup. ;)
  12. Offline


    Could you make it work in harmony with Backpack them with @Afforess ?
  13. Offline


    Backpack does not touch the level.dat. It does, however, alter how the player.dat saves for each player.
  14. Offline


    Ah, my bad, I knew it wouldn't touch level but player instead. :p
  15. Offline


    This mod is very useful thank you. Makes cleaning up messy builds a snap.

    It can be funky with trees that are on the edge of a chunk.
  16. Offline


    Can you add /undo on your plugin ???
  17. Offline


    Sounds really useful, but it looks like the download link is broken...
  18. Offline


    I'm adding it. ;)

    Fixed. :)
  19. Offline


    Thanks for the re-up; tried it and works wonderfully. Big props!
  20. Offline


    It is useful, but limited to the one chunk per command issuance. Can you add functionality for an area regenerate? That would be extremely useful.

    Thank you very much.
  21. Offline


    I would like it shortened down, please. Typing it all out takes a while. Maybe make it /cr?
  22. Offline


    I second, or 20th this. :)
    L24D likes this.
  23. Offline


    Hmm, just in case you didn't know about this, there's a major bug... anyone can use this regardless of permissions.
    i found that out while i was messing around on one of my test accounts on my server. (with no perms for him)
  24. Offline


    very great plugin!
    but l24d say it... anyone can use the command :(

    hope you can fix it or make a op only version :)
  25. Offline


    Would be very good to have a undo command and even a selection command so you can select wherre you want to regenerate :p apart from that...Very good plugin...my server crashed and i got random towers (vortexs) all over my world, this fixed them no problem... THANKYOU :D
  26. Offline


    Added shortcut for command and fixed the Permissions. :)
  27. Offline



    This plugin seems really useful. Just tried to give it a shot to fix some unmatching terrain (also not sure how that happened, noticed it near the world edge recently) but the regenerated surface doesn't match the original terrain. You mentioned something about the level.dat file - I have never modified it directly (could something else have?). Here is the server start-up screen to see what else is running. Thanks

    146 recipes
    16 achievements
    16:41:16 [INFO] Starting minecraft server version Beta 1.5_02
    16:41:16 [INFO] Loading properties
    16:41:16 [INFO] Starting Minecraft server on *:25565
    16:41:16 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-
    gf3ae4c3-b733jnks (MC: 1.5_02)
    16:41:16 [INFO] Preparing level "World5"
    16:41:16 [INFO] Preparing start region
    16:41:17 [INFO] Preparing spawn area: 77%
    16:41:17 [INFO] [Permissions] (Phoenix) was Initialized.
    16:41:17 [INFO] ChunkRegenerate version 1.1 is enabled with permissions!
    16:41:17 [INFO] [EasyFlight] version [0.2] is Enabled.
    16:41:17 [INFO] [LightLevel] using Permissions 2.7
    16:41:17 [INFO] [LightLevel] - Version 0.1 Enabled
    16:41:18 [INFO] [MYHOME]: 7 homes loaded
    16:41:18 [INFO] [MYHOME] Permissions enabled using: Permissions v2.7
    16:41:18 [WARNING] [MYHOME] 'Help' isn't detected. No /help support.
    16:41:18 [INFO] [MYHOME] MyHome 1.9.4 enabled
    16:41:18 [INFO] [MYWARP]: 47 warps loaded
    16:41:18 [INFO] [MYWARP] Permissions enabled using: Permissions v2.7
    16:41:18 [WARNING] [MYWARP] 'Help' isn't detected. No /help support.
    16:41:18 [INFO] MyWarp 1.10.5c enabled
    16:41:18 [INFO] Nether v1.1 enabled
    16:41:18 [INFO] nSpleef version 0.3.1 is enabled!
    16:41:18 [INFO] [Permissions] version [2.7] (Phoenix) loaded
    16:41:18 [INFO] [General] version [2.2.5] (Chernobyl) loaded
    16:41:18 [INFO] [General] hooked into Permissions.
    16:41:18 [INFO] Done (0.167s)! For help, type "help" or "?"
    16:44:24 [INFO] kythoon [/] logged in with entity id 35
  28. Offline


    link not work can't download :(

    someone can rehost it?
  29. Offline


    link doesnt work?!
  30. Offline


    Download link redirects to LAN ip
  31. Offline


    fix the link plix plox.

Share This Page