[INACTIVE][ADMN] Wandmin v0.35 - Easy command use [602-677]

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Jan 24, 2011.

  1. Offline


    Wandmin - Easy command use, with a "magic" wand

    The Wandmin plugin lets you bind any command to your wand. You can create multiple wands to create things organized.

    Grab elBukkit.zip to get all of my plugins- take out the ones you don't want.

    For more details on Wandmin, or for individual jar downloads, see the Wandmin wiki.

    If you really love this stuff, and you're feeling generous, I'd more than appreciate a donation.

    Go here if you're interested!

    View changelog on github
    Miome, Shadus, wOur and 1 other person like this.
  2. Offline


    Great job NathanWolf. You're doing a fantastic work for this community!

  3. Offline


    You would have to set yourself up in wand.properties' deny list and then wandmin's allow list.

    I think both of those plugins are still using their own "built-in" permissions for now, but eventually this would all be integrated into bukkit permissions profiles- so you could set up wand and wandmin profiles separately, for instance.
    --- merged: Feb 24, 2011 3:41 AM ---
    Thank you very much! [sheep]
    --- merged: Feb 24, 2011 3:42 AM ---
    Yeaahh... I never did get around to reproducing and fixing this :) I should add it to my issue tracker...
  4. Offline


    Odd, I do the command for making a new wand and nothing happens.

  5. Offline


    I'll take a look at this- I'm getting across-the-board reports on all my plugins that none of the console commands work :p
  6. Offline


    Very nice mod, just that i don't know how to use it :)
    Can someone PM me about it? :D
  7. Offline


    Well, it may be broken right now, but I doubt it since I'm not using permissions here at all :)

    I still haven't had time to test it out, but this should get you going:

    /wandmin create mywand
    /wandmin bind home
    That should make you a wand with one command. Swing your wand to go home, assuming you have a plugin that does that :)
  8. Offline


    I got it working but is it supposed to be that you have to create a stick, create a wand and to use it left click with that stick? I thought creating a wand would bind that one stick to that wand so you can have one stick in your quickbar that is for combat and one for mining... Having to type /wandmin next gets annoying.
  9. Offline


    Once you bind commands to your wand, their bound forever- not sure if that's what you're asking?

    The stick is not your wand, that's just an icon, a tool, an item, etc. A "wand" is a virtual grouping of commands.

    You can have any number of wands, you can bind the "/wandmin next" command to each wand to switch between them easily.

    Once you have your wands set up, you should not have to use "/wandmin" again- or any other console command, for that matter, unless you need parameters- that's kind of the whole idea with Wandmin :)

    Here's an example if it's still not clear, using Spells:
    /wandmin create explore
    /wandmin bind cast blink
    /wandmin bind cast torch
    /wandmin bind wandmin next
    /wandmin create combat
    /wandmin bind cast arrow
    /wandmin bind cast fireball
    /wandmin bind wandmin next
    Yes, that's a lot of typing, but you only do it once.

    Now, you just use a stick. Left-click to use the current command (probably "wandmin next" if you followed what I did up there), and right-click to cycle commands.

    So, if you have the "explore" wand selected, right-clicking cycles between the blink and torch spells, as well as the "wandmin next" command, which you can use to switch to the "combat" wand.

    Hope that makes sense.
  10. Offline


    This doesn't seem to be working for me on build 493, I have Persistence installed and that's only just generated a file. There currently isn't a wandmin.properties file (it hasn't generated) so I've restarted the server a few times but still nothing. It also says that the plugin was loaded when booting up the server.
  11. Offline


    Hm- and you have 0.30? I did have to remove the old-style command support when they dropped it from bukkit, but otherwise it ought to be working.

    To be honest, I don't regularly test Wandmin since having Wand and Wandmin installed at the same time gets complicated. I'll take a look at it ASAP.
  12. Offline


    This plugin looks really awesome! But sadly, it doesn't work for me... I've downloaded Wandmin, Spells and Persistence. It should work, but when I try to wave my wand nothing happends, meanwhile in the console I get this error:

    17:54:04 [SEVERE] Could not pass event PLAYER_ITEM to Wandmin
    at com.elmakers.mine.bukkit.plugins.wandmin.WandminPlayerListener.onPlay
    at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.ja
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:457)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)

    I'm such a n00b at this.. xD
    Hope you could help me fix it! Thanks.

  13. Offline


    Hi! Sorry about that.

    I've had a couple of people report a similar-looking error (@Redbyte, in particular, is one who comes to mind)- and I have not been able to get them up and running, even by giving a zip of exactly what I'm running :(

    I'll take a look at Wandmin specifically soon- unfortunately I'm in the middle of refactoring it at the moment, so I can't really do much testing :(

    Anyway, point being there may be something wrong here that I just can't reproduce for some reason- so I doubt it is your noobness (necessarily) at work :D

    I'll get back in here as soon as I can- in the meantime, if you feel up for it, you can try fishing around in here:


    If you go back far enough in Spells and Wand/Wandmin, Persistence is not even required anymore, so this definitely won't be an issue there :)

    Also, the Wand plugin is really "better" for Spells- Wandmin is meant more for admin, not for use with Spells, necessarily.
    Oh, also, @Alex1756- could you please go to pastebin.com and paste your entire server.log (with the error in it), and come back here and paste the link?

    Since I can't reproduce this myself, that could help me quite a bit in tracking it down.
  14. Offline


    2011-03-15 07:56:42 [INFO] Loading wand-commands.txt
    2011-03-15 07:56:42 [SEVERE] Exception while reading wand-commands.txt
    at com.elmakers.mine.bukkit.plugins.wandmin.Wand.copyTo(Wand.java:26)
    at com.elmakers.mine.bukkit.plugins.wandmin.PlayerWandList.copyTo(PlayerWandList.java:21)
    at com.elmakers.mine.bukkit.plugins.wandmin.WandminPlugin.load(WandminPlugin.java:446)
    at com.elmakers.mine.bukkit.plugins.wandmin.WandminPlugin.onEnable(WandminPlugin.java:226)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:451)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:217)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:92)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:70)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-15 07:56:42 [INFO] Wandmin version 0.3 is enabled

    I have to type in the wands everytime again
    2011-03-15 07:56:42 [WARNING] Plugin: Wandmin does not support the onLoad() method
    Build: 554
  15. Offline


    Oops! Wandmin got axed!

    No, it's still very much in development- I just updated my thread title to match my other plugins, I'm currently testing on 527.

    Ok, I do need to look into Wandmin, since there have been bug reports... so I'm not going to throw a fuss about this until I've had a chance to do some testing :)
    Thank you for that! Let me look into it- that should definitely not happen, sorry.

    I'm going to have a new build of Wandmin up soon, which will use Persistence instead of a flatfile to store commands, to that would certainly at least change this problem, hopefully get rid of it :)
  16. Offline


    Hi, I am having a little trouble with wandmin.
    I made a wand with the name explore.
    Bound the cast blink and torch.
    But when I use them, nothing happens..
    Please help me!
  17. Offline


    Well, if you're using Spells you have to set up permissions to cast spells.

    To test out Wandmin, try binding a command that you know you can use- then we can talk about spells permissions in the Spells thread :)
  18. Offline


    Currently this loads cleanly (556) but doesn't seem to function fully for anyone who isn't an admin anymore (or at least doesn't work with permissions (Permissions 2.5.4) to control access correctly might be a better way to put it.)

    CraftBukkit 556, current plugins: Persistence, Permissions, CrowdControl, NetherGate, Wandmin, PermissionsSupport, Spells

    #Minecraft Properties File
    #Thu Mar 17 16:01:55 EDT 2011
            group: Builder
                - 'Spells.commands.spells'
                - 'Spells.cast.peek'
                - 'Spells.cast.blink'
                - 'Spells.cast.ascend'
                - 'Spells.cast.descend'
                - 'Spells.cast.recall'
                - 'Spells.cast.spawn'
                - 'Spells.cast.rewind'
                - 'Spells.cast.alter'
                - 'Spells.cast.day'
                - 'Spells.cast.night'
                - 'Spells.cast.tree'
                - 'Wandmin.commands.*'
    The testusr will be unable to access any wandmin commands. If I add them to the wand-users= field then they will have 'commands', 'spells', 'wands', and 'next'... but pretty much everything says create a wand first. Of course the admin user works fine completely side to side.
  19. Offline


    Ok- it's sad that I had to go look at the code to be sure, but the current version of Wandmin does not support Permissions- it's all done via the wand-users file. (And then Spells permissions would be done via Permissions)

    There are no pnodes associated with wandmin commands, I don't think- they just fail silently if you don't have permission to use wandmin.

    Oh, anyway- to complete this thought, the next version of Wandmin will support Permissions, and will no longer have a wand-users file. So, like the most recent Spells transition, you'll now have to use some sort of permissions- though I may just make it on by default, especially if Wand ends up being off by default. We'll see.

    At that point, as Spells becomes Magic, Wandmin will also become data-driven. So, the commands file will go away as well, and your wands will be stored in a database.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  20. Offline


    oh and can you add support for the http://forums.bukkit.org/threads/ad...keep-your-server-plugins-up-to-date-531.5026/ Plugin?
  21. Offline


    Wow, you guys are like all over the place spamming this plugin :)

    A plugin like that shouldn't need anything but a URL to stay up to date- I'm not going to change my plugins to use any other plugins anymore, frankly, unless it's functionality I actually want- and this isn't. Fill will do this when it's here.
  22. Offline


    Awesome as always!
  23. Offline


    Hi, i have been using your plugin for quite some time, and i have trouble with the "Fill" command, sometimes, when i first click on, For example, sand, and then somewhere else, it makes a Sand cube (depends on the dimensions) but sometimes, it gets replaced by air, and i dont know why Q.Q.

    The thing is, one of my moderators went Ragequitting and build some mountains of TNT.....At the spawnplace...
    How do i get fill to make air? I can find another plugin but i think it will come in handy in other situations as well. :D

    P.s. Love your Plugin :D
  24. Offline


    Hello! So, two questions, one answer :)

    There is a "material selection" system that may be "messing" with you :)

    In short, whatever material you have in the farthest-right active slot (inventory slot 9) will be used to build with. This includes air, so long as you've got one other building material in your inventory.

    For cleanup, btw, try recurse with air- will get rid of that TNT in a couple of clicks, hopefullly!
  25. Offline



    You reply fast :O (yay) ok, i figured out that i can change the material, after doing the first fill, then putting a block down, (in air-aiming soesnt work D:) and then the 2nd fill,

    And your idea is working! thanks very much :D

    i had another question, in the vid i can see that you get notifications by every single click you do, it may sound weird, but i like that, any way i can get that back on? :S
  26. Offline


    Glad I can help!

    That is probably some remnant of the old system- you don't actually have to place the block, just right-click while holding it (or punch for air). This system is going away in Magic, though! :)

    For sure! I just turned it off by default- check spells.properties, there are "silent" and "quiet" options- turn those both on and Spells will get very verbose (chatty) just like in the video :D

    Oh... and I think I've already removed "/spells reload", so you'll have to restart your server for those changes to take effect.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  27. Offline


    You mean set Silent and Quite to True? They already are, dont you mean false/off ? (quite was true, silent was false)

    No worries, i am the only player on my server (BOOHOO D: Forever alone)

    Yay Working, i get all the annoying messages, i like confirmation, i am quite the screw up.
    Btw, i am the only one on server because my friend got bored, i am making a city now, and then invite random people i never heard off, yay :D

    And for the next questions (srry D: ) can i remove spells from my wand, or do i have to make a new wand? (FOUND Unbind Commnd :D ) and is it possible to temporary disable activating spells? i have another plugin which requires me to both use the left and right mouse button while holding a stick, (again) this problem can be solved using another item, but can this happen anyway?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  28. Offline


    Ha- sorry, yeah set them both to false :)

    Cool! :)

    Offering up spells and wand is a great way to draw in players - but prepared for your world to get trashed! ;)

    Magic will have these chatty settings available per-player, so you could make it super verbose for you (and it will be verbose while you're in SU either way), but maintain the game experience for your players by making it silent by default.

    Nope, use "unbind"!

    Also, if you're only using Wandmin for Spells- you might check out Wand! Of course, if you like all that console chatter, you will probably prefer Wandmin to the way Wand works ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  29. Offline


    I Used wand, but Wandmin was just easier in the video (because of the confirmation messages) and dont have to know it all by head
  30. Offline


    Ah- fwiw, the messages all come from Spells, so you'll get those (with your modified properties file) no matter which wand you use (or no wand at all). :D
  31. Offline


    I don't know which spells I am permitted to. I am actually new to this so don't know how to put up the permissions.
    Can you maybe help me with that?
    Thanks for your reply tho :D

Share This Page