[INACTIVE][ADMN] sqlPermissions v0.5b - Change your Permissions via SQL [740]

Discussion in 'Inactive/Unsupported Plugins' started by SvenBrnn, May 6, 2011.

  1. Offline


    sqlPermissions - Change your Permissions via SQL:
    Version: v0.5b

    Projekt not needed Anymore. Permission 3.x has its own SQL permission system.
    So i stop developing this Plugin!

    The Plugin is for Administrating the Groups/Users of Nijikokun and TheYeti Permissions Plugin via MySQL. You can use the Webpage comes with the Plugin or Develop your own Pages using the Database the Plugin brings with.
    The Webpage the plugin brings with uses the Smarty Engine for Templates and a very simpel Black/White template.

    • Loads the Permissions file into the DB if it is newer then the DB entrys
    • Writes the DB entrys into the Permission files if they are newer
    • Checks the DB and Files every 5 minutes for changes
    • Web Page uses the Smarty Template engine
    What the Plugin needs:
    Source Code

    ATTANTION: If you are using permissionPlus. When you change something in DB and after this within 5 minutes via permissionPlus your changes could be lost. I cant do anything against this!

    ATTANTION2: If you use the Website on an Linux System you have to set the cache and template_c directory rights to 777

    • "Nicer" looking webpage ;)
    • "real" sql Permission system as optional (so that no permissions is needed)
    • suggest something (no GroupManager ATM not^^)

    Changelog (open)

    Version 0.5b
    • Fixed Webpage and Suffix
    Version 0.5
    • Some more Fixes
    Version 0.4
    • Make it Work with permissionPlus
    Version 0.3
    • Fixed an error when Parsing realy big files
    Version 0.2e
    • Changed mysql_real_escape_string to mysql_escape_string to remove PHP errors when Connection has no Password
    Version 0.2d

    • Some more Bugfixes
    Version 0.2c

    • Fixed Bug when World has a quote in its name
    Version 0.2b

    • Fixed Bug when Permissions of Group = null
    Version 0.2

    • Corrected string excaping when Reading the permission configs
    • Removed one Debug on Webpage
    Version 0.1

    • First Release
    Thanks to Nijikokun and TheYeti for the Permissions Plugin
    Ambedrake likes this.
  2. Offline

    tom v

    In my plugin it autoloaded it. And with reload it would throw an erorr so I removed the line.
    So need to figure out the best way to fix it in an elegant way.

    (BTW didn't program JAVA for 2 years and then only in school, so it's a bit rusty, but I'm developing in vb.NET at work so shouldn't be a large problem)
  3. Offline


    the Way to set the Driver via config let the way open for other sql servers. Maybe someone wants to make an other DB connection later :p
  4. Offline


    well i got a problem with your plugin here.

    i got it to work just fine and didn't like so i removed it and dropped the DB,
    now i cant seem to get my permissions to work keeps creating a .yml with the name
    and every time i start it with out your plugin it just keeps creating that file with nothing in it and it deleted my
    world2.yml that i made for permissions in the first place how can i truly get rid of ur plugin and get this from happing
  5. Offline


    I got the same error as i Installed a fresh server without my plugin. Thats seems to be a bug in Permission self. Try to write to the Permission support Thread: http://forums.bukkit.org/threads/ad...ow-with-real-multiworld-permissions-740.5974/
  6. Offline


    making a post there now lets hope they can fix it
  7. Offline

    Nick Hooper

    This fix worked for me, thanks!
  8. Offline


    Hey!! absolutley great plugin!!

    any chance of sorting on the webpage? ie alphabetical by name?
  9. Offline


    you could add a ORDER BY name in the website's SQL
  10. Offline


    I will stop developing this Project because sql is build in the Permissions 3.x and not needed anymore.
    Maybe i will edit the old Page for work with Permissions 3.x

Share This Page