[INACTIVE][ADMN] SimpleSave v3.25 Simple automatic saving! [000] - Backups!

Discussion in 'Inactive/Unsupported Plugins' started by desmin88, Mar 11, 2011.

  1. Offline


  2. Offline


    i decided to update the simple save yesterday before ether last few update the one i had in there sense i started the server way back in mc 1.5 (i cant remember which version if simple save) it worked fine all the way till i updated to the newer version of this plug-in now its un responsive no error messages just not saving or backing up at all :( i miss it because it kept my server running smooth with light weight saving.
  3. Offline


    I am having the same problem, @Andys
    My Bukkit is 1000, and when I am logged in my server and /reload, it loads up fine. But when I start up the server, it doesn't seem to want to load that way. I can't find any other save plugins either.
  4. Offline


    idk if it helps my case any but here is my stats
    Bukkit - 1000
    Simple save 3.25
    world guard
    world edit
    voxel sniper
    iconomy chest shop
    coupon code

    Error: just not working i set the plugin-send-save option to false to auto save and every 10 mins nothing happens every 25 min no backup happens. no error messages just non responsive like its not there yet it loaded the plug-in i have watched the server. :( like i said before the older version a few before this was working just fine till i updated it. i also added alot of these plug ins around the same time but non of them to y knowledge change the way this should act ike i said not getting no errors.

    woops sorry forgot to post config
    #SimpleSave Config File
    #Thu Jul 21 00:57:33 CDT 2011
    backup.message.ending=[Server] Ending world backup
    backup.message.starting=[Server] Beginning world backup
    save.message.starting=[Server] Beginning world save
    save.message.ending=[Server] Ending world save
    backup.date.format=yyyy-MM-dd hh-mm-ss

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  5. Offline


    temp work around for those running linux..

    this only works if running from screen

    setup a cronjob to output the following

    every 1 hour
    screen -S $SCREEN_NAME -p 0 -X stuff "`printf "ssbackup\r"`";
    every 10 mins
                    screen -S $SCREEN_NAME -p 0 -X stuff "`printf "save-all\r"`";
    accomplishes the same thing, just utilizing the backend to make it happen for now.
    Bronski likes this.
  6. Offline


    Too bad it wont save (after the time has run out)
  7. Offline


    Fill out an error report using the template from the OP, and be more descriptive.
    I cant help you without any more info
    Maybe take a look at the top red huge warning at the OP?
  8. Offline


    It only gives the message that I shouldnt post it in this thread.
    It seems that the timer doesnt trigger and it wont auto-save. forcing it to backup works though.
  9. Offline


    The same problem here.
  10. Offline


    2011-07-22 09:33:02 [SEVERE] SimpleSave: Error when copying files!
    2011-07-22 09:33:02 [SEVERE] SimpleSave: This means a plugin you have is not acting nice, or isn't threadsafe
    2011-07-22 09:33:02 [SEVERE] SimpleSave: Go to my thread and post the following information
    2011-07-22 09:33:02 [INFO] Failed to copy full contents from 'MineCore/region/r.-8.1.mcr' to 'backup/MineCore/region/r.-8.1.mcr'null
    2011-07-22 09:33:02 [SEVERE] java.io.IOException: Failed to copy full contents from 'MineCore/region/r.-8.1.mcr' to 'backup/MineCore/region/r.-8.1.mcr'
    2011-07-22 09:33:02 [SEVERE]    at com.apache.commons.FileUtils.doCopyFile(FileUtils.java:310)
    2011-07-22 09:33:02 [SEVERE]    at com.apache.commons.FileUtils.doCopyDirectory(FileUtils.java:265)
    2011-07-22 09:33:02 [SEVERE]    at com.apache.commons.FileUtils.doCopyDirectory(FileUtils.java:263)
    2011-07-22 09:33:02 [SEVERE]    at com.apache.commons.FileUtils.copyDirectory(FileUtils.java:230)
    2011-07-22 09:33:02 [SEVERE]    at com.apache.commons.FileUtils.copyDirectory(FileUtils.java:156)
    2011-07-22 09:33:02 [SEVERE]    at com.apache.commons.FileUtils.copyDirectory(FileUtils.java:125)
    2011-07-22 09:33:02 [SEVERE]    at org.desmin88.simplesave.Backup.backup(Backup.java:44)
    2011-07-22 09:33:02 [SEVERE]    at org.desmin88.simplesave.SimpleSave$BackupMethod.run(SimpleSave.java:151)
    2011-07-22 09:33:02 [SEVERE]    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    2011-07-22 09:33:02 [SEVERE]    at java.lang.Thread.run(Thread.java:662)
    2011-07-22 09:33:03 [INFO] SimpleSave: Deleting old backups
    2011-07-22 09:33:04 [SEVERE] SimpleSave: Error when copying files!
    2011-07-22 09:33:04 [SEVERE] SimpleSave: This means a plugin you have is not acting nice, or isn't threadsafe
    2011-07-22 09:33:04 [SEVERE] SimpleSave: Go to my thread and post the following information
    2011-07-22 09:33:04 [INFO] Failed to copy full contents from 'CoreAdmin/uid.dat' to 'backup/CoreAdmin/uid.dat'null
    2011-07-22 09:33:04 [SEVERE] java.io.IOException: Failed to copy full contents from 'CoreAdmin/uid.dat' to 'backup/CoreAdmin/uid.dat'
    2011-07-22 09:33:04 [SEVERE]    at com.apache.commons.FileUtils.doCopyFile(FileUtils.java:310)
    2011-07-22 09:33:04 [SEVERE]    at com.apache.commons.FileUtils.doCopyDirectory(FileUtils.java:265)
    2011-07-22 09:33:04 [SEVERE]    at com.apache.commons.FileUtils.copyDirectory(FileUtils.java:230)
    2011-07-22 09:33:04 [SEVERE]    at com.apache.commons.FileUtils.copyDirectory(FileUtils.java:156)
    2011-07-22 09:33:04 [SEVERE]    at com.apache.commons.FileUtils.copyDirectory(FileUtils.java:125)
    2011-07-22 09:33:04 [SEVERE]    at org.desmin88.simplesave.Backup.backup(Backup.java:44)
    2011-07-22 09:33:04 [SEVERE]    at org.desmin88.simplesave.SimpleSave$BackupMethod.run(SimpleSave.java:151)
    2011-07-22 09:33:04 [SEVERE]    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    2011-07-22 09:33:04 [SEVERE]    at java.lang.Thread.run(Thread.java:662)
    2011-07-22 09:33:04 [INFO] SimpleSave: Deleting old backups
    2011-07-22 09:33:04 [INFO] Ending world backup
    2011-07-22 09:33:05 [INFO] Ending world backup
    can you tell me what this does mean?
    it occured the first time and i didn't install any new plugins :)

    cheers and thanks
  11. Offline


    worked brilliantly for 10 days i have 3 worlds and set backups to 30 once it reached the 30 backups it started saving randomly every 2 mins not actually saving saying its backing up and not actually backing up im running latest RB#1000 and latest simplesave 3.2.5
  12. Offline


    I also came here to let you know that this plugin does not work for me at all. It says it starts up when I start the server, but never saves. I played around the with settings to no prevail. here is some information:

    Craft Bukkit 1000
    Simple Save v3.25
    Config.properties (open)
    #SimpleSave Config File
    #Thu Jul 21 19:14:41 CDT 2011
    backup.message.ending=[SimpleSave] Ending world backup
    backup.message.starting=[SimpleSave] Beginning world backup
    save.message.color=LIGHT PURPLE
    save.message.starting=[SimpleSave] Beginning world save
    save.message.ending=[SimpleSave] Ending world save
    backup.date.format=yyyy-MM-dd hh-mm-ss

    Other Plugins (open)


    Let me know if you need anymore information. Thanks.
  13. Offline


    i am using simple save as well 3.25

    02:35:12 [INFO] SimpleSave: Parts of config file are blank, but not null. Possib
    le errors might happen.
    02:35:12 [INFO] SimpleSave: DON'T! Post this 'warning' on the thread.
    02:35:12 [INFO] SimpleSave: 3.25 Initialized

    i know it say dont post this, but it does not work at all. it will not save.

    having same issue as user above me =[
  14. Offline


    I am using SimpleSave 3.25

    That error does not refer to the saving. However, I have read through this post and have found a sort of work around for the problems of not saving, at least for me. Someone else in the thread mentioned it. (I am sorry for not remembering the name now, thank you though! lol)

    I have to start my server. I must then log in. Once I am in the game, I type 'reload' into the CMD, this will cause it to actually give me the times of the save and the backup. I have had to set the save to 1m and the backup to 30m. So far, any other settings do not actually work. I am lucky that I pretty much sit here all day between various games, and my guildies are able to let me know if something is going wrong with it (if I have not already noticed).

    I can deal with this error for now, as it saves and backs up without everyone having to log off. (They like to farm things) And, because I can sit here and reload it every once in awhile to ensure it stays on schedule. It is also correctly backing up and deleting the old world files each time. I will link my start up, mods, and config file, just in case I am missing something. I started out with only this and Remote Toolkit. This program does not seem to do the same thing, so hopefully not interfering.

    CMD on Open (open)
    C:\Users\user\Desktop\Crafbukkit>"C:\Program Files\Java\jre6\bin\java" -Xmx30M -
    Xms30M -XX:MaxPermSize=40M -jar Minecraft_RKit.jar parkle:minecraft
    Minecraft Remote Toolkit R10 Alpha 10.31
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Wrapper is running on: Windows 7 6.1 amd64
    Starting wrapper...
    Starting UDP listen server on port 25561
    23:38:36 [INFO] Starting minecraft server version Beta 1.7.3
    23:38:36 [INFO] Loading properties
    23:38:36 [INFO] Starting Minecraft server on *:25565
    23:38:36 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-
    g73697a4-b1000jnks (MC: 1.7.3)
    23:38:36 [INFO] Preparing level "7-18-11 O"
    23:38:36 [INFO] Preparing start region for level 0 (Seed: 8071875115914466201)
    23:38:37 [INFO] Preparing spawn area: 24%
    23:38:37 [INFO] Preparing start region for level 1 (Seed: -522460894989729560)
    23:38:38 [INFO] Preparing spawn area: 93%
    23:38:38 [INFO] [PetCreeper] version 0.32 is enabled!
    23:38:38 [INFO] PetCreeper main loop running.
    23:38:38 [INFO] SimpleSave: Parts of config file are blank, but not null. Possib
    le errors might happen.
    23:38:38 [INFO] SimpleSave: DON'T! Post this 'warning' on the thread.
    23:38:38 [INFO] SimpleSave: 3.25 Initialized
    23:38:38 [INFO] Server permissions file permissions.yml is empty, ignoring it
    23:38:38 [INFO] Done (0.242s)! For help, type "help" or "?"
    23:38:48 [INFO] Parkle [/] logged in with entity id 206 at ([7-18
    -11 O] 6.28125, 62.0, -162.25)
    23:38:56 [INFO] PetCreeper version 0.32 is disabled.
    23:38:56 [INFO] SimpleSave: Powered down
    23:38:56 [INFO] [PetCreeper] version 0.32 is enabled!
    23:38:56 [INFO] PetCreeper main loop running.
    23:38:56 [INFO] SimpleSave: Parts of config file are blank, but not null. Possib
    le errors might happen.
    23:38:56 [INFO] SimpleSave: DON'T! Post this 'warning' on the thread.
    23:38:56 [INFO] SimpleSave: Current save interval is 1 minute(s)
    23:38:56 [INFO] SimpleSave: Current backup interval is 30 minute(s)
    23:38:56 [INFO] SimpleSave: 3.25 Initialized
    23:38:56 [INFO] Server permissions file permissions.yml is empty, ignoring it
    23:38:56 [INFO] ←[32mReload complete.←[0m
    00:08:56 [INFO] [SimpleSave] Beginning world backup!
    00:09:01 [INFO] SimpleSave: Deleting old backups
    00:09:01 [INFO] [SimpleSave] Ending world backup!

    Config File (open)
    #SimpleSave Config File
    #Wed Jul 20 23:08:38 EDT 2011
    backup.message.ending=[SimpleSave] Ending world backup!
    backup.message.starting=[SimpleSave] Beginning world backup!
    save.message.starting=[SimpleSave] Beginning world save!
    save.message.ending=[SimpleSave] Ending world save!
    backup.date.format=yyyy-MM-dd hh-mm-ss

    Note: I have tried Save in 1,5, 20, 30 mins and only the 1 seems to work.
    As well as, back ups at 5(for quick testing) 30, and 60. Nothing over
    30 seems to work.

    Thank you!!
  15. Offline


    try changing plugin.ignore.noplayers=true
    I think it can help with backups stopping to run (could be related to same no-players situation as when server starts).
    I do the same thing - login and /reload right after server start, after that everything works fine, backups are made at 60 mins intervals. Each one eats 37mbs off my hdd, even if nothing changed on server, but I can live with that.
  16. Offline


    @Andys ,

    I think I forgot to try that one lol I will change it and check it out the next time no one is on. Thx! Maybe this will somehow fix my 60 min saves :) Will complain again if not. Thanks again!

    Edit: Sad to report that changing that did not fix the issue. It still requires me or at least one other person to be logged in, in order for the save option to even show in the CMD text and to actually save. I know it might not be as important if no one is on. I am just afraid of something getting all screwed up and not having a back up. That and if I do not physically reload it, it wont start once someone logs in. :) It is still sort of working, so not complaining too much.
  17. Offline


    Well same problem here. The old simple save saved fine but backups were erratic.
    Now updated to 1000 bukkit and updated all of my plugins including simple save and not even sure if save works, and I see no backups at all. Seems like that plugins does nothing at this moment though I see no errors.
    Any word on any fixes or updates for this??
  18. Offline


    Not working for me either. Which just really sucked because I would have liked to roll back.
  19. Offline


    Wtf it saves backups, but once it has reached the limit (100 backups for me), it doesn't delete old ones. So now right when I wanted to rollback something this same plugin caused (plugin.send.saveoff-on was set to true after updating, i dont even understand why isnt it off by default), I had some 7 day old backups -.-

    Actually I just noticed it doesn't save or anything at all. What the hell?
  20. Offline


    Ditto... Just lost a whole day of work.
    Rustyhoff likes this.
  21. Offline


    Works for me too.

    I don't understand why the plugin doesn't provide any error messages on load - it just does nothing.
  22. Offline


    It seems the developer is no longer contributing to this plugin. We must find a better alternative since the dev clearly doesn't want to fix the problems.
  23. Offline


    i posted a work around a page back if your using linux and screen to run your server.
  24. Offline


    I run mine on Windows :/

    Also there isn't a better alternative at the moment. There is a similar plugin, but from what I've read it doesn't work that good, yet.
  25. Offline


    It said post this error so...
    unable to delete directory backup\world_nether\DIM-1.null
    java.io.IOexception: Unable to delete back\world_nether\DIM-1.null
  26. Offline


    Bug found and squashed.Original from github :
    	public void onPlayerJoin(PlayerJoinEvent event) {
    		if (players == 1 && !plugin.backuptimer.isCancelled()) {
    Missed players count increase:
        public void onPlayerJoin(PlayerJoinEvent event) {
            if (players == 1 && !plugin.backuptimer.isCancelled()) {
    Seems to be working. Save+Backup are run once and timer stops when last player quits. Timer starts if someone new logs on to server after that. (I get messages about save/backup intervals too at this point).
    Didn't check long intervals (more than 10 mins) since that would require me to leave my computer running Minecraft at work... Pretty dangerous.
    Are there any rules on this forum prohibiting me from posting fixed jar?
  27. Offline


    @Andys I'm not sure, I've seen others do it. It may be at the discretion of the author though. I'd send him a PM saying you found the issue :)
  28. Offline


    or just post it and remove it if he asks :)
  29. Offline


    Here it is, give it a try.
    And a extra thing I added - if you have whatever_noplayers parameter set to true, plugin will start ticking when server loads. That's how I like it - you run server and see that everything's running at once.
    If false - nothing changed. It starts when someone logs on and stops when there's no one left.

    Attached Files:

  30. Offline


    meep. this can be deleted
  31. Offline


    Just adding to what others are saying about it not working. Because of this mod I've lost over a week due to it killing chunk saving, even on forced saves and server stop. Yeah... not happy.

    I can't use this thing again till this issue is confirmed fixed.

Share This Page