[INACTIVE][ADMN] InstantArmor v2.0 - Own permission system and console commands[677]

Discussion in 'Inactive/Unsupported Plugins' started by ceulemans, Feb 20, 2011.

  1. Offline


    InstantArmor - The Instant Armor Plugin:
    Version: v2.0

    The InstantArmor plugin gives you a whole set of armor with just one command,
    it also "overwrites" your old armor set, so it gives you a new set (= no damage).
    You can also give out sets to other player if you have the permission to.
    I'm now using a users.yml for permissions.

    • It gives you instant an armor set.
    • You can give other players armor sets.
    • Console compatible!
    • All with only one command!
    • My own users.yml permissions file.
    Download InstantArmor

    Wiki with commands, users.yml and FAQ's

    • Then you just place the .jar in your plugins folder!
    • Run the server, it will create the users.yml file.
    • Edit the users.yml file.
    • Reload the server. Done!
    TODO list:

    • Making it able to give out the set of armor to another player.
    • A delete command.
      • If this is done, then I'll redesgin it like /armor [material] <player>. That will be version 1.0!
    • Inplant "rpg style" earning system?
    Please post any bugs,glitches and ideas below!

    Changelog (open)

    Version 2.0
    • Big code clean up.
    • Adding console commands
    Version 1.3

    • Inplanting users.yml file!
    • Miner bug fixes
    Version 1.2

    • Modifying to latest bukkit versions.
    • Now without Permissions, this is temporarily!
    Version 1.1

    • some bugfixes.
    Version 1.0

    • redesigned commands and ingame help.
    Version 0.2

    • now you can give other players armor sets
    Version 0.1

    • Releasing the initial InstantArmor plugin with Permissions
    davispuh likes this.
  2. Offline


    It it possible to make this so that it gives a player armor automatically based on if they have a permission for their group? Maybe even automatically replace/repair the armor as needed too. Just some ideas...
  3. Offline


    Like when a player of that group joins?
  4. Offline


    Yes, when someone joins who is part of a certain group or when admin activates that feature.
  5. Offline


    Yes, i can make it that.
    I'll put it on todo list, atm I have problem with deleting armor, it was crashing client, now that is fixed it has other problem.
    But I already redesigned the command a inplanted a syntax error.

    --- merged: Feb 22, 2011 8:40 PM ---
    I added the all my Todo things (except a armor clear command),
    but i can't test to with new update !
  6. Offline


  7. Offline


    Everytime i start up the plugin i get a series of errors in cmd. After that i try to enter the command in /armor ? and it works. But if i try and give myself armor i say /armor <iron> [myusername] and it returns with error that says <iron> not found
    Here are the errors in command prompt

    Starting minecraft server version Beta 1.3
    2011-02-24 12:41:38
    [INFO] Loading properties
    2011-02-24 12:41:38
    [INFO] Starting Minecraft server on 192.168.1.---:25565
    2011-02-24 12:41:38
    [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-453-g51b7cd8-b435jnks (MC: 1.3)
    2011-02-24 12:41:38
    [INFO] Preparing level "world"
    2011-02-24 12:41:38
    [INFO] Preparing start region
    2011-02-24 12:41:39
    [WARNING] Using the stupidly long constructor be.ceulemans.InstantArmor.InstantArmor
    (PluginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is no longer recommended.
    Go nag the plugin author of InstantArmor to remove it!
    (Nothing is broken, we just like to keep code clean.)
    2011-02-24 12:41:39
    [SEVERE] com/nijiko/Messaging (Is it up to date?)
    java.lang.NoClassDefFoundError: com/nijiko/Messaging
    at be.ceulemans.InstantArmor.InstantArmor.onEnable(InstantArmor.java:42)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:140)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:426)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:76)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:57)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:187)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:174)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:120)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:227)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.ClassNotFoundException: com.nijiko.Messaging
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:30)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    [INFO] Done (851643489ns)! For help, type "help" or "?"
    2011-02-24 12:42:45

    Please tell me what i did wrong and if i need to post the permissions
    Keep in mind i think if i did the permissions right then i should have full admin privilages
  8. Offline


    Having the same error as above. Not updated for latest recommended release it seems.
  9. Offline


    yes, noticed myself,
    I'll post update in a minute.
    --- merged: Feb 24, 2011 7:26 PM ---
    ok, should be updated.
    (PS: I didn't remove TSLPC to win some time, I'll remove it later. It doesn't make a big difference atm.)
    --- merged: Feb 24, 2011 7:29 PM ---
    @jimmysanes, first of all thanks for notifying.
    Also you don't need to do /armor <iron> [myself], it is /armor iron to give yourself
    <> means to type the material there.
    And [] = optional, it is only for giving, but it works for giving to yourself too.
  10. Offline


    so I got a problem. not sure why this happens, but here's the error.
    2011-02-24 17:05:54 [SEVERE] Could not pass event PLAYER_COMMAND to InstantArmor
            at be.ceulemans.InstantArmor.InstantArmorPListener.onPlayerCommand(Insta
            at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.ja
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:646)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:596)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:590)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-02-24 17:05:54 [INFO] egam1234 issued server command: armor iron egam1234
    any help would be wonderful.
    Thanks in advance,
  11. Offline


    Don't do /armor iron Egam1234, just do /armor iron.
    Il see when I get home, I'll post reply here.

    did you update you latest craftbukkit version?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  12. Offline


    i have the latest versions of crat bukkit and when i do /armor diamond username it dousn't work but /armor ? does work
  13. Offline


    fo giving to yourself or to other person?

    ooh, are you guys using the latest permissions?
    I haven't updated to latest permission version.

    I'll update to latest version Permissions, before I repost it is not gonna work, sorry.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  14. Offline


    Its fine dont worry about it. But i am still getting the same error here are my permissions v2.1
    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    # Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    # Does not work for the default world.
    system: default
    # Groups can contain inheritance.
    # To make a group inherit the permissions from another
    # group simply place the groups name in the "inheritance:" like so:
    # Example:
    # inheritance:
    # - Default
    # All permissions including the asterisks must be placed in single quotes.
    # like so:
    # - 'general.spawn'
    # Otherwise errors will happen!
    # Globalized Permission settings:
    # If a permission contains periods (.) you can denote a globalized parameter:
    # - 'general.*'
    # This will allow you to use all general commands.
    # Single Asterisk denotes all commands:
    # - '*'
    # To exempt a node use the - prefix like so:
    # - '-general.time'
    default: true
    build: false
    - 'general.spawn'
    - 'iConomy.payment'
    - 'iConomy.list'
    - 'iConomy.rank'
    default: false
    build: true
    - Default
    - 'general.time'
    - 'general.teleport'
    - 'general.teleport.here'
    - 'general.player-info'
    default: false
    build: true
    - Moderator
    - 'InstantArmor.diamond'
    - 'InstantArmor.gold'
    - 'InstantArmor.iron'
    - 'InstantArmor.leather'
    - 'InstantArmor.chainmail'
    - 'InstantArmor.*'
    - 'InstantArmor.diamond.give'

    # Theitaliansico has control over all commands.
    group: Admin
    - 'InstantArmor.diamond'
    - 'InstantArmor.gold'
    - 'InstantArmor.iron'
    - 'InstantArmor.leather'
    - 'InstantArmor.chainmail'
    - 'InstantArmor.*'
    - 'InstantArmor.diamond.give'
  15. Offline


    I'm didn't had time to update, it will work if I post it as 1.2, sorry again but life is busy!
    --- merged: Mar 1, 2011 8:43 PM ---
    ok, I updated!
    But you need latest version of craftbukkit! (here)
    And no Permission ATM, sorry but I can't if it isn't up to date.
  16. Offline


    I want people to work for their armors, but give them a basic leather armor on call... any chance of permissions making their way back in?
  17. Offline


    yes, but with Nijikokun leaving I had to remove Permissions.
    I saw someone took over the Permissions project, so I'll start implanting Permissions again.
    --- merged: Mar 6, 2011 7:40 PM ---
    Pm me with your idea, i'm thinking about something and maybe we can talk about it.
  18. Offline


    where to download the user.yml
  19. Offline


    The regular download is a zip with the users.yml inside.
  20. Offline


    I was able to install the .jar flie, but what do I do with the yml file?
    umm, I use brohoster

    When I try to get hte armor it just shows me examples and I try the examples and nothing, no armor just more examples the same thing over and over

    you say in the instilation part that you edit the yml file, How to do that.
    Sorry I am brand new to this stuff
  21. Offline


    You just place your name in the list you want, probably full-users.
    You just type:
    <4 spaces>-<space><YourName>
  22. Offline


    Updated to recommended build + new stuff!
  23. Offline


    I would love this plugin if it had permissions support and more config, like being able to use partial armor sets.
  24. Offline


    This works Great on my minecraft! Great Job, i'd recommend it to anyone!
  25. Offline


    Ok, i'll try if i have some free time.
    Any ideas are welcome


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  26. Offline


    I used to love this plugin but since you don't update the title (maybe even not the plugin) I don't use it because I'm not sure if it works.

    It works so please update the title to 766 so people will actually use this plugin.....

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  27. Offline


    Sorry, can't acces my pc atm :(, I will update from the moment i can.
  28. Offline


    Okay. :p
  29. Offline


    cb 677 - inactive

Share This Page