Question I'm about to lose my mind over PEX, send help...

Discussion in 'Bukkit Help' started by iScopedThePope, Apr 25, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    So, I'm running Bukkit on my minecraft server that I bought just 2 days ago. Having owned one before, I got permissions set up and running perfectly but alas, this time I cannot get it to work.

    Plugins I'm currently using are AutoSaveWorld, LWC, iChat, CommandBook, PEX (Obviously) and iConomy.

    HOWEVER, no matter how many times I set up permissions, they do not have any effect in game. My files LOOK to be working correctly, when I add users to specific groups using the ingame commands the users DO get put in the correct groups, I've assigned the groups (Admins, Members & Defaults) the correct permissions I want for each group, made sure to set Default as the default, but if I promote a player to a member, they cannot use simple commands like /chat <color> yet the default enabled ones like lwc.protect work fine for them. It's as if the permissions are not taking effect.

    I have no error messages when I start the server running. Everything gets detected and runs as normal. This PEX thing is beginning to drive me insane though.

    I can post server logs, yml files, jars, anything you guys need, just let me know. Any help is greatly appreciated beyond a level of comprehension you would ever understand.
  2. Offline


  3. Offline


  4. Offline


    well, ichat.<color> is not a valid permission, so nothing there will happen from it.

    NO permissions will ever actually have < > or [ ] in their names, those are used when the author wants to indicate "There are a dozen permission nodes or more all look the same except this part that comes here, you specify the color or the block id or the material name or the warp name or the kit name"
  5. Offline


    I had a similar problem. The only some-what decent answer I had was to name my file name to "permissions.jar" in the config in the Pex folder. It's rather annoying to mess around with .jar, but my permissions are finally working now without a problem.
  6. Offline


    @Googolplexian, you really shouldn't have to do that, although I remember I had my fair share of issues with pex when I was fiddling with it a year ago. There has to be a better solution to that.
  7. Offline


    I sure hope there's a better solution! I've been looking around, but it doesn't seem like too many people have this problem, so I don't know why I am.
  8. Offline


    @Googolplexian, have you tried redownloading the jar? I know that it might be the "guy from India reading off of a computer screen" answer, but its a good place to start.
  9. Offline


    I recommend just reinstall Pex or use the old pex config or reload your pex settings or best solution get GroupManager it's very easy to use and cool.
  10. Offline


    @Tecno_Wizard Yes, I just tried that with the same results. I might give GroupManager a try and see what happens.

    @ShadowTrain I ended up removing Commandbook and installing Essentials as well as group manager, as I was having a few other issues other than with perms. It solved all of my problems. A bit sad though because I like Commandbook.

    <Edited by bwfcwalshy: Merged posts, please use the edit button rather than double posting.>
    Last edited by a moderator: Apr 27, 2015
Thread Status:
Not open for further replies.

Share This Page