Solved I think I broke eclipse...

Discussion in 'Plugin Development' started by mazentheamazin, Feb 7, 2014.

Thread Status:
Not open for further replies.
  1. Offline



    I'd first like to say I didn't really know where to post this so I thought the most relevent one would be in Plugin Development. So, recently I had an issue with Minecraft and wanted to force stop java.exe as I did that, I accidentally force stopped Eclipse. As I noticed that I immediately opened eclipse again to realize that my workspace was corruped. Well, let me explain.. I open eclipse and it says all my files are not found, but I can import my projects into the workspace without a problem. However, when I close eclipse I get this message:
    Problems occurred while trying to save the state of the workbench.
      Internal Error
      Cannot set lower sequence number for root (previous: 142, new: 1). Location: C:\Users\admin\workspace\.metadata\.plugins\org.eclipse.core.resources\.safetable\org.eclipse.core.resources.bak
    And when I open it I get the same problem where all my projects are not found/recognized. I've been looking up almost everywhere I could and all the fixes I found did not help, so I decided to post here.

    Any help is appreciated,
  2. mazentheamazin
    Save your projects and then try reinstalling it. Then, try running it without any of your projects in the workspace and see what happens. Some of, if not all of your projects may have been corrupted
    mazentheamazin likes this.
  3. Offline


    mazentheamazin likes this.
  4. Offline


    The Gaming Grunts
    Didn't work :'(

    Just tried that, it didn't work. Deleted the .metadata folder and it worked. Thanks soo much Gater and The Gaming Grunts for the help ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 6, 2016
  5. mazentheamazin
    Was about to suggest doing that :p
Thread Status:
Not open for further replies.

Share This Page