I have port-forwarded my server, but friends still cannot join

Discussion in 'Bukkit Help' started by Roman123, Oct 23, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hi, I'm running OS X 10.7.5 on a macbook pro and am trying to host a bukkit server. I have done all of these permissions and such, and then finally port forwarded my ip address. My ip address for the server has the port forward number (25565) in it, which Im pretty sure means hat it worked. But whenever my friends try and join, it won't let them, they can't see that the server is even up.

    195 recipes
    27 achievements
    19:43:15 [INFO] Starting minecraft server version 1.3.2
    19:43:15 [INFO] Loading properties
    19:43:15 [INFO] Default game type: SURVIVAL
    19:43:15 [INFO] Generating keypair
    19:43:16 [INFO] Starting Minecraft server on *:25565
    19:43:17 [INFO] This server is running CraftBukkit version git-Bukkit-1.3.2-R1.0-b2377jnks (MC: 1.3.2) (Implementing API version 1.3.2-R1.0)
    19:43:17 [INFO] While loading bPermissions (plugins/bpermissions.jar) found old-data folder: plugins/bpermissions next to the new one: plugins/bPermissions
    19:43:17 [INFO] [bPermissions] Loading bPermissions v2.9.24
    19:43:17 [WARNING] ----- Bukkit Auto Updater -----
    19:43:17 [WARNING] Your version of CraftBukkit is out of date. Version 1.3.2-R2.0 (build #2396) was released on Wed Oct 17 11:36:23 EDT 2012.
    19:43:17 [WARNING] Details: /downloads/craftbukkit/view/01460_1.3.2-R2.0/
    19:43:17 [WARNING] Download: /downloads/craftbukkit/get/01460_1.3.2-R2.0/craftbukkit.jar
    19:43:17 [WARNING] ----- ------------------- -----
    19:43:17 [INFO] [Essentials] Loading Essentials v2.9.4
    19:43:17 [INFO] [EssentialsChat] Loading EssentialsChat v2.9.4
    19:43:17 [INFO] [EssentialsProtect] Loading EssentialsProtect v2.9.4
    19:43:17 [INFO] MLog clients using java 1.4+ standard logging.
    19:43:17 [INFO] [EssentialsSpawn] Loading EssentialsSpawn v2.9.4
    19:43:18 [INFO] [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.9.4
    19:43:18 [INFO] Preparing level "world"
    19:43:18 [INFO] Preparing start region for level 0 (Seed: -471308558828820427)
    19:43:19 [INFO] Preparing spawn area: 20%
    19:43:20 [INFO] Preparing spawn area: 28%
    19:43:22 [INFO] Preparing spawn area: 32%
    19:43:23 [INFO] Preparing spawn area: 69%
    19:43:23 [INFO] Preparing start region for level 1 (Seed: -471308558828820427)
    19:43:24 [INFO] Preparing spawn area: 12%
    19:43:25 [INFO] Preparing spawn area: 52%
    19:43:26 [INFO] Preparing start region for level 2 (Seed: -471308558828820427)
    19:43:26 [INFO] Preparing spawn area: 0%
    19:43:27 [INFO] Preparing spawn area: 48%
    19:43:28 [INFO] [bPermissions] Enabling bPermissions v2.9.24
    19:43:28 [INFO] [bPermissions] Loading world: world
    19:43:28 [INFO] [bPermissions] Loading world: world_nether
    19:43:28 [INFO] [bPermissions] Loading world: world_the_end
    19:43:28 [INFO] [Essentials] Enabling Essentials v2.9.4
    19:43:29 [INFO] Essentials: Using bPermissions2 based permissions.
    19:43:29 [INFO] [EssentialsChat] Enabling EssentialsChat v2.9.4
    19:43:29 [INFO] [EssentialsProtect] Enabling EssentialsProtect v2.9.4
    19:43:29 [INFO] Initializing c3p0- [built 21-May-2007 15:04:56; debug? true; trace: 10]
    19:43:29 [INFO] [EssentialsSpawn] Enabling EssentialsSpawn v2.9.4
    19:43:29 [INFO] [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.9.4
    19:43:29 [INFO] Server permissions file permissions.yml is empty, ignoring it
    19:43:30 [INFO] Done (11.793s)! For help, type "help" or "?"

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  2. Offline


    Roman123 likes this.
  3. Offline


    Are you able to connect by typing in your external IP? (http://www.whatismyip.com/)

    Also firewalls and security systems can interfere with ports, even when opened.
  4. Offline


    My firewall is off, and ill try connecting using my external IP

    Okay, the ip on that link that you gave me was way different than the one I use for my server, but my server is up and running for me. I took off the :25565 part of my server ip and I could still join just using my normal network ip, so I don't know whats up

    I am running my server off of the ip that I see when I go to my network settings, its 192.168.***** but the one on canyouseeme.org is completely different, something like 74.255*****

    I am using my ipv4 address
  5. Offline


    1. Please use the handy-dandy "Edit" button!
    2. Do you have anything in your server config (server.properties)' server-ip= line?
  6. Offline


    Merged consecutive posts.
  7. Offline


    I don't have anything written in the server ip line
  8. Offline


    start your server and then go here http://ping.eu/port-chk/ put in your ip and port it will check if its open if it says closed then you didnt port forward right
  9. Offline


    Okay, my port is closed apparently. But its weird, whats the difference between my ipv4 address and my normal ip address?
  10. Offline


    the ipv4 is your external ip always and there will be a new version ipv6 coming out the other numbers are internal numbers
    think of the ipv4 as your telephone number its exclusive to you they are running out of ipv4 numbers so the are implementing ipv6 to take up the slack

    also what do you think your normal ip is if it begins with 192 thats your router number thats internal go here for your external ip http://www.whatismyip.com/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  11. Offline


    Okay, so Ive been using my internal ip address then, but my server is running on that ip address. How do I change it to my external?
  12. Offline


    Your ipv4 addy that starts with 192 is a local address. People need to be plugged directly into your network to see it.

    You need your WAN address... that's what that website gave you. Your friends need to use it. They will NEVER have access to the 192 one.

    Forward the ports. Remove the "server-ip" from the server.properties file (change it to a blank value). It should work after that when others use the external address. (Fair warning, there are many routers that will NOT allow YOU to use the external address from inside the network. They call this a "loopback" and many routers now block that kind of traffic)
  13. Offline


    Roman123 Use the whatsmyip address. This is your public facing address.

    The Router transfers packets from the external ip to the internal ip, that is why you have to do port forwarding. The forwarded port tells the router that anything hitting that address (external) on that port(25565) should be directly routed to your server ip (internal -192.168.what.ever) and vice versa.
  14. Offline


    Okay, so the ip I give my friends is my external followed by my port?
  15. Offline


    The default port for a Minecraft server is 25565. If you have correctly forwarded port 25565 and that is the port you have entered in your server.properties, your friends can simply connect using your IPv4 address with no port after it.
  16. Offline


    sorry to revive an old thread but i have been struggling with this same problem and i finally figured out an alternative solution to the problem bc apparently 25565 is being used y something else on my machine and im not sure what.

    i have forwarded the 25565 port 100% correctly in my router and i even used the portmapper program made by Fateful but still couldnt get 25565 to open on my machine.

    so i simply change the port inside my server properties to 25566 and then went here http://ping.eu/port-chk/
    and checked my external ip with that port and FINALLY i got to access my server by my external ip by logging in with

    i know this isnt the ideal way to do it since the default 25565 SHOULD have worked but it didnt and this way solved my issue.
  17. Offline

    Frank Wozniak

    sorry for also reviving this but it says the port is open on my public ip but when i check it with my ipv4 it says its closed. i port forwarded correctly and allowed it through the firewall, run the server, check the ipv4 and it says its still closed and im still not sure how to get it open. im pretty new to bukkit forums so sorry if im in the wrong place and if i sound like a noob but i really need help.
    fatguy46 likes this.
Thread Status:
Not open for further replies.

Share This Page