Solved I have a bug with MCP 1.7.2 :(

Discussion in 'Plugin Help/Development/Requests' started by Ewearys, May 6, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    Ewearys

    Hello guys, I need your help with MCP 903 (1.7.2)
    I have recompile & reobfuscate my client with MCP, I have drag all the reobf files in a clean 1.7.2.jar and I tried to open it with the Minecraft Launcher, but It does not work.
    Here's the error :
    Code:
    Exception in thread "main" java.lang.IllegalAccessError: tried to access class bgq from class net.minecraft.client.main.Main
        at net.minecraft.client.main.Main.main(Main.java:95)
    Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
    
    I tried many things like making a new MCP, doing things like updatemd5, decompile and others, but no one has worked !
    I don't find the help !
    Could someone helps me please? :(
    Thanks !
     
  2. Offline

    megamichiel

    First of all, it took me a bit to realise that MCP stands for minecraft coder pack, it would be smarter to just say it. And second, I know this is the alternatives section but is this really the place to be at? Doesn't MCP have a help forum or something? And third, I looked on the newest MCP site (modcoderpack.com) and it appears that it's for 1.6.4, 1.7.10 and 1.8 only, not for 1.7.2, I would update to a later version of MC or just use MinecraftForge.
    Edit: Found this on the bottom of the MCP website: http://gyazo.com/8e472c46fab0c7638bc7ecd4e7f3c8df
     
  3. Offline

    Ewearys

    Forge is not easy to use...
    I don't understand lots of things, like why we should call a class like GuiMainMenu "GuiMainMenuCustom" but not "GuiMainMenu" ? Because when we try to reobfuscate with a Custom class name, the class is not Obfuscated
    Or, could I recompile and rebfucate my actual client and drag it on a forge ?

    EDIT : The 1.7.2 of MCP was available to download 1 year ago
     
Thread Status:
Not open for further replies.

Share This Page