How to Install Bukkit (Newb-Friendly!)

Discussion in 'Bukkit Help' started by TheArcher, Jan 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    my server works fine and stuff but when i try to connect it says server outdated and i looked at my servers command prompt and it says its running craftbukkit for MC V. 1.5_01.

    please help me with this!!!
  2. Offline


    The link in the Windows CraftBukkit Setup works fine. Is that what you are using to download the .jar file?

    No, thank you.

    Update your CraftBukkit .jar. All setups in the thread have updaters. :)
  3. Offline


    Hey can you put up a quick tutorial on how to install plugins onto the serv? Because I have made a plugins folder and tried to install worldedit, but nothing is working :S
  4. Offline


    Can you please tell me where all the links are? It just says

    [MOD: and link shorteners are banned]

    [MOD: and link shorteners are banned]
    Mac OS X
    [MOD: and link shorteners are banned]
    underneath the "Step 1" Heading. Is this temporary? Is it something with my computer? What's the deal?​
    Thank you very much for all the time you've put into maintaining this, and I really would like to use it!​
    - thefritzinator​
  5. Offline


    aw, links are down like instant.
  6. Offline


    The links are back up.

    It is very easy, download the plugin and follow the instructions (which are almost always simply to drop the ".jar" file into the "plugins" folder).
  7. Offline


    When i run CraftBukkit Starter JRE6 it says that it doesnt know command java(i have latest java though). What is wrong with it?
  8. Offline


  9. Offline


    [​IMG] why wont it Load? :O
  10. Offline


    You would know if you read the "Read Me". :D
  11. Offline


    @TheArcher adfly links are forbidden on this forum, please remove them immediately
  12. Offline


    i get the same thing....

    alright i figured it out :p
    go to notepad and type in
    @Echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui

    name the file whatever but make sure its a .bat file

    and run that .bat to run the server, it should work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  13. Offline


    Hi, I'm on a Mac OSX and when I try to open the command It gives me the message... "The file “Mac OS X CraftBukkit Setup.command” could not be executed because you do not have appropriate access privileges. To view or change access privileges, select the file in the Finder and choose File > Get Info."

    I have changed the permissions and everything, and I am admin on my computer, but I still cannot run it.
    If you have the answer, please tell :D

    Thanks in advance.
  14. Offline


    1. Start up Terminal
    2. Type "chmod +x " (notice the extra space at the end)
    3. Drag the .command file onto the Terminal window
    4. Hit enter
    You should now be able to run it. Didn't I include a README or something with that? If not, I should. lol
  15. Offline


    When I do that, I get this message :c

    Users/~/Desktop/Mac OS X CraftBukkit Setup.command: Permission denied
  16. Offline


    Ok, try this instead: "sudo chmod +x " (drag file) (hit enter) (type password when it asks)
  17. Offline


    Are you sure that's in the right order? Because when I type sudo chmod +x it asks for a password, and I gave it the password THEN put the file in and hit enter but it still did not work.
  18. Offline


    No, type "sudo chmod +x " but don't hit enter yet. Now drag the .command file onto the Terminal window. You'll see have something like this waiting in Terminal:
    sudo chmod +x /Users/sunlis/Desktop/Mac OS X CraftBukkit Setup.command
    Now hit enter. It will ask for your password; type it in and hit enter.

    NB: When you are typing your password, it won't show any characters or give any other indication that it knows that you're typing, so just make sure you type it correctly.
  19. Offline


    Thanks, this helped a lot! :D :D :D I love you (no homo)
  20. Offline


    Hello when i try to set up my server i get the following message
    Failed to load main-class manifest attribute from C:users\jag\desktop\skrivbordet\sermodding\craftbukkit-1.0.1-R1.jar

    Thanks for helping! [​IMG]
  21. Offline


    I need help. I have been trying to get mt bukkit to work for a couple hours now and I just can't get it to. I followed the directions step by step and when I go to open it I get

    The system cannot find the path specified.

    I have no clue what I did wrong but could someone please help me.
  22. Offline


    I set up my bukkit server, no problems at all
    But yesterday, the launchserver.command in terminal stayed blank, the server still works, but i need the console!
    I had (before the problem) downloaded bunchs of plugins, and after the problem deleted them
    I use a mac.
    Help please?
  23. Offline


    Could you download this file: LaunchServer.command
    And use that one instead?
    You will have to make it executable: open Terminal, type:
    chmod +x [drag file here]
    And press enter. Don't forget the space after "+x".

    If that doesn't solve the problem, tell me, I'll look into it. :)
  24. Offline


    The search seems to be broken so sorry if this has already been posted. When I run the RUN.bat that the guide tells me to, I get this message:
    "The system cannot find the path specified
    Press any key to continue . . ." and pressing a key closes it. (I don't know what version of Java I have, I thought it was Java 7 so I tried the thing for that)

    When I paste the other thing into the RUN.bat file, I get:
    "Unable to access jarfile craftbukkit.jar
    Press any key to continue . . ." and pressing a key still closes it. What do I do to fix this so I can run Runecraft?
  25. Offline


    Virtual Box
    CPU: 1 core 4.3 Gh.
    RAM: 2304Mb.
    System: Ubuntu Server 64;
    Java: openjdk-7.
    bukkit:1.4.6 0.3
    start: java -Xmx2048M -Xms2048M jar server.jar nogui

    Exception in thread "main" java.lang.NoClassDefFoundError: jar
    Caused by: java.lang.ClassNotFoundException: jar
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    Could not find the main class: jar. Program will exit.
  26. Offline


    Did you save it as a .bat?
    To do this, open notepad by hitting MediaKey+R and type "notepad" w/o quotes
    Now, type java -Xmx1024M -jar craftbukkit.jar -o true
    (Note: You must hit enter between true and PAUSE, and PAUSE must be in Caps)
    Also, is java runnable from the cmd line? Open command prompt, and type "java -version"
    Again, no quotes

    oh and, save as run.bat

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
Thread Status:
Not open for further replies.

Share This Page