How to fix your world errors/corrupt chunks

Discussion in 'Bukkit Help' started by Pezmantbh, Jan 11, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    There have been a lot of issues on the help forum recently that are usually world related. Another major problem is a massive number of entities in a small area – This happens a lot with TNT. Before you read this thread, it may be worth noting that I am happy to fix your world for you; go here to learn more:

    PART 1
    The first tool we will use is Chunkster. Download it from here:

    Once you have downloaded it, unzip it into the folder that your world is in, then stop the server and open the RunMe.bat file. Once it is open, check that it has found the right world and then continue (by pressing y). Let it do its thing, and then press the any key when asked(you have one of those, right?).
    The next step is to start your server and check if it has worked. There is a good chance it has worked, however if it has not then the next tool should fix it for you :)

    PART 2
    Download the Minecraft Region Fixer from here:

    You should extract Region Fixer to its own folder, in this case I will use C:\MCRF\
    You should now open up a command prompt (press the windows key + r, then type cmd) and type in the following:

    C:\MCRF\region-fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 C:\server\world

    Replace C:\server\world with the path to your world folder (not your server folder, the actual world folder itself).
    Once it has finished, it will display something along the lines of:

    Found 0 corrupted and 0 wrong located chunks of a total of 1192

    After it has finished, it will have removed excessive amounts of entities and deleted corrupted region files – It will not fix wrongly located chunks and/or entities...
    If, once it has finished, it displays something like this:

    Found 0 corrupted and 1 wrong located chunks of a total of 1192

    then a wrongly located chunk has been found. To fix this, go back up in the command window and look for something like this:

    Scanned r.-1.-1.mcr <c: 0, w: 1, t: 354>

    You are looking for w: 1 – That is how many wrongly located chunks were found in that region file, and the number may be more than 1... “r.-1.-1.mcr” is the name of the file with the issue. To fix this, go into your world folder, then into the region folder, and delete the file mentioned in the previous step (in this case “r.-1.-1.mcr").

    You can now start your server. If you still have an issue then make a thread in the help section, the guys there will assist you in fixing the problem.

    Alternatively, if there is something I have not made clear or that I have not explained well enough then feel free to reply in this thread. I will edit this soon to fix many of the grammar mistakes, and I will also add some screenshots and linux commands:)
  2. Offline


    Awesome guide!
    Let's just hope people read this...
    Sticky? :3
    Charly_ZA and frozone2008 like this.
  3. Offline


    I believe that MCedit has a Repair regions option similar to this.
  4. Offline


    Indeed, but these two tools are made for this specific purpose... I like to employ a few other methods to fix worlds, as well as use the two tools in this thread, but this guide will help the majority of people with issues :)
  5. Offline


    You told me to do part 2 I did and i did what you said but it keeps saying region-fixer: error: no such option: -e
  6. Offline


    What command are you using for the region fixer?
  7. Offline


    the exact one you wrote
  8. Offline


    My apologies. I have now fixed it :)
  9. Offline


    Redownload it?
  10. Offline


    No, copy the command again. It was an issue with the command itself :)
  11. Offline


    Okay thanks :)
  12. Offline


    Let me know if it works :)
  13. Offline


    Okay but the new error is region-fixer: error: The world path doesnt exists!

    my cmd: C:\mcfix\region-fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 “C:\mc12\world"
  14. Offline


    Does C:\mc12\world exist?
  15. Offline


  16. Offline


    What about the world folder within mc12?
  17. Offline


    if your mc12 is the world folder, try removing the quotes around "c:\mc12\world" at the end of the cmd line.
  18. Offline


    Did you make RF? :)

    It is a habit of mine to use the quotes because I often have folders with spaces in the name ;)
  19. Offline


    I did all what you said. My world keeps getting randomly corrupted chunks. Sometimes theyre in line, sometimes its a single chunk. They just are out of place. They are a random chunks from somewhere else, sometimes from nether even, that get copied into other area where they shouldn't be. Worst cases are when they appear inside someone's faction house...
  20. Offline


    the 2nd step has not worked for me i edited the C:\MCRF\region-fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 C:\server\world

    several diffrent ways to try and get it to work but still will say path not specified
  21. Offline


    I have the same problem as jsimmons6422. And I really need help A.S.A.P..
    I created a folder named MCRF on my desktop. Download it. Extracted its contents to my deskop. (which was a folder). Took the folder, cut all its contents, pasted it into MCRF. Opened CMD and typed in C:\MCRF\region-fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 C:\Users\[MyName]\Desktop\Techopolis\Minecraft MMO Server <--- (and that has the "world" folder in it)
    and the cmd says it cannot find the specified path.
  22. Offline


    You need to point the parameter at the end to the world folder, not the folder which has the world folder in it.
    Also, you need to make sure that the files are like this:
    rather than something like this:

    Hope it helps ;)
  23. Offline


    I even took my world folder and put it straight to my desktop so the path would be C:\world
    still didn't work. and like i said. when i extracted the rar it gave me a folder named region fixer-0.0.6. I took all the contents out of it and put it into a folder named MCRF on my desktop. so i know im typing in everything correctly. its just not working.
  24. Offline


    figured out whatthe problem was your :\MCRF\region-fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 C:\server\world

    is wrong pezmantbh..

    this is correct one

    C:\Users\jake\Desktop\MCRF\Minecraft-Region-Fixer-v0.0.6\Region-Fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 C:\Users\jake\Desktop\world

    you dont have "Minecraft-Region-Fixer-v0.0.6" int here between mcrf and region-fixer.exe

    so gamer freak this is what i did i draged and droped the world folder to desk top and same with the mcrf folder. and just use

    C:\Users\jake\Desktop\MCRF\Minecraft-Region-Fixer-v0.0.6\Region-Fixer.exe --verbose --delete-corrupted --delete-entities --entity-limit=100 C:\Users\jake\Desktop\world

    and make changes like your name. hopefuly this will fix your issue b.c it looks like u had same problem i did
  25. Offline


    That worked. Thank you VERY much.
  26. Offline


    Explains itself pretty well ;)

    Means put the RF files into /MCRF/

    Perhaps you misinterpreted what I said :)
  27. Offline


    well it doesn't matter now anyway, jsimmons got the solution for me :)
    This thread helped me very much though.
    So thank you pezmantbh :)
  28. Offline


    ya after i did it it still dident fix my problem but im glad to help anyways lol
  29. Offline


    I will edit this guide in the next week or so with linux commands and some minor sentence changes :)
  30. Offline


    My server is completely shut down and I don't know what to do... I used Chunkster exactly as you said and all it says is "ERROR: The system was unable to find the specified registry key or value.
    ERROR: The system was unable to find the specified registry key or value.
    Java found! \bin\java.exe
    The system cannot find the path specified.
    Press any key to continue . . ."
Thread Status:
Not open for further replies.

Share This Page