Question How do I get coloured chat for Groups using PermissionsEX?

Discussion in 'Bukkit Help' started by Keyboard Warrior, May 24, 2015.

Thread Status:
Not open for further replies.
  1. So I'm having some trouble getting coloured chat to work - I hosted a localhost server with the same essentials config and same permissions.yml and the coloured chat worked, but when I put it into a public server, it doesn't work.

    Here's my Essentials Config.yml:

    And here's my Permissions.yml:
  2. Offline


    I didn't get mine working until I installed PExChat. Maybe there's a more efficient way of doing it but that's the best I came up with. I'm also looking for help with plugins but I'd be glad to help you as much as I can. If you install PExChat and it still doesn't work let me know and I'll try to help you out! =)
  3. Offline


    Do you have EssentialsChat installed on the public server?
  4. Offline


    Find the EssentialsChat thing on your Essentials config, then let's take for example group Owner.
    Where it says:
    After that type something like that:
    Owners: &4{DISPLAYNAME} &7&l >> &mc{MESSAGE}
    Then I believe you don't have to delete this # sign.
  5. Offline


    Or you can just use the prefix option in PermissionsEx, and EssentialsChat will use that.
  6. Yes. I even tried to install 2 different versions of it.

    I've already set it as my own format.
  7. Offline


    Please post your latest.log, maybe there were some problems.
  8. Here's my latest.log:

    And here's my plugins incase you think something may be interfering with EssentialsChat -
  9. Offline


    Line 11: Ambiguous plugin name --> You have two jar files for the same plugin, with different filenames. The server flips a coin randomly each time to determine which file to load, if they are the same version its not a big issue, if its a different version, you end up flipping between some things working vs not.

    Line 13: Could not load plugins/mcore.jar ... yet, mcore runs. Not sure how to explain that one, errors are never good to have. Perhaps it is a second file in a subfolder "/plugins/plugins/mcore.jar" ?

    Line 325: Unable to load ess GeoIP properly. It may still appear green, but, I bet the plugin commands dont work for it. Version issue. Unless geoip is really important to you to use , its a heavyweight potential for errors and network errors.

    Line 475: That blob is from NameTagEdit , something to do with scoreboards. May be a version incompatibility

    Line 504: That blob is from essentials xmpp. If you have no actual need for xmpp features (almost no one does) remove the plugin.. this is also the coin-flipping plugin on startup which may be toggling from working and non-working files.

    Pastebin your essentials config -- may be a matter of not commenting the right thing int he format, or having a boolean flag not set compatible. Or, your custom format that is ignoring a vriable to simply change.
Thread Status:
Not open for further replies.

Share This Page