How can I stop mobs spawning in a region?

Discussion in 'Bukkit Help' started by Nercoe, Mar 21, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Basically, how can I stop mobs from spawning in my town region, I used Worldguard to set the region. Is there a plugin or command that can help me do this? Will rep+ :)
  2. Offline


    Nercoe likes this.
  3. Offline


    look into the worldgaurd wiki
    /region flag <id> <flag> [<value>]
    /region flag nameofregaion mob-spawning deny
    Nercoe likes this.
  4. Offline


    Thank you very much! ++
  5. Offline


    not a problem now i have to go deal with my server problems
  6. Offline


    I did that and it didn't work...
  7. Offline


    how is the command for an whole world if there is one?
  8. Offline


    Depends which plugin your using. for multiverse it's /mvm set difficulty peaceful <World>

    If your not using any plugin, set the difficulty in
  9. Offline


    just deny mob-spawning in your server properties
  10. Offline


    Horrible necro-post. Please refrain from bringing old threads back to life.
  11. Offline


    lol yeah didn't realise how old it was :p
  12. Offline


  13. Offline


    CrazedLobster :
    For me WorldGuard region flag mob-spawning deny worked, I selected a village and all the villagers disappeared on server restart :( So it works :) But I have to say, it does not deny the entities to enter that region, so if you meet a zombie (for ex.) in that region it doesn't means the mob-spawning is not denied, just a zombie walked into the region from outside. I think "entity" flag is for that somehow but i didn't look at it.
Thread Status:
Not open for further replies.

Share This Page