Help! I cant run!

Discussion in 'Bukkit Help' started by iNsAnItY_Wolf, Jul 27, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Okay, so I have a few questions.

    Im trying to run Bukkit, and I saved this into my notepad as RUN.bat:

    @Echo off
    "C:\Program Files (x86)\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit.jar
    But when I click it says:
    The system cannot find the path specified
    Press any key to continue_

    I dont know how to fix this and I've just started my server.
    How can my friends connect to my server? When I give them my laptop ip it cannot connect.

    If you can help, you are Epic.
    But Im not as technical as you may think, so try to simplify if you can. ^_-

    Your Eternaly iNsAnE Wolf,
  2. Offline


    Try "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" instead of the path you have.
  3. Offline


    I have tried using "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" instead but I had the same problem. I believe I do have java but Im not sure which one. But, I have other files in my folder, could that be a problem? Im not very good at computers as I would hope. And do I need a specific name for the folder I put them in? Please help. ((Once again, not good at computers. -Facedesk- ~Thanks~

    Your Eternaly Insane Wolf,
  4. Offline


    Try going one level up - i.e. instead of "%ProgramFiles(x86)%\Java\jre6\bin\java.exe", try using "%ProgramFiles(x86)%\Java\jre6\bin\" (or, if that doesn't work, "C:\Program Files (x86)\Java\jre6\bin\").

    Also, I just saw the thing about your friends connecting. This can be a pain to sort out, but here's how to do it:

    1. Find out your internal IP address. On Windows 7 systems, the easiest way to do this is to right-click the network connection icon in your taskbar, click Open Network and Sharing Center, click on your connection (next to where it says Connections), click on Details and then write down your IPv4 Address.
    2. Whilst you have this window open, also take note of your IPv4 Default Gateway.
    3. Now, go to your Internet browser and type your IPv4 Default Gateway into the address bar, and press Enter. This should take you to your router's configuration page - this might require a user name and password, which will vary depending on the make and model of your router.
    4. Now you need to create a new firewall rule for your router. Again, this varies by make and model (and even by ISP), so I'll be able to help you more if you can tell me the make and model of your router. Either way, you need to find a screen which lets you add a firewall rule. Create a new inbound rule (name it whatever you like) with the following details:
      1. Port range (or single port) 25565 - this is the default MC server port, so if you've changed it yourself in then obviously it'll be different.
      2. The rule needs to be TCP/UDP.
      3. The rule needs to be directed to your internal IP address (the IPv4 address you took down earlier).
    5. Now, make sure that the new rule is enabled on your router. Again, this procedure varies by router make and model, so if you tell me your router's make and model I can help you more easily!
    6. Now you need to find your external IP address. Go to, type in "my IP address" and hit Search - Google will tell you your external IP address, which is the address you'll need to give your friends if they want to connect to your server, plus the port the server is operating on, separated by a colon (i.e. if your external IP was and the server was on port 123, your friends would connect to
    7. If you want to connect to your server yourself, you need to use your internal IP address (the IPv4 address), plus the port the server is operating on (separated by a colon), to connect.
    8. You can check that you've configured your router correctly by going to and typing in the port you want to check (25565 by default). If the port is open, then you've done everything correctly. If not, then you haven't!
    Like I said, if you tell me your router's make and model and your ISP, I'll be able to give you more detailed setup instructions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  5. Offline


    The problem with this one:
    I have tried both of these files and both of them did the same thing. When I pressed RUN I saw the window blink, but it was only for a brief second. It wasnt long enough for me to read what it said. I tried numorous times. I could see the tet was short, maybe only two lines long. Do I need to delete and run again? I hope my problems arent bothering you. [zombie]

    Your Eternaly Insane Wolf,
    ~~ iNsAnItY Wolf
  6. Offline


    Try this instead:

    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
    Make sure that it's in the same directory as the server files. Also, if you're running Java 7, change "jre6" to "jre7".

    I also just want to confirm - you're definitely running a 64-bit OS, yes?

  7. Offline


    I use
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar minecraft_server.jar
    Edit: totaldonut beat me to it
  8. Offline


    Sorry ;)
    Jozeth likes this.
  9. Offline


    I do not know if this is a problem or if it's good:

    This opened 2 windows in cmd.exe

    One said:
    Error occured during initialization of UM
    Could not reserve enough space for object heap
    Press any key to continue_

    The other said:
    182 recipies
    27 achievements
    13:51:39 [INFO] Starting minecraft server on version 1.2.5
    13:51:39 [INFO] Loading Properties
    13:51:39 [INFO] Starting minecraft server on *:25565
    13:51:39 [WARNING] **** FAILED TO BIND TO PORT!
    13:51:39 [WARNING] The exception was: Address already in use: JVM_Bind
    13:51:39 [WARNING] Perhaps a server i already running on that port?

    Does this mean I have java 7? Like I said Im not as technical as you may think. ^_-

    Also, I do not know my router's make and ISP but my dad might. I'll have him work on it with me. Thanks!

    Your Eternaly Insane Wolf,
    ~~iNsAnItY Wolf
  10. Offline


    The second one looks like it was working, but something else was using port 25565. Did you already have another server running?

    Close all your open applications, and try running the second one again. I'm pretty sure that'll work. If not, restart your computer and try again. If it still doesn't work, then we'll look into other solutions.
  11. Offline


    Great Notch it worked! :D
    Happy zombie: [zombie]

    Thank you so much ^^
    Now I just need to download the plugins, but I wont have a problem with that. ^_-
    Here is cake: [cake]

    [cake]+[tnt]= [creeper]
    Thanks again!

    Your Eternal Insane Wolf,
    ~~iNsAnItY Wolf
  12. Offline


    No problem :)

    Feel free to ask for more help later on if you can't figure out how to let your friends connect.
Thread Status:
Not open for further replies.

Share This Page