Help! A Program is using my server port, but i can't find it!

Discussion in 'Bukkit Help' started by tonkku107, Jul 21, 2013.

Thread Status:
Not open for further replies.
  1. So i tried to run my server and it said: [​IMG]
    java.exe or jawaw.exe is not running. port is being forwarded. I tried this:
    6048 is running 25565.
    But the problem is, [​IMG] There is no 6048 on the list. (sorry for the Finnish lagnuage)
    How can i find the program running port 25565?
    P.S. Rebooting didn't work.
  2. Offline


    Give TCPView from Microsoft a look at. Open the file and search for the 25565 port, then right click and "End Proccess", or "Close Connection", depending on whether you want to end to program, or just close the connection.
  3. I don't want to install anything right now...
  4. Offline


    You don't need to, all you need to do is download the file, open with WinRAR(or similar) and run Tcpview.exe.

    The program will run on your RAM, there is no need to install it.
  5. I found a hidden java.exe. every time i open my computer it appers there as a internet service. How can i stop it?
  6. Offline


    One way is to go to Task Manager(Ctrl + Alt + Esc), go to the Processes tab, find the java.exe and end it by right clicking and "End Process", but that may only be a temporary solution.

    If the program runs on startup, go to the System Configuration(Control Panel > System and Security > Administrative Tools > System Configuration). Go to the Startup tab and search for Java (not Java SE Auto Updater), if there is one there, deselect the box next to it, Press OK, and restart.
  7. I found it from the task manager when i clicked the all users thingy button.
    I'll have to try.
  8. Before i did that i noticed java.exe is running my old 1.5.2 server that i think is chached. The MOTD is like 5 months old and so is the server. It's running the old map, but i don't have it saved anywhere anymore. only on my website (not running from my computer) I changed the map ages ago. Help me! How can i get the cache away

    On the startup tab there is only Windows 7

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 3, 2016
  9. Offline


    A cache is a temporary storage device that is wiped on shutdown (RAM, HDD Cache).

    The only way that could have really happened is if you either;
    A) Started it yourself
    B) Have a startup script that runs it/Windows started it(Startup Tab), and it's somewhere you can't find it. Try doing a search?

    The Boot tab might be where you are looking, not Startup. The startup tab displays all programs that start when the computers boots up.
  10. Nope, it started again on startup.
    A) No, I started my computer, opened minecraft, the server is on with 1.5.2.
    B) I did a search (with multiple diffrent keywords) and i only found:
    • The current server.
    • The test server where i test plugins offline.
    • Old backup of 1.6.2 motd.txt with ä and ö characters that appeared as ?
    • Some website logos...
    You mean Ohjelmat (Programs) tab?
    Only java i found there is Java(TM) Platform Auto Updater
  11. Offline


    Process Explorer is a slightly more in depth version on Task Manager. In an attempt to narrow things down, first look under;
    explorer.exe > cmd.exe and see if there is a java.exe running (Hopefully that makes sense).

    If it's not there go through and try search for the java.exe under each area (It may take a while).

    When you find it, right click and select Properties and under "Current Directory", it will tell you where it is being run from, eg;
  12. Ok, i'll give it a try. But why is java doing this?
  13. Offline


    DO NOT PUT AN IP IN server.properies. It is not needed. That should fix your problem. Anyways, just Go into Task Manager and End Java Processes.
  14. There is no ip in the properties. See that *:25565?
    Also you should read further...
  15. Offline


    As i said, just End all Java Processes and don't put 25565 in the IP in the server properties.

    Also, start the server before opening Minecraft. Minecraft will just open more Java Processes

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 3, 2016
  16. READ FURTHER so you can see what is the problem now (double facepalm)
    Also 25565 is the freaking port that my server is using!
  17. Offline


    I did read further, :oops: Try using this in the startup bat file.
    java -Xmx1024M -jar craftbukkit.jar -o true
  18. No!!!!! When i start my computer it starts my old server. I want that to stop!
  19. Offline


    What do you mean it starts your old server? It wouldn't start unless you opened the batch file.
  20. tonkku107 use process explorer to see the location of the old server, press rigth click on it, then select properties, to see the path

    Rogerzz you really need to read al the posts to see whats going on
  21. I opened the Process Explorer, it didn't show me the java.exe under cmd. When i opened my server it said again failed to bind port and showed a java.exe but that was for my current server. I also tried the show all users button but it wasn't there
  22. Offline


    Did you try doing a search in Process Explorer (Find > Find Handle or DLL) and search for java.exe?

    Make sure no known java.exe files are running(current server, Minecraft eg)
  23. Offline


    Try running
    as Administrator and find the PID there.
    Also if it's always restarting, it's probably something that starts on boot or logon.
    There are a bunch of locations where autorun programs can be, if you're lucky it will be shown in
    If you can't find it there, try using Autoruns
  24. Thank you! I finally found it!

    It was another server program that i tested so long time ago, now it wanted to start on startup...
    It was on ...\AppData\local\

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 3, 2016
Thread Status:
Not open for further replies.

Share This Page