Solved Hello I need help with this error I am having on my server Please Help

Discussion in 'Plugin Development' started by Danielh90, Aug 11, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Danielh90

    Code:java
    1. [17:43:54] [Server thread/INFO]: Starting minecraft server version 1.7.10
    2. [17:43:54] [Server thread/INFO]: Loading properties
    3. [17:43:54] [Server thread/INFO]: Default game type: SURVIVAL
    4. [17:43:54] [Server thread/INFO]: Generating keypair
    5. [17:43:55] [Server thread/INFO]: Starting Minecraft server on *:25565
    6. [17:43:56] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks (MC: 1.7.10) (Implementing API version 1.7.10-R0.1-SNAPSHOT)
    7. [17:43:56] [Server thread/ERROR]: Could not load 'plugins\epicraft.jar' in folder 'plugins'
    8. org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/danielh90/epic/Main : Unsupported major.minor version 52.0
    9. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    10. at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    11. at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    12. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:364) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    13. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.<init>(CraftServer.java:326) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    14. at net.minecraft.server.v1_7_R4.PlayerList.<init>(PlayerList.java:68) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    15. at net.minecraft.server.v1_7_R4.DedicatedPlayerList.<init>(SourceFile:14) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    16. at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:133) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    17. at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:436) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    18. at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    19. Caused by: java.lang.UnsupportedClassVersionError: com/danielh90/epic/Main : Unsupported major.minor version 52.0
    20. at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_67]
    21. at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    22. at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    23. at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    24. at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_67]
    25. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    26. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    27. at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_67]
    28. at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_67]
    29. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    30. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    31. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    32. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    33. at java.lang.Class.forName0(Native Method) ~[?:1.7.0_67]
    34. at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_67]
    35. at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    36. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    37. ... 9 more
    38. [17:43:56] [Server thread/ERROR]: Could not load 'plugins\SubCraft.jar' in folder 'plugins'
    39. org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/danielh90/subcraft/Main : Unsupported major.minor version 52.0
    40. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    41. at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    42. at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    43. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:364) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    44. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.<init>(CraftServer.java:326) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    45. at net.minecraft.server.v1_7_R4.PlayerList.<init>(PlayerList.java:68) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    46. at net.minecraft.server.v1_7_R4.DedicatedPlayerList.<init>(SourceFile:14) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    47. at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:133) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    48. at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:436) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    49. at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    50. Caused by: java.lang.UnsupportedClassVersionError: com/danielh90/subcraft/Main : Unsupported major.minor version 52.0
    51. at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_67]
    52. at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    53. at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    54. at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    55. at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_67]
    56. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    57. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    58. at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_67]
    59. at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_67]
    60. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    61. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    62. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    63. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    64. at java.lang.Class.forName0(Native Method) ~[?:1.7.0_67]
    65. at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_67]
    66. at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    67. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    68. ... 9 more
    69. [17:43:56] [Server thread/INFO]: [Essentials] Loading Essentials v2.13.1
    70. [17:43:56] [Server thread/INFO]: [ClearChat] Loading ClearChat v1.0
    71. [17:43:56] [Server thread/INFO]: Preparing level "world"
    72. [17:43:57] [Server thread/INFO]: Preparing start region for level 0 (Seed: 5775151342591454799)
    73. [17:43:58] [Server thread/INFO]: Preparing spawn area: 34%
    74. [17:43:58] [Thread-7/INFO]: ----- Bukkit Auto Updater -----
    75. [17:43:58] [Thread-7/INFO]: It appears that you're running a Development Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
    76. [17:43:58] [Thread-7/INFO]: If you would like to be kept informed about new Development Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'dev'.
    77. [17:43:58] [Thread-7/INFO]: With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
    78. [17:43:58] [Thread-7/INFO]: If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
    79. [17:43:58] [Thread-7/INFO]: ----- ------------------- -----
    80. [17:43:58] [Server thread/INFO]: Preparing start region for level 1 (Seed: -4135890054344571055)
    81. [17:43:59] [Server thread/INFO]: Preparing spawn area: 30%
    82. [17:44:00] [Server thread/INFO]: Preparing spawn area: 73%
    83. [17:44:01] [Server thread/INFO]: Preparing start region for level 2 (Seed: -4135890054344571055)
    84. [17:44:01] [Server thread/INFO]: [Essentials] Enabling Essentials v2.13.1
    85. [17:44:02] [Server thread/INFO]: Essentials: Using config file enhanced permissions.
    86. [17:44:02] [Server thread/INFO]: Permissions listed in as player-commands will be given to all users.
    87. [17:44:02] [Server thread/INFO]: [ClearChat] Enabling ClearChat v1.0
    88. [17:44:02] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    89. [17:44:02] [Server thread/INFO]: Done (5.579s)! For help, type "help" or "?"
    90. [17:44:04] [Server thread/INFO]: Plugins (2): Essentials, ClearChat
    91. [17:45:20] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 2602ms behind, skipping 52 tick(s)
    92. [17:45:21] [User Authenticator #1/INFO]: UUID of player Danielh90 is 7f954eef-7c2f-404a-bbbd-6872c3aeeb1f
    93. [17:45:21] [Server thread/INFO]: Danielh90[/127.0.0.1:60698] logged in with entity id 86 at ([world] -770.8794301945254, 56.0, 92.15282316158184)
    94. [17:45:34] [Server thread/INFO]: Danielh90 issued server command: /rankup
    95. [17:45:36] [Netty IO #1/INFO]: <Daniel> ./pl
    96. [17:45:37] [Server thread/INFO]: Danielh90 issued server command: /pl
    97. [17:45:38] [Server thread/INFO]: Danielh90 issued server command: /help
    98. [17:45:39] [Server thread/INFO]: Danielh90 issued server command: /he
    99. [17:45:43] [Server thread/INFO]: Danielh90 issued server command: /help 2
    100. [17:45:48] [Server thread/INFO]: Danielh90 issued server command: /customtext
    101.  

    I Don't now what i am doing wrong it worked couple of days ago i did not do anything to the plugin.yml and its with all my plugins
     
  2. Offline

    Funergy

    Do you have problems with exporting? Do you use the same Craftbukkit/Bukkit version? Is the right main class set in the plugin.yml?
     
  3. Offline

    Danielh90

    What Do you mean Iusing to code it is 1.6.4 Bukit and yes it is set to the right class
     
  4. Offline

    Funergy

    Look in you're stacktrace... MC: 1.7.10
    You are using 1.6.4 bukkit. Go grab the newest version 1.7.10 CraftBukkit at www.dl.bukkit.org
    You need to use the right version in you're coding program and server.
     
  5. Offline

    Danielh90

    Thank You idk if that was it :) and that link does not work
     
  6. Offline

    Funergy

    oh http://dl.bukkit.org/ for some reasons it doesn't work with www but okay here is the link.

    1.6 CraftBukkit =/= 1.7 CraftBukkit. they updated they're code.
     
  7. Offline

    Danielh90

    Do I get the recommend or the beta ?
     
  8. Offline

    Skionz

  9. Offline

    Funergy

    Get the 1.7.10 version
    That means you need to download the Development version. and if you don't wanna use the development version. download the beta version and change the old version with that version that you've downloaded on the server AND coding program
     
  10. Offline

    Danielh90

    Code:java
    1. [17:43:54] [Server thread/INFO]: Starting minecraft server version 1.7.10
    2. [17:43:54] [Server thread/INFO]: Loading properties
    3. [17:43:54] [Server thread/INFO]: Default game type: SURVIVAL
    4. [17:43:54] [Server thread/INFO]: Generating keypair
    5. [17:43:55] [Server thread/INFO]: Starting Minecraft server on *:25565
    6. [17:43:56] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks (MC: 1.7.10) (Implementing API version 1.7.10-R0.1-SNAPSHOT)
    7. [17:43:56] [Server thread/ERROR]: Could not load 'plugins\epicraft.jar' in folder 'plugins'
    8. org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/danielh90/epic/Main : Unsupported major.minor version 52.0
    9. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    10. at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    11. at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    12. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:364) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    13. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.<init>(CraftServer.java:326) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    14. at net.minecraft.server.v1_7_R4.PlayerList.<init>(PlayerList.java:68) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    15. at net.minecraft.server.v1_7_R4.DedicatedPlayerList.<init>(SourceFile:14) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    16. at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:133) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    17. at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:436) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    18. at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    19. Caused by: java.lang.UnsupportedClassVersionError: com/danielh90/epic/Main : Unsupported major.minor version 52.0
    20. at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_67]
    21. at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    22. at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    23. at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    24. at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_67]
    25. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    26. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    27. at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_67]
    28. at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_67]
    29. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    30. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    31. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    32. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    33. at java.lang.Class.forName0(Native Method) ~[?:1.7.0_67]
    34. at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_67]
    35. at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    36. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    37. ... 9 more
    38. [17:43:56] [Server thread/ERROR]: Could not load 'plugins\SubCraft.jar' in folder 'plugins'
    39. org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/danielh90/subcraft/Main : Unsupported major.minor version 52.0
    40. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    41. at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    42. at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    43. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:364) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    44. at org.bukkit.craftbukkit.v1_7_R4.CraftServer.<init>(CraftServer.java:326) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    45. at net.minecraft.server.v1_7_R4.PlayerList.<init>(PlayerList.java:68) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    46. at net.minecraft.server.v1_7_R4.DedicatedPlayerList.<init>(SourceFile:14) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    47. at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:133) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    48. at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:436) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    49. at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    50. Caused by: java.lang.UnsupportedClassVersionError: com/danielh90/subcraft/Main : Unsupported major.minor version 52.0
    51. at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_67]
    52. at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    53. at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    54. at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_67]
    55. at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_67]
    56. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    57. at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_67]
    58. at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_67]
    59. at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_67]
    60. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    61. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    62. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    63. at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_67]
    64. at java.lang.Class.forName0(Native Method) ~[?:1.7.0_67]
    65. at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_67]
    66. at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    67. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[bukkit.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    68. ... 9 more
    69. [17:43:56] [Server thread/INFO]: [Essentials] Loading Essentials v2.13.1
    70. [17:43:56] [Server thread/INFO]: [ClearChat] Loading ClearChat v1.0
    71. [17:43:56] [Server thread/INFO]: Preparing level "world"
    72. [17:43:57] [Server thread/INFO]: Preparing start region for level 0 (Seed: 5775151342591454799)
    73. [17:43:58] [Server thread/INFO]: Preparing spawn area: 34%
    74. [17:43:58] [Thread-7/INFO]: ----- Bukkit Auto Updater -----
    75. [17:43:58] [Thread-7/INFO]: It appears that you're running a Development Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
    76. [17:43:58] [Thread-7/INFO]: If you would like to be kept informed about new Development Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'dev'.
    77. [17:43:58] [Thread-7/INFO]: With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
    78. [17:43:58] [Thread-7/INFO]: If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
    79. [17:43:58] [Thread-7/INFO]: ----- ------------------- -----
    80. [17:43:58] [Server thread/INFO]: Preparing start region for level 1 (Seed: -4135890054344571055)
    81. [17:43:59] [Server thread/INFO]: Preparing spawn area: 30%
    82. [17:44:00] [Server thread/INFO]: Preparing spawn area: 73%
    83. [17:44:01] [Server thread/INFO]: Preparing start region for level 2 (Seed: -4135890054344571055)
    84. [17:44:01] [Server thread/INFO]: [Essentials] Enabling Essentials v2.13.1
    85. [17:44:02] [Server thread/INFO]: Essentials: Using config file enhanced permissions.
    86. [17:44:02] [Server thread/INFO]: Permissions listed in as player-commands will be given to all users.
    87. [17:44:02] [Server thread/INFO]: [ClearChat] Enabling ClearChat v1.0
    88. [17:44:02] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    89. [17:44:02] [Server thread/INFO]: Done (5.579s)! For help, type "help" or "?"

    Its still giving errors
     
  11. Offline

    xTigerRebornx

    Danielh90 Your server is running a lower version of Java then you've compiled your plugin with. Either update your server or compile with a lower version.
     
  12. Offline

    Danielh90

    how do i update my server java ? or updat it
     
  13. Offline

    xTigerRebornx

    Danielh90 Install the version of Java that you are compiling with or compile with a lower version.
     
  14. Offline

    Danielh90

    How do i check my compile java version is it with jdk ?
     
  15. Offline

    xYourFreindx

    In eclipse....
    >Eclipse
    >Preferences
    >Java
    >Intalled JREs
    Do your thing.
     
Thread Status:
Not open for further replies.

Share This Page