Having Read Timed Out/Connection Reset errors, CONSTANLY

Discussion in 'Bukkit Help' started by ClichedBluefish, Dec 5, 2011.


Are you getting Read Timed Out/Connection Reset Errors?

  1. Yes

    20 vote(s)
  2. No

    2 vote(s)
Multiple votes are allowed.
Thread Status:
Not open for further replies.
  1. Offline


    I am running CraftBukkit dev build 1550. The errors happen when certain players join, or sometimes completely randomly. The server freezes completely when these errors happen and I can't do anything. Here is my plugin list:
    [​IMG]I am running Java x32 I believe. I get no errors when the server freezes, just a "Read Timed Out" message.

    The server is running on a Mac OS X 10.6 with the latest Java software.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  2. Offline


    I'm having this same exact issue with 1559 and almost every single dev build prior to that. Frankly, I don't really think it's Bukkit but my host keeps telling me "If your server crashes suddenly without any errors , then its because of bukkit dev build."

    05.12 20:16:24 [Server] INFO Read timed out
    05.12 20:14:15 [Server] INFO Read timed out

    and then my server is down.

    BananaChunk - v4.6 - 1060
    Blue TelePads - v0.5.3 - 1060
    BookWorm - v1.8.2 - 1337
    BorderGuard - v4.20 - 1337
    CreativeColours - v1.3 - 1240
    CustomCrafting - v0.6 - 1240
    Essentials - v2.6.5 - 1337
    Factions - v1.6.1 - 1337
    FoundDiamonds - v2.0 - 1510
    GiftSend - v2.0 - 1337
    HeroSpawn - v0.2 - 1240
    LeaverBuster - v0.1 - 1337
    Minequery - v1.5 - 1337
    NoCheat - v2.20b - 1550
    OpenInv - v1.6.1 - 1550
    Permissions - v3.1.6 - 935
    Reservations - v1.3 - 1337
    Vanilla - v0.1 - 1185
    Votifier - v1.4 - 1337
    WorldEdit - v4.7 - 1337
    WorldGuard - v5.3 - 1185
    McMMO - v1.2.04 - 1549
    motd - v1.1.1 - 1337
    SpongeRestore - v1.2 - 1337
  3. Offline


    Thank god, at least I know I'm not alone. This actually hasn't happened at ALL until I upgraded the server to 1.0.0, and it's really pissing quite a few people off, because my server is supposed to be running 24/7, which it normally does.

    I'm going to try 1559 myself and see if I get the same problem.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  4. Offline


    Ditto. I didn't start my server until 1.0.0 so this is all I've known for the last 10 days. Crash after crash of at least 15 different dev builds numbering back into the mid1400s. Once in a while the "Heroes" plugin would spit out a SEVERE about "SEVERE Could not pass event ENTITY_DEATH to Heroes" and something about player login but I disabled it and it wasn't anywhere near the issue, I've crashed like 3 times in the last hour. Sometimes it will go a few hours but that's still nowhere near long enough.

    I'm new to this, and I've been troubleshooting myself and removing and testing plugins to find the issue because I didn't want to feel like a nub if I posted about it, but seeing your thread gives me hope that this isn't my fault, nor my plugins.

    All we have in common are essentials, permissions, and worldedit. EDIT: and that was a mis-read due to a linebreak. just essentials and worldedit...
  5. Offline


    I removed WorldEdit, because I heard on a different thread that it may have been causing the problem. The crashes happen less often without it, though they still do happen. I haven't experienced any crashes on my server yet after upgrading to 1559, but then again it's only been running for 15 minutes and I'm the only one that's been on it. Which reminds me. It almost never crashes when it's just me on the server.

    What would you know, as soon as I said I hadn't gotten any errors with 1559 yet, and that the server almost never crashes when I'm on alone... Guess what just happened...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  6. Offline


    I know exactly how you feel. I'm using Avante for my host, don't know if that matters (for anyone who wanders in to try and help us).

    ...So it isn't WorldEdit, then. >.< and tons of servers use essentials so that can't be it......
  7. Offline


    We're definitely not the only ones getting this problem. I searched around a bit. Apparently quite a few other people are. No one has come up with a reason or a fix yet. If it helps I host the server on my own computer. I would really appreciate some help from a Bukkit Developer or someone involved with Bukkit...
  8. Offline


    that's my greatest concern. i'd love to sit on "oh, it's dev build that's the issue" but at this point i'm almost certain an RB is going to come out and these crashes will still be happening.

    Just crashed, went about 2 hours without one.

    halp us plz :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  9. Offline

    Nathan C

    You are using a dev build, what do you expect?

    Latest dev build does not mean it is more stable. In fact, it can be even worse, try downgrading to an older dev build.
  10. Offline


    sorry, i may not be the most privy thing on earth when it comes to running a server, since i've only been going about two weeks....

    but i have used older dev builds. As I mentioned, I've used at least 15 (probably closer to 25 or 30) dev builds since around 1470, and I bet Cliched is in the same boat.

    I don't know what to expect. I expected instability and a lack of compatibility. I did not expect absolute volatility. :p If other servers can run the same builds as Cliched and I are, then why are we crashing incessantly? I wholeheartedly (and genuinely) don't understand how it can just be the fact that it's a dev build if other servers aren't being crippled, too. But I guess I can just attribute that to being new at this...? :p :(
  11. Offline


    I believe this actually has nothing to do with dev builds at all. Foxwillow is correct, I have used almost every single 1.0.0 dev build, and still get the same problem. I was even getting read time outs with 1337. I did some research and found that it may have to do with my IPS, but this most likely wouldn't be the case for you foxwillow, since your server is hosted by Avante.
  12. Offline


    Ok, lets start with the first part, how do you start your server? Meaning what is the command line you are using to start the server?
  13. Offline


    I believe this a good way to start as well, the code I'm using is:
    cd ~/Dropbox/MagnaCraft
    java -Xincgc -Xmx4096M -jar CraftBukkit.jar
    I use DropBox so I can sync with my laptop and work on my server from my laptop. Maybe this has something to do with it?
  14. Offline


    ok first try changing your -Xmx to -Xmx1024M and see what happens.
  15. Offline


    How would lowering the RAM help? Or am I completely wrong and that's not RAM at all XD. Who knows, I taught myself everything I know, so I could be completely wrong XD. I will try using this starting code instead and see what happens.
  16. Offline


    Well you are running a 32 bit java that limits your ability to use more than 1.5gb of ram, what you are telling the machine to do is not possible with 32 bit. How much ram does your machine have?
  17. Offline


    @foxwillow - You're running Permissions 3? There's your problem.
  18. Offline


    4 GB, but I'm getting an RAM upgrade this weekend for 16GB. I'm using a iMac 27", is it possible to upgrade to 64 bit java?
  19. Offline


    I am not a mac guy so i don't know whether your machine is 64 bit or not, if the processor and os are 64 bit you can use 64 bit java if they are not 64 bit java wont work. With 4 gb's of ram on your machine you are probably crashing due to the java virtual machine running out of memory or something like that. by reducing the amount of ram java is trying to use it should limit your crashes, maybe.
  20. Offline


    Yes but won't it also slow down the server drastically?
  21. Offline


    server speed depends on a lot of different things, your cpu and inet connection speeds as well as your disk i/o will have more of an affect on lag than the amount of ram you have. I have 5 to 6 people on a vps and only run out of ram at 1gb when doing large world edit paste commands. but a slower server versus one that crashes all the time I guess is a choice you can make if the lower ram solves the crashing issue.
  22. Offline


    I have 50Mbps Verizon Fios and my server starts in around 0.5 seconds
    Do you think I'll be ok?

    The server I'm running is public with about 4 people average at a time.

    Well anyway thanks for all your help :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  23. Offline


    well, lets see if the lowered ram amount fixes your crashing issue, your inet speed will host as many players as you want, the only limit you will have is the cpu and ram, both of those will come to play when you go above 10 or so players at a time. disk i/o will have an affect on lag so when u upgrade your ram see if you can do ram disks of some sort for your worlds files.
  24. Offline


  25. Offline


    I start my server, in 4-5 hours they work fine. In about 5 hours, lag and map don't load some chunks. One our later, Connection Timed Out,

    #1561 since #1555 apx.
  26. Offline


    Got the same problem sometimes it crashes every 15min and sometimes once in like 5-6 ouhrs :(
  27. Offline


    That's kind of a lame excuse. Many people are using dev builds and not experiencing their problems. It's plugins.
  28. Offline

    Nathan C

    Ok, let me ask you this.

    Are you guys using the /reload command by chance?

    Because my server can stay up 24/7 without crashing. Although if I even use the /reload command once, it will read timeout after about 3 hours.
  29. Offline


    Guys I think I found the problem, at least for me. I updated Essentials to Dev2.7.159 and I am no longer getting read timed out errors.
  30. Offline


    Did the same hoping it wont crash!

    Still the same :( did not work meh.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
Thread Status:
Not open for further replies.

Share This Page