Having a weird error msg plz help i just want to have fun with friends

Discussion in 'Bukkit Help' started by BloodyWolf643, Aug 22, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    1.Dell Inspiron Windows 7x64
    4.No I am doing a version with no portfowarding or hamachii
    6.#Minecraft server properties
    #Fri Aug 22 23:06:24 CDT 2014
    motd=A Faction Server(Currently Under Maitnece)
    6.[19:39:53] [Server thread/INFO]: Starting minecraft server version 1.7.10
    [19:39:53] [Server console handler/ERROR]: Exception handling console input
    java.io.IOException: The handle is invalid
    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.6.0_29]
    at java.io.FileInputStream.read(Unknown Source) ~[?:1.6.0_29]
    at java.io.BufferedInputStream.fill(Unknown Source) ~[?:1.6.0_29]
    at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.6.0_29]
    at java.io.FilterInputStream.read(Unknown Source) ~[?:1.6.0_29]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader$1.read(ConsoleReader.java:167) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:267) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:204) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readCharacter(ConsoleReader.java:995) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLineSimple(ConsoleReader.java:1506) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:1153) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:1117) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:1105) ~[craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    at net.minecraft.server.v1_7_R4.ThreadCommandReader.run(ThreadCommandReader.java:34) [craftbukkit-1.7.10-R0.1-20140817.180155-16.jar:git-Bukkit-1.7.9-R0.2-24-g07d4558-b3116jnks]
    [19:39:53] [Server thread/WARN]: To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    [19:39:53] [Server thread/INFO]: Loading properties
    [19:39:53] [Server thread/WARN]: server.properties does not exist
    [19:39:53] [Server thread/INFO]: Generating new properties file
    [19:39:53] [Server thread/WARN]: Failed to load eula.txt
    [19:39:53] [Server thread/INFO]: You need to agree to the EULA in order to run the server. Go to eula.txt for more info.
    [19:39:53] [Server thread/INFO]: Stopping server
    [19:39:53] [Thread-4/INFO]: Stopping server
    7. "C:\Program Files (x86)\Java\jre7\bin/java.exe" -Xmx1024M -jar craftbukkit.jar -o true
    PAUSE other one didnt work so i had to find a different way and this let me on.
    8.World Edot and World Guard
    9.No one can join
    10.I cant think of anything to try for this problem
    11.None of those go with my problem

    Jaguar what did u edit?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 9, 2016
  2. Offline


    I didn't change anything. The reason it has that little "edited by" thing on it is because your post got sent to the moderation queue to wait for approval, I was the person who checked it, and then said it was okay for everyone to see. Generally speaking, if I do change something in someone's thread, I'll add a little [edit by JaguarJo: explanation of what I did and why] to the bottom of it.

    The moderation queue is an automatic thing that kicks in for all new forum members for your first handful of posts. After you've been posting for a little while, your posts won't have to go through it anymore. The main purpose of this automated queue is to catch spam bots that join the forums and then try to post spam advertisements all over the place. It's really effective; we catch a lot of them. A secondary reason we have it is to make sure that new forum members are following basic posting guidelines, since sometimes new people don't read through the forum rules before they post. This helps us keep an eye out for blatant forum trolls.

    As for your actual thread topic, I personally don't know much about that console error, so I'm afraid I'm not much help in this instance. I did notice that it says you still need to open up the eula.txt and agree to it before the server will run though.
  3. Offline


    I have done that want me to copy paste it?

    sorry kinda new to this

    i have loaded the server multiple times

    #By changing the setting below to TRUE you are indicating your agreement to our EULA (https://account.mojang.com/documents/minecraft_eula).
    #Fri Aug 22 17:21:05 CDT 2014

    [edit by JaguarJo: merged posts. Please use the edit option to add onto your post if yours is the most recent comment. Otherwise it end up getting spammy. Thanks.]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 9, 2016
  4. Offline


    You could paste it if you want. Just a tip: it's helpful when pasting files if you either use the code button in the comment toolbar or paste your file to pastebin.com and give us a link to it. That helps preserve your file formatting.
  5. Offline



    Do you want me to do that?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 9, 2016
  6. Offline


    Since you already posted it up above and it's such a small file, you don't need to bother with the pastebin. That was more of a general tip for pasting longer files and files where the spacing matters a whole lot, such as YAML files.

    Does your server startup still look the same as it did in your first post, now that you've agreed to the eula?
  7. Offline


    I have tried aton of ways but they always end up being for port fowarding or hamachii and i did it with niether

    i have had the eula agreed since the second time i ran it

    I can do it right now if you want me to

    [edit by JaguarJo: merged posts again. If the edit option doesn't seem to be showing your text, try using the button that says "more options" to open up the full editor. That should let you see your full post and you can then add onto it.]

    i also made it into a domain and the domain name works fine for me but no one else can get on

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 9, 2016
  8. Offline


    What domain did you use?
    Go daddy...?
  9. Offline


    Well generally if you're running the server on your own computer, then the way you join isn't going to be the same as the way other people join. You will need to port-forward if you want people outside your network to be able to join your server. This is because you are able to join with your local network but other people are on the outside of your modem and router and for them to access your server you need to have the port open for them.

    My server doesn't have a domain name, it's just the IP numbers. That's kind of just a preference thing depending on how you want your server to look.
  10. Offline



    I know that i have to use ip4v ip not my external ip

    If yall want to try my external code to get on you can i have no clue what it says but i know it doesnt let you join

    [edit by JaguarJo: merged posts again. Seriously, learn to use the edit button.]
  11. Offline


    Try a quick fix:
    Press your windows key and search:
    Allow a program through windows firewall (Or just go to firewall + Then on side press Allow a program through windows firewall)
    Then you want to go down to java and change settings and allow all java on public and private and make sure their checked on the left side too!
  12. Offline


    lilkj ill try it but i didnt do port dfowarding or hamachii
  13. Offline


    Oh lol you really need to port foward, that is the only way anyone can join silly :p
    If you need help on how to port foward ask me :)
  14. Offline


    likj i had 4 javas each one the same i marked all as to pass through

    well i have seen alot of yt vids on how to do it
    they got people on

    likj do u wanna try to get on my server now?

    [edit by JaguarJo: merged posts.]

    Well could you help me on portfowarding? or could i do hamachii instead?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 9, 2016
  15. Offline


    BloodyWolf643 I had to remove your post with the IP addresses in it. I know you're trying to troubleshoot your problem, but server advertising is still not allowed in this section regardless.

    Also, your posts are starting to get a little too spam-like. If you think of more you need to say and yours is the most recent comment, then you need to edit your comment to add onto it with your new thoughts. Stop making lots of little posts one after the other.
  16. Offline


    okay how do i merg?

    Is likj still here?

    [edit by JaguarJo: merged posts.]
  17. Offline


    Yes do you have skype?
    Add me on skype Lilkj9503
  18. Offline


    lilkj can i just use hamachii or do i have to portfoward?

    I have Skype but forgot password
  19. Offline


    You can't merge posts, what you want to do is called edit. There is a little button at the bottom of the comment section that says "Edit". Click that and if it doesn't show your comment correctly (some browsers don't work right for this part), then click on another button that says "more options". That should show everything correctly. At that point you can add onto your comment with whatever else you want to say.

    Helpful side tip: to make sure someone knows that you have replied to them, you can hit the "Tahg" button on one of their comments and it will add their name to your comment along with sending them a little alert that you're talking to them.

    I just noticed this; was that just a typo or is it how your startup script actually looks? You have a / where you want a \ in there. Try using this one:

    "C:\Program Files (x86)\Java\jre7\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit.jar -o true

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 9, 2016
  20. Offline


    I will try it
Thread Status:
Not open for further replies.

Share This Page