Question Group Manager Permissions for Plugins

Discussion in 'Bukkit Help' started by Scurl, May 20, 2019.

Thread Status:
Not open for further replies.
  1. Hello, it's me again. Back in 2017 I created a post regarding basic permissions and stuff. I hade huge troubles setting the most basic things up, timtower tried to help me with that. The original post is still here:

    First things first, the server I am playing on is only for me and my friends, so I don't need groups or rankings.
    1.12.2, newest Vault.
    I am not using a lot of plugins. I want us to be able to use every single Plugin without being OP'd (i.e. ChopTree).
    I am using GroupManager and I've read this guide (, watched several tutorials on youtube and set everything up as described there.
    I don't need people to be able to use any chat commands, since we don't have any at the time besides the standards (maybe it'll come, but I won't worry about it since we want to keep it almost vanilla).
    I set myself as the "Owner" and everyone else as "Builder", yet when placing a block, we get the message: "You can't do this" (but it still places it), also no plugin works for us and I (owner) can't issue any commands. I am not OP'd in the "ops.json" but I think I don't have to since GroupManager does that instead..?

    Without adding any specials, how can we use the plugins without being OP'd on the server?
    The ChopTree Plugin says "ActiveByDefault: true"

    GroupManager DOES get some errors on startup, even if I just added one Plugin to the list for testing, here is the GroupManager message from the server startup:

    GroupManagers "user.yml":
    GroupManagers "groups.yml":

    Error (full):
    Last edited: May 20, 2019
  2. Online

    timtower Moderator Moderator

  3. Online

    timtower Moderator Moderator

    @Scurl Line 4 needs a space after the colon.
  4. Already tried that before, didn't work.
    I also changed line 32 in the groups.yml and pasted it in between 27 and 28 without the g:
  5. Online

    timtower Moderator Moderator

  6. Edited in starting post
  7. Online

    timtower Moderator Moderator

    Scurl likes this.
  8. Seems to work for almost everything, besides the server commands, like "/time set" or "/gamemode"
    Also when joining the server as a new player, I don't get the default group set, the user.yml doesn't get edited.
    I would have to set the groups manually, even the default one (which is Builder in that case)
    Last edited: May 20, 2019
  9. Online

    timtower Moderator Moderator

    Default users don't get put in the user.yml, they don't need to.
    What is the group that you have when you join?

    And how do they not work?
  10. So the plugins seem to work now, as long as I am builder and the default group (builder) has the permissions set.
    But when I am "Owner", I can't issue commands, even with the permission '*'
    At first it didn't work automatically and I had to set in manually, but now it seems to work:

    On startup, my name (blacktiger810) seems to get added to the "users.yml" as following:

    lastname: Blacktiger810
        group: Builder
        subgroups: []
        - groupmanager.noofflineperms
    Alright, I found my mistake. I tried editing it in the file itself and then restarting the server. Using the server commands it semms to work.
    Can't believe I finally made it xD
    Thank you sir!

    Edit: Some basic server commands like "time set" or "weather clear" don't seem to work, but "gamemode" does. Should I delete the remaining two lines?:

    - -vanish.effects.*
    - +vanish.effects.toggle.allmanuadd

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2019
  11. Online

    timtower Moderator Moderator

    @Scurl Define "not work"
    And you could remove them.
Thread Status:
Not open for further replies.

Share This Page