Greatest Plot Plugin that never got noticed...

Discussion in 'Plugin Requests' started by DarthMike, Feb 8, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    DarthMike

    Good day to all, I have currently been on the hunt for a plugin called PlotClaim that no longer exists. Now I have no Idea why such a plugin would just die like it did because it is THE BEST plot plugin I have ever used. I have tried to contact the author "Zethien" but apparently he no longer logs in or checks the associated email so I am at a loss. <editsnip>

    Here I am. I need a Pro's help on this since I am nowhere close to coding the way others do on java savvy plugin creators. Now before you start posting "use plotme" or "plotty" or whatever else you think is a "great plotting plugin" try this plugin, download an old version of minecraft 1.7 and be amazed! I dislike other plotting plugins and have just never even gone back to a plotting plugin after 1.7. Thats how much I need this plugin.

    Please help me out guys.

    Thanks in advance.

    MSU


    [edit by moderator: please do not include monetary commentary in posts]
     
    Last edited by a moderator: Feb 8, 2016
  2. Online

    timtower Moderator Moderator

    @DarthMike Why not just install it on 1.8 and see if it works?
     
  3. Offline

    DarthMike

    Well thanks timtower for your fast response, but I guess I didnt state on the post that I had already installed it and is not working. I thought that it would be self explanatory when I mentioned I needed it to be updated for 1.8, but thats what I get for ASSuming.
     
  4. Online

    timtower Moderator Moderator

    @DarthMike Running an 1.4 plugin here without issues.
    Could you post your full server log using http://pastebin.com so that we van see what the issue might be.
     
  5. Offline

    DarthMike

    OK Dude, you almost got me there, you made me feel a little bad, let me tell you that. You had me kicking myself for like the first hour on how you could get it to work and not me and cursing at myself the other cause I could not find the plugin you stated in your post. Maybe... just maybe, this is my fault again. For I did not provide a link to the plugin and you downloaded some other plugin that is NOT called PlotClaim as I stated in the first post. So, im gonna paste the here, and see if this time you can try it out again. There is no 1.4 version I googled MY A$$ OFF!
    http://dev.bukkit.org/bukkit-plugins/plot-claim/

    not cool dude...
    not cool...
     
  6. Offline

    teej107

    @DarthMike Does that plugin throw errors in the console? Most plugins should work across multiple versions.
     
  7. Online

    timtower Moderator Moderator

    @DarthMike Never said that it was that plugin either, it is a private one due to security risks in it.
    Could you still post your log?
     
    shades161 likes this.
  8. Offline

    DarthMike

    OK Dude, thanks for your help, and I dont want to be a douche or anything, but if you read my first post the plugin is stated right there. Anyway here is the pastebin address.
    http://pastebin.com/GK1XEYQh

    It happens everytime with any bukkit or spigot over 1.7.9
     
  9. Online

    timtower Moderator Moderator

    @DarthMike That is due to the fact that the worldguard API changed, downgrade worldguard to before 6.0 on the 1.8 server and it should work
     
  10. Offline

    DarthMike

    Ooorrrr maybe $omeone here might be nice enough to help me out by updating thi$ plugin$ code $0 that it work$ with the current WorldGuard plugin ver$ion, a$ the very nice moderator ha$ $tated. I$ anyone intere$ted in making thi$ po$$ible? I know I would apreciate it $o $o much!

    BTW, thank you for taking the time to look at problem timtower.

    M$U
     
  11. Offline

    MCJoshua345

    @DarthMike
    https://www.dropbox.com/s/jztb7s6oanxvp85/PlotClaim.jar?dl=0
    I upgraded it to CraftBukkit 1.8.8, so it works on any CraftBukkit version.
    I upgraded it to WorldGuard 6.1 and WorldEdit 6.1. It should work on any newer WorldEdit and WorldGuard versions.
     
  12. Offline

    DarthMike

    Hi MCJoshua! :) Thank you for trying that out, I was really very exited about it. Maybe you uploaded the old version by accident? I get the same error as you can see here. Could you maybe check to see if that was the case, if so im very anxious test it out.

    MSU
     
  13. Offline

    MCJoshua345

    @DarthMike

    I'm looking into it.
    Next time please tag me because I did not notice your post until now.
    (BTW, that is not the same error.)

    EDIT: I'm not sure what the problem is. Could you please tell me your Java version?

    EDIT 2: I have looked into the problem. I am using Java 8 to compile this plugin. If you are not using Java 8, then I suggest you switch, or have me compile it with Java 7.

    EDIT 3: I have just tested the plugin with Java 8. The plugin boots up correctly.
     
Thread Status:
Not open for further replies.

Share This Page