[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    does this work with Permissions 3?
  3. Offline


    Do you have WorldEdit? It is required to run CommandBook. If you don't want to use WorldEdit, it can be used as a dependency if you place the WorldEdit.jar in the CommandBook plugin folder.
  4. Offline


    I have the same question. Our server has a guest group which cannot build/mine and has no permissions except op.list (from OpPermissions 0.03), but guests can still use /item and /give. /teleport doesn't work, haven't tried any others. I even tried setting -commandbook.* and -commandbook.give, but they can still spawn items.

    1000, Permissions 3.1.6

    EDIT: /teleport does work for guests, as does everything else it seems. What's the deal? :/

    EDIT again: Never mind, I was being an idiot. A quick server reload did the trick. Great plugin! Especially loving the infinite stacks. :)
  5. Offline


    Is there any way to make mobs spawn at the reticle's target instead of directly on top of you? Essentials had this, but I dumped it in lieu of your plugins, which I happen to like a lot more.
  6. Offline


    I'm pretty certain /spawnmob chicken 32 #target will spawn 32 chickens under your reticle.
  7. Offline


    I'm having a problem with /item's permissions
    Both /i and /items result in "no permission" or "you don't have permission"

            - commandbook.give.*
            - commandbook.more
            - commandbook.kit.*
            - commandbook.item.*
    I added the item* for a test just in case but I have no idea why it is not working :/

    Can anyone help?
  8. Offline


    The node is

    - commandbook.give
    - commandbook.give.*

    for the item command.

    Top one:
    Rileyb80 likes this.
  9. Offline


    >.> that is so confusing I assumed that give.* would give it but thank you it'd be nice if he made that clearer on the wiki :D
  10. Offline


    Is there any log which shows command using?
  11. Offline


    I seem to be having an issue with the /time -l command. When I try to lock the time, it causes Weird/Bad Lag on the map in question.. Redstone wont work right and every mechanical thing with it, even liquids don't flow right.

    Not sure if it's because when it locks the time, it's just resetting it every second or so.
    I don't suppose you could add a way to Lock the time BETWEEN 2 times. So for example, I could have the Sun instantly go back to 9am every time the sun gets to 7pm. Of course this would be fully customizable.

    This way we could have maps that are always day, or night, but (I hope and assume) wont have that weird lag issue.

    With the time only resetting say every 5 minutes, instead of every second, do you think that would help fix the lag?

    I really hope this can be fixed somehow, I like having a night map, and an always-day creative map.
  12. Offline


    @OkinKun that sounds like a good idea, I'd like to see that too!
    And yes, the whole redstone/liquids thing IS caused by locking the time.
  13. Offline


    Is there any way to make this the default behavior is what I am actually asking. Having to type that extra parameter is a bit annoying.
  14. Offline


    Bit confused here. I know you can use the /kit command to give a kit to someone remotely with "/kit <kit> <name>" but only the owner (me) seems to be able to do that. I cannot see a permissions node for this action so how do I let others do it? I want my Admin team to be able to give out kits to others too/

    Anyone know?
  15. Offline


    can that be that commandbook disable the bed funktion?
    all users allways spawn at the spawn. xD

    sry for bad english. :DD
  16. Offline


    i got spawn issues.

    Since i have switched to commandbook im unable to setspawn at the right spot it spawns players where
    the original spawnspot was.. /setspawn or /spawnset , /spawn set / set spawn all does nothing but say command unknown??

    any suggestions ?
  17. Offline


    I have the following SEVERE warnings on my server:

    2011-08-12 17:50:47 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    2011-08-12 17:50:47 [SEVERE] Could not load 'plugins\CommandBook.jar' in folder 'plugins':
    unacceptable character #FFFD special characters are not allowed
    in "<reader>", position 285
    at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:68)
    at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:159)
    at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:117)
    at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:106)
    at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(ScannerImpl.java:964)
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:237)
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
    at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produce(ParserImpl.java:200)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:104)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at org.bukkit.util.config.Configuration.load(Configuration.java:82)
    at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:157)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:175)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:207)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:130)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:51)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    Any ideas why? I have deleted and uploaded the current commandbook.jar several times.
  18. Offline


    You've just used a character that it can't print, either in your motd or rules or something. Just look for any non-english characters that might be a problem.
  19. Offline


    @Vaupell do you use wormhole extreme? It uses setspawn, so does essentials spawn...and many many others..
  20. Offline


    after using commandbook players are often invisible for another players until often relogging
  21. Offline


    I am begging for /who color support/permission groups support!
    3 online out of 20.
    Admin: Sayshal
    Builder: WHOO_GBS
    Default: austinzappy

    Obviously, I can't add white or you couldnt read it, so all black text is supposed to be white!
    Afotai likes this.
  22. Offline


    yep, been banning alot of people i thought was haxing ;) invisible players.
  23. Offline


    Same here
  24. Offline


    Icant find the file for "muted" players is there any file for that?
  25. Offline

    Bios Element

    I still can't get /spawn to work. Everything else works and I'm sure I have CommandBook.spawn but it's still bugged. Anyone have suggestions on what it might be?
  26. Offline


    no. but i think there is an /ismuted
  27. Offline


    Where is online parser? I tried the free yaml thing but it did not tell me anything.
  28. Offline


    didnt work
  29. Offline


    I recommend another banning/muting system. Commandbooks' lacking. Try KiwiAdmin?
  30. Offline


    commandbook is great and its not ban/kick im having problem with its just muted players
  31. Offline


    I'm having troubles getting the /tp command to work with my mods. It works for me (admin) however. The odd thing is, that the same permission nodes the control /tp also control /s... and they can /s to bring a player to them no problem.


    Here's my permissions:

            default: false
                prefix: ''
                suffix: ''
                build: true
            - Architect
            - waypoint.warp.access.mod
            - waypoint.home.access.mod
            - commandbook.time.lock
            - commandbook.kick
            - commandbook.bans.*
            - commandbook.debug.*
            - commandbook.clear.*
            - commandbook.broadcast
            - commandbook.teleport
            - commandbook.teleport.other
            - commandbook.teleport.coords
            - commandbook.locations.coords
            - commandbook.warp.*
            - commandbook.return
            - commandbook.call
            - commandbook.more
            - commandbook.more.infinite
            - mcmmo.*
            - vanish.*
            default: false
                prefix: ''
                suffix: ''
                build: true
            - '*'
            - waypoint.warp.access.admin
            - waypoing.home.access.admin
Thread Status:
Not open for further replies.

Share This Page