[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    Great! Now I have a give command that works :) Also msg and reply. Does reply work with the shortened /r?
  3. Offline


    Yep! The wiki has a list of all the aliases.
  4. Offline


    WOW! thank you man. You rule

    you get 10 out of 5 diamonds! [​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG]
  5. Offline


    Oh noo!

    [SEVERE] Could not load plugins/CommandBook.jar in plugins: null
    	at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:80)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    	at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
    	at java.lang.Class.forName0(Native Method)
    	at java.lang.Class.forName(Class.java:264)
    	at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:72)
    	... 8 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandPermissionsException
    	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    	at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:30)
    	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    	... 11 more
    Running perms 2.4, CB 477
  6. Offline


    Owner of the above server - we're really eager to be able to switch to this and get rid of Essentials for good, so we hope you can help us work through that issue.
  7. Offline


    Works great! I was looking for a clean plugin that will support all of these features without a bunch of junk in it.

    I know you directed users to the MyHome addon for the individual homes for players, but is there any possibility of adding a /home /sethome command into this? MyHome is getting a lot of errors currently while I haven't had any problems with your plugin yet.

  8. Offline


    I've had this with worldguard update to the latest version of craftbukkit :)
  9. Offline


    Make sure you have WorldEdit and update it.

    If you still have problems, tell me.

    I currently don't plan to add home commands. It's a bit complicated at the moment since Bukkit doesn't provide a way to store data, and I think a different plugin is better suited to it.
  10. Offline


    Updating WE did the trick, thanks!
  11. Offline


    just to let you know, you can give yourself slab:5 which will work in bukkit, but freeze the players :S

    also, /item slab:wood and aliases as such do not work.
  12. Offline


    I'm officially requesting you to make a /pong or /ping command so that it will let you see how much lag may be on the server based on its return time - is this possible Sk89q?
  13. Offline


    /setspawn possibility?
  14. Offline

    Crazy Crack

    I personally love how i can trust the effectiveness and reliability of your mods working, keep on the excellent work. + simplicity of use
  15. Offline


    Great work once again!
    Deleted user likes this.
  16. Offline


    Setspawn would be greatly wanted too.
  17. Offline


    I'll look into /setspawn. 1.3 broke my /setspawn, and I haven't looked into a proper way to do it.

    And I'll look into those above issues.

    @Kainzo: Not possible. I could add a dummy /ping command that says "pong" or something, but to actually measure response time, a client modification would be required. It'd have to start a timer when you sent "/ping" and then subtract the new time upon receive of the pong in order to get the latency. I could, however, theoretically add a tool to average the number of ticks per second or other time unit, and that'd give you essentially the FPS of the server.
  18. Offline


    Second Life servers used to have a server FPS statistic as well - it really helped give you a heads-up that the server wasn't keeping up.
  19. Offline


    Nice one @sk89q , but I'd stick with Essentials for a while. :) It's glitchy but has some more features.
  20. Offline


    Yeah - just adding in a dummy response - as if you were typing in chat - is what i meant - it would be exactly like typing in chat except no one else would hear you and you would get verification back.
  21. Offline


    Thanks for the General replacement! This seems to be overriding /tp from TelePlus and /motd from LoginMessage. Is there any way I can have them handle those commands while your plugin does the rest? I'm probably missing a simple fix. Thanks and keep up the good work.
  22. Offline


    Any way to restrict item & give? Otherwise, I would be using it right now!

    Unless it's already OP only?

    EDIT: nvm :)
  23. Offline


    I used to need like 10 plugins for all of this, and it was a pain when one of them had to be updated.
    sow YES HELL YES, YES.
  24. Offline


    i have a problem, the plugin ignores my permissions so, the admin can use them but noone else, i gave everyone the same permissions
    bukkit #444
    permissions 2.4
    Worldedit 4.0 beta8

            default: true
                build: true
                - 'CommandBook.who'
                - 'CommandBook.motd'
                - 'CommandBook.spawn'
                - 'CommandBook.msg'
    that are my permissions
  25. Offline


    ya know what. I'm gonna say screw it and say i LOVE YOU.
    You're most of my commands on my server.

    I wish you as a person were a plugin xD

    edit: Any chance you can shorten the /give command like it was in hmod.
    what i mean is.
    by default when i type
    /give 4 64
    It gives the person who used the command it, without having to type there username.
  26. Offline


    Kindly requesting a 'more' command, (shamelessly stolen from PlgEssentials) refills the stack of whatever you're holding to 64 units of whatever is in your hand...
  27. Offline


    :D finally. A great dev made a great general plugin. Thank you.
  28. Offline


    Version 1.1

    Note: You will need to upgrade to build 479 (required by /setspawn).

    • Added item data value aliases for dye, slabs, double slabs and wood.
    • /ping added as requested by Kainzo. This sends back a dummy reply so you don't have to spam chat with test messages. No permissions are required for its usage.
    • /setspawn [location] added. It uses commandbook.setspawn for permissions.

    You can either download commandbook-1.1 or customize it for your needs (if you've got another plugin you want to use for a function instead).


    Keep "CommandBook." lowercase.

    Use /item or /i.

    I'll look into adding that. I'll likely add a function to make a stack -1 too, as that's something I've wanted for a long time now.
  29. Offline


    Thank you so much for releasing this to the public, and for the tip about not actually having worldedit running to use commandbook. Not that I dont love worldedit, its just I run a survival centric server and running worldedit is kind of out of place and wouldnt be used. Also the customizable commandbook is very impressive!
  30. Offline


    • CraftBucket v440
    • World Edit 4.0 beta 8
    • Permissions (Phoenix) 2.5.1
    • CommandBook v1.1 (I realize the setspawn command reqs. a higher developmental build, but decided to hold off on that specific function as the newer build 480-something breaks a # of other plugins).
    The issue at hand is that I am having problems with anyone (aside from myself as the sole admin with * perms) being able to use any of the commands in this plugin. In fact, the only way I can find a way for them to work is by OPing them - the exact opposite of what I am seeking to achieve by using this and similar mods.

    For whatever reason, the permissions are not being recognized. I did some testing with WorldGuard configurations, regarding what groups are allowed certain abilities (or are ignored for certain limitations like lava buckets) and WG works just fine now. Still, however, no luck with anything related to CommandBook aside from being able to check the time via "/time." Anything else from TPing to MOTD are returned as "You do not have permission." I've even tested by copying over the specific perms to the user (instead of or as well as the group - tried both ways) and have had no success.

    Your assistance would be welcome! Thanks.
Thread Status:
Not open for further replies.

Share This Page