[GEN] SignReadMore v3.3 - Sign/Bookshelf linked to read more text (PERMISSIONS) [740]

Discussion in 'Inactive/Unsupported Plugins' started by Milton, Feb 21, 2011.

  1. Offline


    SignReadMore - Allow read more on Signs/Bookshelfs
    Version: v3.3

    Now with *COLOR* support and *PERMISSIONS*!

    Allows an users to associate a text file to a Sign post/Bookshelf in Minecraft. When a user right-clicks the Sign-Post/Bookshelf, a message contained in the associated text file will be displayed to the user.

    • Allows users to read more info about a Sign/Sign Post/Bookshelf
    • Unzip to your plugins folder
    • Permissions: add the following node to your permissions: signreadmore.srm
    Download Sign Read More Plugin
    Source Code
    Feel free to make any DONATIONS
    Usage (open)

    1. Create a Sign Post/Bookshelf and place it anywhere

    2. Open chat and type /srm line[1 - 8] Some text for line[1 - 8]
    e.g /srm line1 Some text for line1

    Use "#[0-9a-f]" to specify color.
    eg /srm line1 This is #0black text

    Repeat step 2 to enter different lines (max 8 lines)

    3. Right-click Sign Post/Bookshelf to associate sign post with file

    NOTE: Calling /srm for a sign already has a file associated allows you to EDIT the different lines.

    If a sign alread has line1 to line5 entered. If a user then types "/srm line3 new line 3 details"
    Then the sign will be updated as follows:

    1. Some text for line 1
    2. Some text for line 2
    3. new line 3 details
    4. Some text for line 3
    5. Some text for line 4

    1. Create a Sign Post/Bookshelf and place it anywhere

    2. Open chat and type /srm file filename.txt
    The filename specified should be located in [/plugins/SignReadMore] folder
    e.g /plugins/SignReadMore/filename.txt

    3. Right-click Sign Post/Bookshelf to associate with file

    Upon right-clicking sign post, the contents of the text file will be read and shown to the user.
    Change Log (open)

    Version 3.3
    • Removed OnBlockBreak (Deleting of file)
    Version 3.2
    • You can now assign a blank line (used for deleting)
    Version 3.1
    • Integrates with Permissions 2.5.5
    Version 3.0
    • Updated to craftbukkit #602 (dev-bukkit #486)
    Version 2.9.1
    • fixed minor bug with "/srm file" command
    Version 2.9
    • Using onCommand
    Version 2.8
    • Removed diamond sword for file-base association
    • Minor enhancements to the way messages are displayed
    Version 2.7
    • *Major* Added color support. Use "#[0-9a-f]" to specify color. eg. /srm line1 This is #0black text
    Version 2.6
    • Allow more than 1 user to edit a sign
    Version 2.5
    • No longer uses diamond sword as wand
    Version 2.4
    • Updated to dev-bukkit #461 (compatible with craftbukkit #556)
    Version 2.3
    • Updated to dev-bukkit #432 (compatible with craftbukkit #440)
    Version 2.2
    • Increased line limit (max 10) :: NOTE :: The max limit of the chat window is 10 (for the in-game chat window)
    • Added support for Wall Sign
    Version 2.1
    • Fixed bug for Admin usage. Should be: /srm file filename.txt
    Version 2.0
    • Now works with bukkit 1.3 (#412) - Uses OnBlockBreak instead of OnBlockDamaged
    • *Major* Users can now add read more text (YAY!!)
    Version 1.1
    • Fix "stupidly long constructor" warning
    • Added support for Bookshelf
    Version 1.0
    • Initial Commit.
    ImNotOkay, m5k and Phaedrus like this.
  2. Offline


    (team fortres 2 heavy voice) THANK YOU!
  3. Offline


    mode and currentFileName should be associated with a player, not global across all of them. Consider the following examples:
    Player A uses /srm file <filename>
    - Mode is set to F
    Player B uses /srm line1 <text>
    - Mode is set to S
    Player A right-clicks on a sign
    - Not exactly sure what happens here, but I'm pretty sure it's not what was intended.

    Player A uses /srm file <filename1>
    - currentFilename is set to filename1
    Player B uses /srm file <filename2>
    - currentFilename is set to filename2
    Player A right-clicks on a sign
    - Sign is associated with filename2, not filename1
  4. Offline


    I've looked through all the posts and no one has asked this question yet: is there any way to output # without it becoming part of the color syntax (thus making it not appear)?

    If not I'd like to suggest a 'major' change, changing the color syntax from " # " to " ` " (above tab key).
    NOTE: Anyone with notepad++ can re-edit all their files from # to ` in one go, thus I put 'major' in quotes.
  5. Offline


    please update to new server :)
  6. Offline

    Swoosh Bear


    I really love this plugin and it is VERY important to my server to function properly. If you could update this plugin to 818, it would be greatly appreciated.

  7. Offline


    Yea please update
  8. Offline

    Swoosh Bear

    Seems to work fine on 818 but the next recommended build might. This plugin is really important to our servers, since it lets us display large amounts of info in game instead of having to put it on the server thread.
  9. Offline


    Not working for me:
  10. Offline


    Any ETA for update ? ;)
  11. Offline


    Hey!, how to install this? whathi do with the plugin yml?
  12. Offline


    Ack! There's a directory-traversal security hole in your plugin, dude.

    This works as expected:
    /srm file filename.txt
    (Links the sign to, in my case, /srv/minecraft/plugins/SignReadMore/filename.txt)
    /srm file /etc/sysctl.conf
    (Doesn't work, as I'd hoped.)
    This is broken:
    /srm file ../../../../etc/sysctl.conf
    (Allows reading of a file it really shouldn't.)
    It's no big deal on my server, where it's running as a very unprivileged user and group (and sysctl.conf is indeed world-readable). However, the moment you have some hapless noob running their minecraft server as root, it'll be very easy for server users to read files they really shouldn't be. Would it be possible to just strip out any '..' characters in the path? That access is locked down to just me on my own server, but that's still damn scary, IMHO... is there a real need to access files outside the SRM folder under plugins? Or maybe it could be in a config somewhere?
  13. Offline


    Can you update yor plugin to actual build of Bukkit [1000]?

    Because, a destruction of bookshelf or sign don´t delete saved message.
    Or what i´m doing wrong?
    Joggal likes this.
  14. Offline


    Can you also add the letters ä ü ö
    That German and Austrian Server that also can use?
  15. Offline


    I think I'm gonna go ahead and assume the developer isn't paying much attention. Going to look into branching his source code this weekend... though I'll be learning Java on the fly to do it, so it might take me a couple weeks. Never made a plugin before.

    Joggal - Have you tried them? If so, does it give an error, or does it just not work? I wonder if it may be an ASCII vs. Unicode problem?
  16. Offline


    Do you have to use permissions? or is it possible without
  17. Offline


    I just forked it, gonna work on it this weekend unless you already have something done.
  18. Offline


    what about the reboot of this plugin ? :)
    it's really interesting if someone could update this very usefull plugin !
  19. Offline


    Keep us posted on whether or not this is being continued! I would love some continued support, I love this plugin.
  20. Offline


    ha, i'm looking into it. my personal life just got a little hectic, but i'm relearning java on the fly.
  21. Offline


    PLEASE, ANYONE READING THIS that has the ability to fix the security issue of going thru directories....
    please fix it and post a link to where ever you keep the file... this is worthy of a *faceknee* any time it is read about..

    other than that, great plugin... brilliant!

    and can we get a separate permission for reading with it? that would allow a hidden message.txt behind what everyone could see. i would use that a lot. treasure hunts(pex's time limited node feature), mod separate instructions utilizing the same signs and things as such...

    again, brilliant, "bravo"
  22. I hope somebody can sacrifice some free time and knowledge to update this. It's a perfect plugin for my server and the newbies that enter it. :oops:
  23. Offline


    Hey, I've been setting up a server for me and my friends, and with SRM I run into a little problem when using the commands. If anyone could help, I would love it.

    21:31:53 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'srm'
     in plugin SignReadMore v3.3
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:16
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:722)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:715)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:471)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHand
            at com.bukkit.Milton.SignReadMore.SignReadMoreCommand.onCommand(SignRead
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
            ... 12 more
    Caused by: java.lang.ClassNotFoundException: com.nijiko.permissions.PermissionHa
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 14 more

    Can you possibly help fix this, I've tried multiple things, made sure I use the correct permission node and enabled it, and I know I enter in the right command: /srm line1 herpederp.
  24. Offline


    Hey, I keep getting this error:
    org.bukkit.command.CommandException: Unhandled exception executing command 'srm' in plugin SignReadMore v3.3
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:165)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:378)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:757)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:722)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:715)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:93)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:527)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Caused by: java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler
            at com.bukkit.Milton.SignReadMore.SignReadMoreCommand.onCommand(SignReadMoreCommand.java:30)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
            ... 12 more
    Caused by: java.lang.ClassNotFoundException: com.nijiko.permissions.PermissionHandler
            at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
            ... 14 more
    What do I do?

    wow, didn't even see that you have the same error as me.. (sorry for double post)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  25. Offline


  26. Offline


    I really like it and will use it alot, but one issue, maybe math will make it unlikely, but we all know how to count on math when it comes to... is this world independent saving or just coordinate saving? Maybe i end up rewriting an existing SignReadMoreText from another World while setting up one for another World Oo?!

    To the guys with the probs, just try the proper formatsyntax (had same probs by just playing around):
    /srm line1 myDamnTextForFirstLine
  27. Offline


    I'm getting the same errors, but mine happen when I right click to get the text read back to me.
  28. Offline


    Is there a way to get this to operate with different block types? I would like to add text to certain blocks on the floor in my server, and some to paintings.
    maybe a config file where you can add blockID's that are compatible
  29. Offline


    Could you possibly update this, or has it gone inactive? I love the idea, but can't find it anywhere else!
  30. Offline


    Appologies. I've been awol and haven't had time to update it. Will do so soon.
  31. Offline


    Long time no see Milton. You will notice that this thread has now been placed into the Inactive Plugin subforum.
    If you wish to revive this plugin, please ensure that you update and test compatibility with the latest recommended Bukkit build before reporting your original post, asking for it to be moved back to the release forum.

    Thanks for your time.

Share This Page