[GEN/SEC/ECON/TP/ADMN] Essentials - A collection of useful commands

Discussion in 'Archived: Plugin Releases' started by EssentialsTeam, Apr 30, 2011.

  1. Offline


    imo this makes permissions/management SOO much easier. i like groupmanager but its fading so maybe a switch to permissions would be good. provided you guys still do the presets as that made it easy to understand
  2. Offline


    I love Essentials, don't get me wrong here! But, I am having a bit of a problem...

    I am having the sign issue too. It's so annoying, and I cannot remove the protection either. Whenever I place a sign, it just goes away and gives me a message saying that I am the owner of a block. This feature isn't helping, especially when I or any Mod need to place a sign in another user's house, i.ed explaining rule violation or complimenting. I don't want to own their house! Nobody can build or do anything where I, or any other Moderator tried to place a sign. I hate to go on a rant, but it is more of a grief tool than a protector if the player who placed the sign cant remove the protection, as it leaves tons of floating blocks when buildings are removed.

    Is there any way to fix this? The command index was not clear, and only posted the permissions required for use instead of any commands. Removing the permission does not remove the protection. Can anybody help me out?
  3. Offline


    Oh, I see Essentials is now caplable to replace AntiGrief plugin.
    How do I prevent block placement for member of one group and allow it for members of another? Actually I set this in config:

    blacklist: placement: 14,56,7,51,10,11,8,9,46
    usage: 327,46
    This prevents all groups from using mentioned blocks/items. So, what I need to add to groups.yml of GroupManager?
  4. Offline


    I majure bug for my server was that because Essentials fall damage was disabled... ALL THE TIME.
  5. Offline


    Stop the server and remove the EssentialsProtect.db in the Essentials folder. This will remove all protections currently in the world.
    If you want no more protections you remove the EssentialsProtect.jar in the plugins folder.
  6. I have problem with /back command on multi world. It sometimes works like it should but too often it teleport you to random position...Any way to fix this?
  7. Offline


    Please Help! I keep getting this error when a brand new player joins I'm using cb:818 and it kicks them and then they join back in and leave, it is super annoying. Heres the code on Terminal:
    deren909 [/] logged in with entity id 587 at ([ BalrogLand] 834.90625, 103.21875, 211.4375)
    21:06:03 [INFO] [AutoSave] AutoSaveThread Started: Interval is 300 seconds, Warn Times are 0
    21:06:06 [INFO] [BBROTHER] Cleaned out 0 records because of age in 0h00m00s.
    21:06:07 [INFO] [Minecart Mania] Loading Sensor Data.
    21:06:13 [INFO] Davern [/] logged in with entity id 640 at ([ Flatgrass] 747.6658106746129, 64.0, 259.5082321099174)
    21:06:13 [INFO] Disconnecting Davern [/]: Internal server error
    21:06:13 [WARNING] Failed to handle packet: java.lang.IllegalStateException: Failed to add player. net.minecraft.server.EntityPlayer@280(Davern at 821.5,69.0,212.5) already is in chunk 51, 13
    java.lang.IllegalStateException: Failed to add player. net.minecraft.server.EntityPlayer@280(Davern at 821.5,69.0,212.5) already is in chunk 51, 13
        at net.minecraft.server.PlayerInstance.a(PlayerInstance.java:36)
        at net.minecraft.server.PlayerManager.addPlayer(PlayerManager.java:78)
        at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:135)
        at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:96)
        at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:33)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    21:06:15 [INFO] ?9[PLAYER_COMMAND] deren909: /time day
    21:06:17 [INFO] <?4deren909Admin?f> hi
  8. Offline


    Hey, when the lowest rank on my server types in /help, the person could see all the commands, is there a way that they could ONLY see commands that they could use?
  9. Offline


    Hey guys! :)
    Just stopping by to let you know this is working great (Essentials 2.3.2) on my CB #860!
    Keep up the great work guys!
  10. Offline


    hi i become this error
    2011-06-11 20:44:40 [SEVERE] Error occurred (in the plugin loader) while enabling Essentials v2.3.2 (Is it up to date?): null
        at java.util.TreeMap$PrivateEntryIterator.nextEntry(TreeMap.java:1100)
        at java.util.TreeMap$KeyIterator.next(TreeMap.java:1154)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:308)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:806)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    i use CB 860
  11. Offline


    So far so good! Working on Bukkit 860 for me with no errors
  12. Offline


    noob problem here..

    using the permissions below, players can't use the /list command..
    but if I change it to essentials.* , they can use all the commands.
    So what am I doing wrong here?

    - User
    - essentials.list
  13. Offline


    So /tempban and /nuke works for you?
  14. Offline


    Hmm let me check, i usually just check the main main features, and all economy features, as i never temp ban and dont even know what nuke does lol.
  15. Offline


    I am getting this same error using Essentials v2.3.3
  16. Offline


    so uhh, yeah :confused: is there a way for /help to have a list of ONLY the commands you could use, instead of everything?
  17. Offline


    Hi All. Since this is my first thread i want to thanks the author for this awesome plugin :)

    But im having a problem, and i think the main reason is this plugin. Im running Essentials, Permissions 3x,
    WorldGuard and WorldEDIT.
    I already checked gameguard and essentials and they both say "false" for protecting spawn, but even I with ADMIN permissions cant edit(remove/add) blocks in a X radious of the spawn.

    Can anyone Help? Where should i look for this spawn protection area?

    Thanks and have a good game :)
  18. Offline


    @ewized: We consider adding multiworld loading, for now use Multiverse
    @houska94: Check the blacklists of EssentialsProtect inside config.yml
    @Revenger: Add a feature suggestion to our ticket system
    @zaklampje, Unknown_1: Did you enable per item permission in config? Then you need essentials.itemspawn.item-itemname
    @RogerWilco: You can set the spawn whereever you want with /setspawn. (If you have EssentialsSpawn.jar)
    @Mactownes: I guess you are still op.
    @inidigomontoya: Multiverse plugin to load the worlds
    @Porydan2: I looks like you are not using Permission or groupmanager, add "home.others" to the restricted command list in config.yml.
    @vasil7112: Don't post yml files in here. The format is lost.
    @Einschtein: It's saved in plugins/Groupmanager/world/worldname/users.yml. It's only saved every 10 minutes. So you did reload the old file from disk, before the changes were saved.
    @Maguron: Can't help you with that.
    @Shay Williams: It should be enough to remove the permission, make sure you are not op.
    @Hrdkr: Permissions like essentials.protect.exemptplacement, read the documentation.
    @dersies: Inside config.yml look for command-costs
    @RugRats: Do you have EssentialsChat?
    @nolan: As an op you can do everything.
    @nichiatu: thanks, I'll check that
    @ItsMeYaniv: create a file called help_guest.txt and write your own help for guests
    @MOHH: Join our irc channel to get help.
    @JagerPrime: Read first post
    @Incendia: test 2.3.3
    @RugRats: I'll test /tempban, /nuke is not released yet.
    @cameron rees: You can't jail ops.
    @caseyjfer: signs-disabled: true in config.yml or remove the permissions
    @quickclay: permission: essentials.protect.ownerinfo
    @logoth: Yes, if the player is unknown to Essentials, it will spawn at the newbie spawn. Comment the spawnpoint line at the end of config.yml with a #.
    @Facepalmed: Will be fixed with the next protect release.
    @Luwiego: More info on that please.
    @Tumpo: Try to find a reproducable way.
    @Deren909: Fixed in 2.3.3
    @Dragonntiger: non-ess-in-help: false or create a file called help_groupname.txt and write your own help.
    @Tealk: Read first post
    @drew: essentials.list should be enough to see the /list command
    @wheresmyhotdog: Read first post
    @insertt: check server.properties
  19. Offline


    Is it possible to remove some features of this plugin? I need some of the admin commands, but there's also alot of stuff that I don't need,
  20. Offline


    @nichiatu: Either by permissions, disable them in config.yml or remove the commands from plugin.yml inside Essentials.jar

    The next release will contain a fix for the lava buckets
  21. Offline

    City Builder

    Is there a way to turn off the Essentials /sell command?

    It's taking precedence over the iconomychestshop /sell command


    Disabled them in the plugin.yml file inside of Essentials.jar file.
  22. Offline


    @essentialssteam I have iChat
  23. Offline


    I can't figure this out!! I'm using all the essentials plugins, I set the build permissions for the default group to true but everyone except Admins is getting a notice when they place blocks saying they don't have permission to, but they can still place the block. It's really annoying them. Help please?
  24. Offline


    I runned a test server, as soon as i added essentials, i got fall damage disabled , after removing essentials everything was fine.
    Another thing-Iget alot of BlockMappingstart, errors, almost in every command.
  25. Offline


    is there a way to have essentials chat installed and still use a name coloring plugin? I have ColorMe, and the latest permissions installed. How can I use the prefix color formatting of permissions for individual groups, and have different colored names for each person in that group with essentials chat installed?

    If it's not possible, that's fine. I prefer the cleaner look of essentials chat.

    I looked into iChat, but it doesnt support permissions 3.x
  26. Offline


    It seems that permission is responding differently based on the case of the world. Notice "daniel" it shows I have permission (correct) yet if I have "Daniel" it will show incorrectly. Note user player is assigned all of the permissions noted below because the group is set as a default group.

    15:10:42 [INFO] º9[PLAYER_COMMAND] Player: /i sand
    15:10:42 [WARNING] Player was denied access to command.
    15:10:51 [INFO] Connection reset
    15:10:51 [INFO] Player lost connection: disconnect.quitting
    15:10:53 [INFO] Freed 276.907 MB.
    >pr player w:daniel has essentials.item
    15:11:51 [INFO] [Permissions] User/Group has that permission.
    >pr player w:daniel has essentials.itemspawn.exempt
    15:11:57 [INFO] [Permissions] User/Group has that permission.
    >pr player w:Daniel has essentials.item
    15:12:08 [INFO] [Permissions] User/Group does not have that permission.
    >pr player w:Daniel has essentials.itemspawn.exempt
    15:12:13 [INFO] [Permissions] User/Group does not have that permission.
    >pr player w:Daniel has essentials.help
    15:12:19 [INFO] [Permissions] User/Group has that permission.
    >pr player w:daniel has essentials.help
    15:15:32 [INFO] [Permissions] User/Group has that permission.

    Also per-item spawning is disabled. But I did add essentials.itemspawn.exempt for testing and still does not work. Could the Case issue noted above cause a problem? Why would it only cause a problem with the "item"?

    Thanks for any and all help.
  27. Offline


    Keep group manager!!!!!!!!!!!1
  28. Offline


    I completely agree. GroupManager's commands are much more intuitive.
  29. Offline


    Do you have Craftbook installed? This was previously a craftbook issue when craftbook added permissions.
    jochim likes this.
  30. Offline


    A few issues.
    Name recondition for spawning items doesn't work. I have to use /item <id> instead of /item <name>
    Every time I try to /warp or /spawn I get an error:null

    Using 860. Do I need to have the jar re-create the config files and folders?

Share This Page