Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Just for everyone to know, if you use this plugin and vStopFire, when you use /modgrp to modify a palyer group it will stop the server. Remove stopfire plugin and everything works fine :D
  3. Offline


    the /compass mixes us east and west. (and the SX and NX ones also).

    Normally going with the clock it's North, (NE), East, (SE), South, (SW), West (NW).
    The /compass makes it: North, (NW) West, (SW) South, (SE) East (NE). Which is totally wrong. Minecart mania used compass directions and I had everything messed up because of this :S
  4. Offline


    Dev build 257 is interfering with MultiVerse. If I die in nether world, Essentials "core" (I don't have any of the other jars in plugins) causes me to spawn at the map spawn point, which is in the air above a lava lake. MultiVerse has its own spawn system, which would make me spawn at a non-deadly location.
  5. Offline


    This has been asked a few times, but hasn't been answered yet:

    Only users in the Admins group can travel through portals, how can we give our players the same ability? We've given them the permission.
  6. Offline


    @petteyg359 make sure nether is disabled in essentials. I don't have this problem. Using MultiVerse as well. Bukkit #300
  7. Offline


    For some reason /rules is not working, comes up with a java error ingame.

    Error: java.util.LinkedHashMap cannot be cast to java.lang.String
    in the console it says this.

            at org.bukkit.earth2me.essentials.Essentials.getLines(
            at org.bukkit.earth2me.essentials.Essentials.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.c(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:232)
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
            at net.minecraft.server.MinecraftServer.h(
    Nevermind i fixed it, i forgot to encase each line in parenthesis. =P
  8. Offline


    version? update
  9. Offline


    uhm? bugreportsystem? how and where?
  10. Offline


    So I'm having trouble loading the extra plugins I've added after the essentials plugin. I'm not having trouble with the standard commands like /jump or /time but when I added the other plugins I can't seem to get them to load. What is weird is that the console seems to recognize that they are loaded but the server never seems to start them. So the /warp and /ban commands are unavailable.

    Here is a screen shot of the plugins folder.


    Here is the server log

    2011-02-10 18:34:00 [INFO] Starting minecraft server version Beta 1.2_01
    2011-02-10 18:34:00 [INFO] Loading properties
    2011-02-10 18:34:00 [INFO] Starting Minecraft server on *:25565
    2011-02-10 18:34:00 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-387-g065aac0-b300 (MC: 1.2_01)
    2011-02-10 18:34:00 [INFO] Preparing level "world"
    2011-02-10 18:34:00 [INFO] Preparing start region
    2011-02-10 18:34:01 [INFO] Preparing spawn area: 8%
    2011-02-10 18:34:02 [INFO] Preparing spawn area: 44%
    2011-02-10 18:34:03 [INFO] Preparing spawn area: 65%
    2011-02-10 18:34:04 [INFO] Preparing spawn area: 93%
    2011-02-10 18:34:05 [INFO] Loaded Essentials build 183 by Zenexer, ementalo, Eris, and EggRoll
    2011-02-10 18:34:05 [INFO] Loaded EssentialsHelp b183 by Zenexer, ementalo, Eris, and EggRoll
    2011-02-10 18:34:05 [INFO] Done! For help, type "help" or "?"

    And here is a screen shot of the command console response.


    I've tried deleting all the plugins then only using the essentials then adding in the others. I've tried adding them all at once. I've also tried adding them all in individually. I can never seem to get anything other than the basic Essentials to load.

    I'm running a MineOS (Linux) server on a VM with the most up to date version of Bukkit (this morning).
  11. Offline


    Just want to say,

    the guys in the live chat were very nice and helped me with my config.yml.

    i was staring at it forever last night and couldnt get it to work, i missed one DANG spacebar in the formatting. Multiple Kits Work fine it was my bad !!

    Again the live chat is great and make sure to check your config.yml formatting everything has to line up EXACTLY.
  12. Offline


    - Added /back
    - Portals can be disabled via nether.portals-enabled: false in config.yml
    - Added teleport delays that are interrupted by combat/movement
    - A whole lot more that I forget--but it's all in the changelog
  13. Offline


    try this

    shut off server
    delete all essentials.jar files NOT YOUR OTHER MODS (just a warning i dont want to be blamed that i screwed ur server)
    Delete the essentials folder so it wont retain any settings.
    put the essential.jar's back in (the ones you want to use home,spawn,ban etc etc whichevers)
    start server

    see if it loads all the right essentials.jar files.


    shut down server

    configure the config.yml file so everyone on your server cant spawn items and crap (or whatever, tweak the config.yml file to your liking)

    save the file.

    restart server

    make suer all essential.jar files load in your log window


    if no success!! then im sorry :( im a nooblet but am trying to help u from what i have done and know.

  14. Offline


    I can't find a download link... what's going on with the old github links?
    hmm scratch that... I think I found them... you may want to make that a little more clear, though!

    P.S. Why did you switch to a module system with commands that.. well.. don't really need to be a module? It's kind of cluttering the plugin folder. A Sub-folder system would be great here at least!

    P.P.S. There is no place to download the Spawn module... but I see it in the image above me... what's the secret here?

    Edit: Aha! I found it! It was in the complete package, which I missed initially. Nevermind, great job on this!
  15. Offline


    I need a bit of help. I get this when I open up my server after adding the essential plugin.

    2011-02-10 17:06:53 [INFO] Starting minecraft server version Beta 1.2_01
    2011-02-10 17:06:53 [INFO] Loading properties
    2011-02-10 17:06:53 [INFO] Starting Minecraft server on *:25565
    2011-02-10 17:06:53 [INFO] Preparing level "world"
    2011-02-10 17:06:53 [INFO] Preparing start region
    Preparing spawn area: 52%
    10-Feb-2011 5:06:55 PM org.bukkit.craftbukkit.CraftServer loadPlugins
    SEVERE: org.bukkit.Server.getWorlds()Ljava/util/List; (Is it up to date?)
    java.lang.NoSuchMethodError: org.bukkit.Server.getWorlds()Ljava/util/List;
    at com.earth2me.essentials.Essentials.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.c(
    at net.minecraft.server.MinecraftServer.d(
    2011-02-10 17:06:55 [INFO] Done! For help, type "help" or "?"
  16. Offline


    I am having trouble with the kit delays too. It seems all the delays are set to 0.
  17. Offline


    I actually tried that last night. No go :( .

    I tried doing essentials by it self, it loads. I deleted all essential plugins and folders. Reboot. Started the server natural. Took server down. Downloaded and installed a fresh version from the stable release, unpacked all into the right folders. Reboot. Only help and essentials loaded. Also cleared rebooted and tried a couple of different combos of Essentials with help/spawn/warp/ban. Still not loading right.

    Best I could get was the one I posted with the Help plugin and Essentials working together with the console seeing them but not the system actually booting the other plugins.

    Thanks for the suggestions though. I'll give it another try tonight to see if some weird combo of plugins/reboots is the cause.
  18. Offline


    great plugin(s), been trying to tweak all the files to my liking. but i really want to tie it into Iconomy more. having a problem getting the command-costs to work. Here's what I have:
      warp: 100
      tp: 100
      spawn: 100
      home: 100
      sethome: 100
    The only one that deducts a cost is spawn. What am I doing wrong? Thanks.
  19. Offline


    /spawn not working at newest build with craftbukkit #302

    Also /list but /online seems to work

    Having also touble with local chat... But I dont think it is related.
  20. Offline


    What is the minimum CB build we should be using for this? Would it be possible to have that included (I know Minecart Mania does that; I hate to compare, but it's very helpful)?
  21. Offline


    The latest version on SVN looks to be built against CraftBukkit build 302, I believe.
  22. Offline


    When I use the /world command (either /world nether or /world normal) it just warps me so that I'm facing perfectly West. Running build #300
  23. Offline


    Nice plugin and nearly everything works fine.
    But i have a few questions/bugs:

    - Is it possible to set different spawns for every world ? (e.g. setspawn normal|nether)
    - In the nether i made 2 portals which are ~10 blocks away from the spawn in different directions. When i go through the first one, i spawn ~5 Blocks away from the portal in the normal world. But when i go through the other portal, i spawn at x-coordinate > 2500 (sometimes 3000). Then Borderguard teleports me to a random place within the border. Is it possible that your spawnpoint in the normal world is where you entered the nether ?
    - the normal motd has 3 lines. If i try to add a 4th line (even if i copy e.g. the 1st line) it seems that Essentials isnt loading

    Craftbukkit build: 300
    Essentials build: 184
  24. Offline


    Ok, Admins are still the only group which can go through portals. The config file has portals enabled. I'm guessing I'm missing a permission but I can't figure out what it is. The only ones that seem applicable are and essentials.nether.


    CB 291
    E 184

    edit: Ok, thanks to those nice chaps in the IRC channel, I got my answer! Its "essentials.portals" Thanks guys!
  25. Offline


    Hmm, we need a way to completely disable the motd again. Adding it to the disabled commands area in the config.yml still has it appear on join, and removing it from the plugin.yml inside essentials.jar still has it display on join.

    CB 302
    E 184
  26. Offline


    just clear the motd content in your config.yml? wouldnt that work so it displays just nothing?

    and still: whats up with this mail stuff? I dont want any user to see "no new mails" when my server doesnt even allow mails for anyone
  27. Offline


    Unfortunately, if you delete the entire message from the config.yml, it causes an error in the console. Consequently, if you delete the entire message and leave:

    - ''

    instead of a message, it still displays a blank line on the chat window after my motd from MCDocs. Not really horrible, but something I would like to have to the ability to completely disable at some point in time.
  28. Offline


    im afraid to download this lol. So, is it working then? or just more buggy
  29. Offline


    yeah im kinda thinking about deleting Essentials from my server as its getting buggier and stranger with every update
    this thread is 90 pages long and there are issues all the way, just crazy!
    I dont understand how these guys can shoot out updates like candy when they havent tested them one bit, so fuckin annoying, never seen a plugin so riddled with issues before
  30. Offline


    I just tested it in the latest dev build, adding "mail" to the disabled-commands list in config.yml, and it didn't show me any message about mails on login. Do you have it disabled in config?

    EDIT: confirmed, actually.
    A workaround that should work either way: instead of adding - '', try adding [].
  31. Offline


    The layout in the config is like this:

    # The message of the day, displayed on connect and by typing /motd
    - ''

    Setting it to that causes the extra line under my MCDocs /motd

    # The message of the day, displayed on connect and by typing /motd

    Setting it to that causes startup errors

    # The message of the day, displayed on connect and by typing /motd
    - []

    Setting it to that causes this error when a player logs in:

    Feb 10, 2011 11:19:20 PM org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event PLAYER_JOIN to Essentials
    java.lang.ClassCastException: java.util.ArrayList cannot be cast to java.lang.St
    at com.earth2me.essentials.Essentials.getLines(
    at com.earth2me.essentials.Essentials.getMotd(
    at com.earth2me.essentials.EssentialsPlayerListener.onPlayerJoin(Essenti
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.ServerConfigurationManager.a(ServerConfiguration
    at net.minecraft.server.NetLoginHandler.b(
    at net.minecraft.server.NetLoginHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    at net.minecraft.server.MinecraftServer.h(

    Other then that error on the console, the workaround works great.
Thread Status:
Not open for further replies.

Share This Page