Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Sorry! Fixing that now, @M1sT3rM4n

    @tekac Looking into that right now.
  3. Offline


    No need to be sorry! I think you are doing a fantastic job chugging out all these updates! I've never seen bugs addressed with such lightning speed.

    +1 :)
  4. Offline


    No kidding! I have plugin devs that I go "Oh man, That dev makes great stuff!" to. Funny thing is, I only have one that I go "That guy is an Amazing dev." Period.
  5. Offline


    Glad to be your developer, lol :)

    Did a whole bunch of updates to the first post. Most are subtle, but some have useful information. Summary:
    • disable-motd will disable the the MotD altogether, not just the command.
    • disable-eco, like disable-motd, will disable most economy features altogether, not just /eco.
    • essentials.msg added to permissions list
    • essentials.rules added to pemissions list
    • Added link to SVN repository for those of you looking to help out with development or view the source code
    • Added new changelog link so that you can watch live as I fix your bugs, even before the fixes are released (F5 button-mashing party, anyone?)

    Oh, and I added Eris to the list of developers, as he's interested in contributing a bit. Anyone else interested in helping--even if you are still a newbie programmer, or learning as you go--is welcome to ask! :)

    @tekac Figured out your bug. It was some stray debug code that I was using to help a server admin troubleshoot some problems. It is an intentional error, and just means that there were no parameters given to a command that expects parameters. It's harmless, and should be removed in the next release.
  6. Still love your plugin and still getting better. Maybe add a /warp or something?

    Oh i got an error: Latest Build Minecraft #135
  7. I like your plugin and i use it on my server.
    But i have one thing to ask: Can you please make it not show "no access"via a setting ? I am using both general and this, and whenever i do a general command (such as /msg), your plugin throws a "you do not have access to that command". Also happens when typing /accept or /deny (from tpc lite)
  8. Offline


    @Silverlink Thanks, fixed that. I had a stray tab in MY config file. I guess YAML can give anyone a headache. ;)

    @TowelieDOH Simply add "disable-msg: true", etc. to your config.yml file, and the commands should be COMPLETELY disabled. If they aren't, let me know, and I'll fix that immediately.
  9. Offline


    Just tested tcp and tcphere, they seem to be swapped. Player1: /tcphere Player2 should teleport Player2 to Player1 and /tcp Player2 should teleport Player1 to Player2. Assuming the functionality is the same as TeleConfirmLite or hMod TeleConfirm.
  10. yay it worked Zenexer!
    Have you read the other comment i made? add /warp :)
  11. Offline


    @lonelydime Thanks, I just fixed that for you. The update is ready now.

    @Silverlink On my todo list :D I just have to finish getting this SVN repo configured.
  12. Offline


    @Zenexer Thanks, I've checked out the code with git-svn. I'll try to get started either today or tomorrow. First order of business is learning more about snakeyaml.
  13. Offline


    Notes about snakyaml: Simple, no compile-time type-safety (reads objects, and from there it's a guessing game with instanceof), and dislikes fancy characters--including, coincidentally, ยง.

    Fixed /ban error when banning an offline player.
  14. Offline


    I'm currently on Bukkit #126 and my users can use the command they should be able to via Permissions. But when I (the Admin & Op) try to use ANY Essentials command, all I get is "You have [x] messages! Type /mail read to view your mail." and /mail read just gives the same message.
  15. Offline


    @Andy /mail clear; I'll add a notification about that.
  16. @Zenexer sweet! Hope to see it released soon. You must rename your plugin AiO Essentials or something! Its All in One! :)
  17. Offline



    /mail clear doesn't seem to do anything, and commands still say the same thing, very odd haha
  18. Offline


    Is there anyway that you can make /whois display the group they're in? Does Bukkit allow that yet?
  19. Offline


  20. Offline


    small thing

    In the OP, the restrict section is missing restrict-tp:
  21. Nice bug list :) an idea: Seperate the kits from the config. Sometimes i delete the config to get all the new settings in the YML file (whatever file x-)) And then i need to copy n paste the kit part.
  22. Offline


    A little request, is it possible to set the /kick and /ban commands so people cant kick a member of a higher ranked group? Because now my mods can kick me now. I am using the permissions plugin. So it might be difficult :s.
    And the {PLAYER} in MOTD gives the name of the first person who logged in :s.

    I love this plugin :)

    Thx in advance,

  23. Offline


    I just restarted my server. And now no one can use any Essentials commands at all :S
    Also when someone logs in the server gets an error saying "Could not pass PLAYER_JOIN to Essentials".
    The log also says that Essentials starts properly.
  24. Offline


    @mattekure Thanks, but I won't be updating the example config to use all config items, not even all the defaults. It's just an example, and I also want to show that you can leave out items to get the default. :)
  25. Offline


    When ever I set myself as op I get access to all the commands, even though Permissions should be disabling most of them. Is this intended? Am I doing something wrong?
  26. Offline


  27. Offline



    Cheers buddy, appreciate it and how hard it can be developing stuff (i'm an Applied Computing degree student) so take your time. You're certainly one of the good ones who seems to listen to their users, +1 for that :]
  28. Offline


    @Andy Glad to help. I believe the problem is in your MotD, though I could be wrong. What does your config file look like?
  29. It works now^^
    I reinstalled Java and Craftbukket. Thanks
  30. Offline


    Yay! In other news, I just released an update to give feedback for bans/unbans and fix a few minor bugs.
  31. Offline


    What does "essentials.rules" let you do?
Thread Status:
Not open for further replies.

Share This Page