Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Tried doing /i spawner:<int> and it always gives me a pig spawner, does work with cloth though, although I could not find the proper alias name for it, tried wool, cloth, graywool, graycloth, nothing worked other then doing 35.

    BTW I officially am switching from General to your plugin, I really like how its coming along.
  3. Offline


    Only says Suprem20 tried command spawn or command "Help" is unknow
  4. Offline


    I keep getting the following error with version 47, craftbukkit 126

    SEVERE: Could not pass event PLAYER_JOIN to Essentials
    at org.bukkit.earth2me.essentials.Essentials.getMotd(
    at org.bukkit.earth2me.essentials.EssentialsListener.onPlayerJoin(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.ServerConfigurationManager.a(
    at net.minecraft.server.NetLoginHandler.b(SourceFile:121)
    at net.minecraft.server.NetLoginHandler.a(SourceFile:47)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    at net.minecraft.server.MinecraftServer.h(
  5. Offline


    @sumTard Surround your MotD with square brackets (for example: motd: [ 'This is my motd' ])

    @Suprem20 And you updated to the latest Essentials build?
  6. Offline


  7. Offline


    None of the commands on mine work at all, for any users on my server.

    I've set up the Config file similar to the example in the OP and left the users.yml alone. I'm users GroupsUsers for permissions.

    The plugin MUST be working because "You have no new mail." and the MOTD supplied within the config.yml file both appear, but not one of the commands work. I was running scrapbukkit and thought that might be the culprit, so I removed that and still nothing.

    I'm using version #114
  8. Offline


    I got something exactly like that vip:
    default: false info: prefix: '2[vip]' suffix: build: true inheritance: permissions: - 'help' - 'top' - 'getpos' - 'homeset' - 'home' - 'spawn' - 'me' - 'msg' - 'kit' - 'playerlist' - 'motd' - 'compass' - 'tell' - 'm' - 'who'

    But no commands or or group color etc
  9. Offline


    I reinstalled build 47, and then updated to build 68 Bukkit, and 127 of Craftbukkit~ and now it works? I haven't tried to add WorldEdit, and WorldGuard back in yet. Let me know of this helps you...
  10. Offline


    @Zenexer You should add warps into this. Commands such as


    I am also having trouble with permissions. I will post problems are I give it another shot!
  11. Offline


    2011-01-23 00:13:23 [INFO] Unknown console command. Type "help" for help.

    2011-01-23 00:15:06 [INFO] Suprem20 issued server command: who
  12. Offline



    How do you download Bukkit build 68... they are just build listings. I only have Craftbukkit installed...
  13. Offline


    Ok. Here is a bug =(

    I typed /plugin enable WorldEdit and I got DC with an error.
    Then I logged back in, and the plugin was active..? So it worked, but kicked me.
    I then typed /plugin enable WorldGuard, and I got d/c with a client crash.

    Here is the log for both:

  14. Offline


    Besides the spawner bug I also just found that on cb 127, don't know about earyler versions... the config file gets re-written to default on every server start...
  15. Offline


    Go here and click on the build number. Then click on the "Artifacts" tab. This will take you to a page from which you can download the jar. Have a look at that link because there is only one slight change that needs to happen to it to download a different build. (No need to drill-down into the pages in the future.)

    Good luck!
    --- merged: Jan 22, 2011 11:29 PM ---
    @Zenexer I posted a few pages back about the null pointer issue after referencing an invalid item with /i. I got an alert that you tagged me but the post did not have a tag for me. (I have noticed weird posting anomalies on this forum when trying to post myself.) Anyway, if you intended to tag me, can you re-post? Thanks!
  16. Offline

    Tazmanian Wolf

    ok my config.yml keeps getting rewritten. any ideas? thank for the advice
    oh and it is showing every one the welcome with my name only :D instead of [PLAYER]
  17. Offline


    Thank You.
    I use this link:

    And I just go off of the release number.
  18. Offline


    First off, Bravo... You have done an excellent job thus far with this plugin. I personally have not had any issue but would like to to issue a thank you and great job (My personal pat on the back). Secondly, /setwarp 1, /setwarp 2 could be kind of useful for op's... I completely understand this is a Basic/Essential command based addon and to add anything out of that range would defeat the purpose of the name, But an idea to make this fun or another addon to make you test your scripting ability would be a "/lotto" command... OP's can type /lottoset (Number) (Prize) (Amount) and players can type /lotto # and if right They win said prize.... If this is out of context then i apologize... Just a thought... Understand i have considered there is already a similar plugin... Not exactly the same and should not be credited the same regardless! Just my 3 cents
  19. Offline


    I downloaded the user-defined build and it gives me errors when I run it using this command;

    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar

    by simply changing the target .jar.

    Am I meant to be running it another way?
  20. Offline

    Tazmanian Wolf

    eh - just did a work around on the config.yml - make it a read only file :) works for now at least for keeping the changes i want, Now to fix the [PLAYER] issue
  21. Offline


    My problem: I type /sethome and it tells me that my home has been set like it should, but whenever I /home after that it says '/home doesn't have a home'.
    Also when i type some random shit like /home sdadas it tells me to put /home help, but when i put that in it also tells me to write /home help for help.
  22. Offline


    Try to type just /home ...not /home sdadas... if that's what you are doing?
    Nevermind i fully read your post. My apologies....
  23. Offline



    Is there any way to disable certain commands and allow users to have access to another mod? Such as your /home /sethome commands. My players really love MyHome mod. with /home private options and /home invite. allowing players to teleport to each others house using /home <name>.

    is it possible for you to add in such features in your Essentials? I really love using it over General but I just miss the freedom of MyHome features.

  24. Offline


    That already does exist, you can enable or disable any of the commands in the config file, and specify if its op only or not. Although the current build is re-writing the config to default every load so you have to set your config read only once you config it.
  25. Offline


    is there any easy way for you to add coloured names? i miss having my red admin colour! Will donate to you if you fix that ;) Like all people in op.txt have red names
  26. Offline


    Thank you very much. Now that you mention it, I did see the ontop of the "op only" commands. God I am not thinking straight. Thanks for pointing it back out to me :)
  27. Offline


    Well for the main part, I would like my name to be red and have a large Owner next to it.
    So in chat, people known who myself, and my admins are.
    SimpleServer did this quite nicely. I really love SimpleServer.
    Now that I have moved onto Bukkit, things have gone downhill... [​IMG]
  28. Offline


    There seems to be a small issue with /msg where it only sends the first word e.g.

    /msg user Hello, how are you?

    It only sends "Hello,"
  29. Offline



    cbuild 127
    main bukkit 68.

    What do these errors mean?
  30. Offline


    it was not there, added it, but did not work :/
  31. Offline


    Brett, make sure you have no tabs but spaces instead in your essentials config file.
Thread Status:
Not open for further replies.

Share This Page