Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Please update this plugin to build 617 (latest recommented)

    and i cant download this plugin it says:

    Not Found

    The requested URL /bukkit/ was not found on this server.

    Apache/2.2.17 (Fedora) Server at Port 80
  3. Offline

  4. Offline


  5. Offline


    everything works for me except warps.
  6. Offline


    Is there any bugs with running the latest build on CB 617?
  7. Offline


    anyone know of any other warp plugins? (since this one dont exist anymore?)
  8. Offline


    Its still part of the package, just not working yet?
  9. Offline


    I dont think it is since i didnt get any new EssentialsWarp.jar to my plugins folder, i was not able to download it either.
  10. Offline


    Doesn't for me.
  11. Offline


    onPlayerTeleport has been replaced with a new signature, (PlayerTeleportEvent)
  12. Offline


    They merged pretty much everything into the core a while ago
  13. Offline


    Yes, this has already been covered in this thread multiple times. Anything that used to be separate before has been combined into Essentials.jar, and everything is still there. Only Chat, GroupBridge, GroupManager, Protect, and Spawn are separate now.

    EDIT: Would be nice, though, if there was some config that we could use to enable/disable different parts of Essentials.jar...

    Yes, this has already been covered in this thread multiple times. Anything that used to be separate before has been combined into Essentials.jar, and everything is still there. Only Chat, GroupBridge, GroupManager, Protect, and Spawn are separate now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
    Skadar likes this.
  14. Offline


    /god doesn't work in 1.4 on #617.
  15. Offline


    So the warp ability just aint working?
  16. Offline


    i have 617 and /god works
  17. Offline


    Is there any way we can edit out some commands in essentials? i.e. if we want to use worldguard's /god, make it so essentials doesn't have that feature? (there were a lot of other things I don't want essentials loading, but that's the first that came to mind.)

    I could edit the source and compile my own custom build, but I'm wondering if more would be involved than simply deleting it then compiling it.
  18. Offline


    The /god and /heal command creates conflict with /god and /heal of WorldGuard (or WorldEdit) :/ With essentials, i can't heal or switch god mod to others players.
  19. Offline


    The warp commands don't do anything, but everything else works. What is the issue?
  20. Offline


    /time day or /time night doesn't work, When I try /time day it just keeps saying /time [day|night]
  21. Offline


    any command you have with essentials that's in another plugin you run, that plugin will supersede essentials. i run those plugins no problem (essentials and worldguard). if you have a problem healing or toggling godmode, then maybe your permissions are not correct.

    For the other people complaining that things are not working, are you using the recommended essentials version 2.1.12? that version should work no problem.
  22. Offline


    Nevermind, I remembered I use WorldEdit so I have to use the /god permission, not essentials.god. I'll have to wait for a WorldEdit Update. :)
  23. Offline


    everhigh->I'm OP on my server, so, i have access to all commands. Configure Permissions for server owners (all permissions) it's very long :/
  24. Offline


    thats why you use '*' as the global permission variable. as an admin, i only need to be op and have that, and all permissions based plugins will work for you.

    there is a tempfix for worldedit:

    /god is in worldguard also
  25. Offline


    I have the brand newest version and the warp functions don't work
  26. Offline


    i dono what to tell you then, i run ver 2.1.12, and recommended build 617, and it works for me. maybe there is an old plugin in your plugins folder interfering with essentials?
  27. Offline


    Well, I have the brand newest version and /warp works just fine for me.

    I do, however, get this error:
    2011-04-01 15:21:23 [SEVERE] null
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
        at com.earth2me.essentials.Essentials.loadData(
        at com.earth2me.essentials.Essentials.reload(
        at com.earth2me.essentials.Essentials.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(
    Though it doesn't seem to affect anything.
  28. Offline


    Just got this mod, How do you get rid of the "[name] placed [item] x,y x,y" ??
  29. Offline


    I updated from the last version, and it is giving me an internal error and crashing the server every time I try to use a command. All I did was swap out the jars, I tried removing the folder and it made a new one, still crashes. Nothing will work at all, and its pissing me off. Also, how do you update it without having to manually reupload all the user and warp files to the host?

    After more trial and error, I found ANY comamnd will crash it, even from other plugins.

    2011-04-01 17:38:24 [SEVERE] java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    2011-04-01 17:38:24 [SEVERE] at java.util.ArrayList.RangeCheck(Unknown Source)
    2011-04-01 17:38:24 [SEVERE] at java.util.ArrayList.get(Unknown Source)
    2011-04-01 17:38:24 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(
    2011-04-01 17:38:24 [SEVERE] at net.minecraft.server.ServerConfigurationManager.c(
    2011-04-01 17:38:24 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-04-01 17:38:24 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:103)
    2011-04-01 17:38:24 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    2011-04-01 17:38:24 [SEVERE] at
    2011-04-01 17:38:24 [SEVERE] at
    2011-04-01 17:38:24 [SEVERE] Unexpected exception
    java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.RangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.ServerConfigurationManager.c(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:103)
    at net.minecraft.server.MinecraftServer.h(
  30. Offline


    Warp commands work for me too.
  31. Offline


    what version of craftbukkit are you using, and what plugins?
  32. Offline


    God mode is stuck "on" for me despite turning it on/off using the /god command. I use WE and Essentials. So could this be the issue?
Thread Status:
Not open for further replies.

Share This Page