Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Using the motd settings provided with the default config file, all players are greeted with the same name. The name appears to be the first person to login after the plugin is enabled for the first time. cbukkit 114.
  3. Offline


    Quick update: fixed the /help bug. Will answer all above questions as soon as I get back in 15 minutes, but sorry, I have to run!
  4. Offline


    when you type /afk, it would set your status to AFK when searched up in /whois. Generals /whois shows the players name, location, health, and status. If your not afk, it just says Around. if you typed /afk, it changed it to Away.

    I thought it was pretty sweet!

    I feel like such a jerk, because I use a TON of that developers plugins. For some reason though, General just wouldn't work for me =/
    --- merged: Jan 22, 2011 7:31 PM ---
    + This.
    Same thing here
    --- merged: Jan 22, 2011 7:46 PM ---
    Ok, I figured it out. It's World Edit
    I removed World Edits and World Guards folders and jar files. Then I added WorldEdit first because it's needed for WorldGuard. Typed /version, and crash.


    Thanks for all your support and work again bud. We appreciate it!
  5. Offline


    I've just found out, as I believe you've already mentioned, the config file is terribly sensitive to indentation. For the longest time, I couldn't figure out what was causing Essentials to spit up errors. I eventually found that one section of my kits was missing a space. For the sake of helping others troubleshoot the problem, I've put the section that helped me in bold. It can be seen after the spoiler.
    Show Spoiler
    Jan 22, 2011 11:29:07 AM org.bukkit.plugin.SimplePluginManager loadPlugins
    SEVERE: Could not load plugins\Essentials.jar in plugins: null
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.c(
    at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    ... 8 more
    Caused by: while parsing a block collection
    in "<reader>", line 91, column 5:
    - 302 1
    expected <block end>, but found Key
    in "<reader>", line 95, column 5:

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.jav
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeDocument(
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(
    at org.bukkit.util.config.Configuration.load(
    at org.bukkit.earth2me.essentials.Essentials.<init>(
    ... 13 more
    I appreciate beautifully indented code as much as the next man, but it seems a bit.. strict.
  6. Offline


    ok, so what? you removed worldedit and worldguard, and the player name function for Essentials started acting properly?
  7. Offline


    Update: Hopefully fixed the MotD backward-incompatibility once and for all with this release. If not, it has to do with Bukkit, and is beyond my control. Also added /msg support.

    @highwisdom I believe that is what he is saying. However, I have both, and /version and /plugin list work fine for me. It's gotta be some really weird bug.

    @techkyle That is the new configuration format adopted by Bukkit: it's called YAML. I despise how it requires spaces instead of tabs.

    @Nate204 I use a ton of his plugins, too, but for some reason, General just hates me. :p

    @obliviron Try renaming your config and working with the default. That way, we'll know if it's a bug or a configuration issue.

    @highwisdom I believe the MotD issue is a bug in Bukkit: it sends Essentials the wrong player!
  8. Offline


    Thank you Zenexer for the /msg support :)
  9. Offline


    Will test out update 44 once i have less users logged in. feel bad rebooting on them constantly haha

    btw, this is sort of unimportant, but in your OP's sampel config file:

    "# Restricted commands will only be available to ops.restrict-tp: true"

    should be:

    "# Restricted commands will only be available to ops.
    restrict-tp: true"


    Edit: Feature Request: option to disable the /help command so it doesn't funnel through Essentials. I'd like to use MCDocs to make my own help.txt file and have the command read it. As is, the Essential help file is full of commands that most users can't access.
  10. Offline


    Oh yeah! *why was I bug testing these plugins again?....*

    When I type /plugin list nothing happens.
    At least it doesn't crash my client anymore.

    Oh, and all /plugin commands arn't working. I'll check my setting quick. I'm in OP and Permission Admin. They should go~
  11. Offline


    I want to set permissions with persmissions plugin, this is my config:
    # Do not move, modify, or erase this line.
    version: 40
    #command-prefix: 'g'
    nickname-prefix: '~'
    default-stack-size: 64
      - '&cWelcome, {PLAYER}!'
      - '&fType &c/help&f for a list of commands.'
    disable-tp: false
    disable-tele: false
    disable-tphere: false
    disable-telehere: false
    disable-s: false
    disable-item: false
    disable-i: false
    disable-give: false
    disable-g: false
    disable-list: false
    disable-playerlist: false
    disable-who: false
    disable-online: false
    disable-home: false
    disable-sethome: false
    disable-mail: false
    disable-helpop: false
    disable-clearinventory: false
    disable-getpos: false
    disable-coords: false
    disable-nick: true
    disable-whois: false
    disable-realname: false
    disable-realnick: false
    disable-spawn: false
    disable-setspawn: false
    disable-tree: false
    disable-bigtree: false
    disable-top: false
    disable-time: false
    disable-kit: false
    disable-plugin: false
    disable-help: false
    disable-heal: false
    disable-motd: false
    disable-ban: false
    disable-kick: false
    disable-unban: false
    disable-pardon: false
    disable-banip: false
    disable-unbanip: false
    disable-pardonip: false
    # Restricted commands will only be available to ops.restrict-tp: true
    restrict-tele: true
    restrict-tphere: true
    restrict-telehere: false
    restrict-s: true
    restrict-item: true
    restrict-i: true
    restrict-give: true
    restrict-g: true
    restrict-list: false
    restrict-playerlist: false
    restrict-who: false
    restrict-online: false
    restrict-home: false
    restrict-sethome: false
    restrict-mail: false
    restrict-helpop: false
    restrict-clearinventory: false
    restrict-getpos: false
    restrict-coords: false
    restrict-nick: false
    restrict-whois: false
    restrict-realname: false
    restrict-realnick: false
    restrict-spawn: false
    restrict-setspawn: false
    restrict-tree: true
    restrict-bigtree: true
    restrict-top: true
    restrict-time: true
    restrict-kit: false
    restrict-plugin: true
    restrict-help: false
    restrict-heal: true
    restrict-motd: false
    restrict-ban: false
    restrict-kick: false
    restrict-unban: false
    restrict-pardon: false
    restrict-banip: false
    restrict-unbanip: false
    restrict-pardonip: false
    # Note: All items MUST be followed by a quantity!
    # Times are measured in seconds.
        delay: 10
          - 277 1
          - 278 1
          - 279 1
        - 20 64
        - 20 64
        - 20 64
    # Supports "Default" and "GroupUsers"
            system: essentials
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:"
    #   field seperated by commas.
    #   Example: inheritance: Default,Admins,
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - 'general.spawn'
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'general.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
            default: true
                build: true
                - 'essentials.list'
                - 'essentials.home'
                - 'essentials.sethome'
                - 'essentials.mail'
                - 'essentials.helpop'
                - 'essentials.getpos'
                - 'essentials.spawn'
                - ''
                - 'essentials.motd'
            default: false
                prefix: [OP]
                build: true
                - Default
                - ''
                - 'essentials.tphere'
                - 'essentials.nick'
                - 'essentials.kit'
                - 'essentials.kick'
                - 'essentials.ban'
                - 'essentials.unban'
                - 'worldguard.region'
            default: false
                prefix: [Admin]
                build: true
                - Moderator
                - 'essentials.item'
                - 'essentials.give'
                - 'essentials.clearinventory'
                - 'essentials.whois'
                - 'essentials.setspawn'
                - 'essentials.tree'
                - 'essentials.bigtree'
                - ''
                - 'essentials.time'
                - 'essentials.plugin'
                - 'essentials.heal'
                - 'essentials.banip'
                - 'essentials.unbanip'
    # DarkGrave has control over all commands.
    # sk89q can use /spawn & /time
            group: Admins
    And my normal players can do tp and other command. What i must change?
  12. Offline


    @highwisdom Nice catch! For /help, simply add "disable-help: true".

    @Nate204 If you are an op, it won't even attempt to check the permissions: it will let you do whatever you want. ;) What happens when you try to use it?

    @WMP I've been having issues with Permissions. I'll look into that for you and get back to you on that.

    Update: Added /afk and expanded /whois. Should I make /who an alias for /whois, rather than /list?
  13. Offline


    When I type /plugin list
    2011-01-22 14:31:40 [INFO] nate204 issued server command: plugin list
    2011-01-22 14:31:40 [INFO] Unknown console command. Type "help" for help.

    TY for the AFK!! =D
    --- merged: Jan 22, 2011 8:33 PM ---
    btw, the consol says Unknown command for every command. Even if they work...
  14. Offline


    Could we get some sort of changelog for this plugin meanwhile? Like, in the top post. I'd like to be able to see what has changed without having to slog through the entire thread. It's mostly noise. :(
  15. Offline


    When I type /plugin reload Essentials,
    It says it's reloaded it in the console, but then nothing works =S
    It's like it's having some sort of hang up now.
  16. Offline


  17. Offline


    /setspawn,/ban,/unban,/pardon is Bronken...
    Error message: Error 0/1

    I'm OP & Admin...
  18. Offline


    Another Request
    maybe /fly
  19. Offline


    Using Permissions people can use all commands
    The only way I stopped them is enableing the command to OP only
    But I need my mods to be able to /kick and /give still
    Is this a problem with essentials or Permissions
  20. Offline


    @Kylei Are you using the latest build of CraftBukkit? /setspawn is known-good on the latest build. Ban, etc. are still in beta.

    @WMP You've got me stumped! Using a similar configuration, I have no issues with /tp and other commands. Try posting in the Permissions thread; @Nijikokun is the expert on Permissions, and knows a lot more about it than I do. I think you are experiencing a problem related to Permissions, not Essentials. If you want, I can send you a "verbose" build that will report certain errors that would normally be "expected", and we can see if we can sort it out.

    @DoritosMan Permissions is not loaded if the "restricted-" commands take effect. Ensure that you have it loading properly.

    @chernobyl360 I made a client that does both of those things. It might be due for an update, but you can check it out at
  21. Offline


    I think the common usage is:

    /who, /list, /playerlist, /online = a list of players logged in
    /whois, /playerinfo = details of only one currently logged in user

    so making /who and /whois function the same is counterintuitive

    what might be interesting would be to make the /whois function as a sort of personal profile even if the user if'd be able to set a single line of text (similar to MyWarp's welcome message, or Essential's /mail feature) that will display when someone whois's you.

    so if someone goes "/whois highwisdom" when i'm offline it might show..text in () is my customized "title":

    highwisdom (is the admin of this server, and likes green tea).
    [login status or time last logged in]
    etc etc

    ideally, color codes would be worked in too..and even MORE ideally, you'd somehow rig a way to input multiple lines of text..up to 10, since that's all the chat buffer can display at once..

    a possible feature for the /who command might be descriptive /who searches...for exmaple

    /who ops
    /who farmers

    providing such groups are setup in compatible permissions plugins..the results would list members in those groups, and maybe have different colors for online/offline users.
  22. Offline


    @Zenexer: I thing this is problem on Essentials - maybe Essentials dont know about Permissions and himself working(only with exxentials config). I write to @Nijikokun.
  23. Offline


    I can't seem to use the Prefix commands.
    The don't show up at all.

    What am I doing wrong. [​IMG]
  24. Offline


    @WMP Well, it's working for me, so it must be a configuration or version difference issue.

    @Danxl5 Due to the direction in which Bukkit is headed, I am forced to drop support for command prefixes. Why are you using it, so that I may find an alternative for you?
  25. Offline


  26. Offline


    How do I give control of all commands over to Permissions? If I set them to restricted people with Permissions can't even use them, and if I set them to unrestricted people without the command in Permissions can still use them.
  27. Offline


    @AbsolutePolak What happens when you try to use them?

    @KiloWhiskey Permissions isn't loading properly if the "restricted-" permissions take effect. The Permissions plugin, when loaded, renders the "restricted-" options inert. Were you using Permissions previously? Is it possible that Permissions isn't even loaded?
  28. Offline


    /nick doesn't work for me. It just ignores my command.
  29. Offline


    I installed the plugin, fixed permissions and commands for certain groups, reloaded the plugin. I tried a command but nothing happened, please help me.
  30. Offline


    it just says no command found.
  31. Offline


    @Desereck You wouldn't happen to have "disable-nick: true" in your config.yml file, would you? ;)

    @Suprem20 Let's start with the basics. Are you in ops.txt?

    @AbsolutePolak Then they are disabled in the config.yml file. Change "disable-XXXX: true" to "disable-XXXX: false". That is for completely disabling commands, not permissions.
Thread Status:
Not open for further replies.

Share This Page