Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Jan 22, 2011 4:41:09 PM org.bukkit.earth2me.essentials.Essentials loadData
    SEVERE: null
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
    at org.bukkit.earth2me.essentials.Essentials.loadData(
    at org.bukkit.earth2me.essentials.Essentials.reload(
    at org.bukkit.earth2me.essentials.Essentials.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.c(
    at net.minecraft.server.MinecraftServer.d(
    Loaded Essentials version 40 by Zenexer.

    after update to rev 40 i have this in my console... is it an error?
  3. Offline


    hey. i'm still stuck on those custom item names for the spawn list. would you consider putting in an optional config file for that specific use?
  4. Offline


    It doesnt look like i can use any of the commands only availabe to "ops.restrict-tp: true" like item,give,setspawn,plugin,tp,tphere etc
    Doesnt that line mean than only ops can use those commands? or do i need to make a file and add my name to it?
  5. /setspawn does work for me with it, it is just that it doesn't work when placed inside a building, if you place it there and type /spawn you end up on the roof instead of inside it, it's not an exact spawn either, sometimes, if the building is small, you spawn next to it instead.
  6. Offline


    So everyone has /give even if i disabled it in all ways possible and the groups dont even have the cmd but still can use /give.
  7. Offline


    @gene Myers I'm not sure! I certainly can't think of why that would be, and I can't reprodue the problem.

    @willystylee Sort of like hmod WorldEdit's /jumpto? I miss that command terribly.

    @TheDarkM Do you receive any errors?

    @shadrxninga I only know so much about Permissions; you would probably be best off asking that question in the Permissions thread.

    @FabianN There is no limit, so good thing. :p I'll see if I can get to the bottom of it. Are you using Permissions?

    @Ryan Hamilton I made a plugin called AreaChat for limited range. You can get info about a user's real name using /whois. I like the kits-costing-money idea--I'll definitely look into that. Coloring groups can be done with Permissions, a plugin that I highly recommend. Currently, there is no means of determining what the crosshair is aimed at via the API. I meant to remove "Some commands might be disabled", because disabled commands no longer appear in help.

    @Hoddie54 I will enable error reporting for that feature in the next build. If Permissions throws an error, Essentials resorts to config.yml.

    @BeerBaron Permissions provides the asterisk node (*), which acts as a wildcard for all nodes.

    @Lolmen Hmm... do you have Permissions installed?

    @StyphaX I'll look into that--you should not be seeing that error. It is an EXPECTED error, though: it just means no MotD is defined. It should be blocked from view.

    @kretu Will-do.

    @Denni199 No, you do not edit users.yml. It is for the plugin to edit. It is not for permissions.

    @Kylei With the latest Bukkit?

    @Rallerbabz I'll see what I can do about that

    @fnullerbasse It is tested and known to work with Permissions.

    @Beatkidz You probably have Permissions installed, which takes precedence over the config.yml permissions provided by Essentials.

    @Adrian Brilliant idea. I'll add it to my "make that shizzle today" list. You saw TeleConfirmLite.

    @lawina /tell

    @Jonne Currently, there is no way to provide group-specific kits. A specialized plugin would be better in the meantime.

    @Bazzam Essentials does not use items.db. It uses hard-coded item IDs for efficiency. I'll see what I can do about wool today.

    @Drakehawke I love both of those ideas. I'll add them to my todo list.

    @Sneedlewoods Your users.yml file is corrupt. You should not edit that file manually.

    @Solaris765 Yes, I will certainly look into it.

    @s0nge Yes, that line means that only ops can use that command. The Permissions plugin will take precedence, however, leaving those config options unchecked. Note that operators automatically get permission to use all commands, regardless of any settings.

    @Graloth The spawn-on-top thing is a restriction placed by Notch, and is intended to ensure that users do not spawn "inside" a block.

    @PanCakes Can you send me your configuration file? Are you using Permissions?
    Ryan likes this.
  8. Offline


    Um.... I cant use /plugin reload XXXXX
    When I do, It "says" it's disabled and reenabled the plugin, but it only just turns it off. I'm thinking it does the whole process too fast. Back in Hey0, you would turn it off (wait a second or two) then turn it back on again.

    Also, if I try and enable a plugin with /plugin enable XXXX (in this case, the one that reload didn't turn back on) my game crashes. It's not the server, just my game...

    Does anyone else have this same problem?
  9. Offline


    wooah, thats support :confused: :D
  10. Offline


    Question. Does the ./kick,/ban work for moderators?
  11. Offline


    Permissions is not installed. and these only became restricted after i customized the config file.. not before
    plugins installed - PreciousStones, Essentials, worldguard, Worldedit, Healthy. i'll try it with permissions when i get back to from work in 10hours
  12. Offline


    Updated with better support for /item and /give. You can now add data suffixes to item IDs. For example, if you wanted to spawn birch, you could do /item log:3. Any non-alphanumeric/space character will work as a separator, so /item log,3 and /item log*3 and /item log-3 all mean the same thing.

    Edit: I forgot to mention that item validation is also part of this update. Sorry, but you can't crash your client anymore.
  13. Offline


    Actually, it's /plugin list that crashes my game. I simply can't seem to get this part of the plugin to work =(

    Just to try and add, is there anyway you could add a "Welcome USER to XXXXX server"? to the motd? I love how personal it sounds. I appreciate your time and effort. Your plugin worked right out the gate for me, and for this~ I'm very happy.
    (well, the /plugin things aside.)
  14. Offline


    Support for healing other players by using /heal (player) please? :D
  15. Offline


    Updated with support for /heal [player] @Seth.D

    W00T, update number 42!

    @Nate204 What plugins do you have installed? Does /version work? Can you provide an error message in the console? For the MotD, try "Welcome to XXXXX, {PLAYER}!"
  16. Offline


    (this appears to be the problem since deleting their .dat file fixed it, but may still be useful)
    Just had a user accidentally try and spawn one of the old cloth blocks, thus causing them to crash and ultimately be unable to join the server. I think something should be done about players trying to spawn these blocks. (assuming that's the problem)
  17. Offline


    Thanks for answering my question guys!!! ... not ...
  18. Offline


    Thank you, Zenexer. You're probably the best plugin developer with your quick replies and quick updates. :D
  19. Offline


    No it doesn't =(

    I just installed HotSwap to try and work around it, but I'll disable it now. It did nothing anyway~

    I have:
    Big Brother
    Essentials =P

    P.S. Sorry about the MOTD, I just saw that on the very first page -.-;
    Thank you for the non-rage response. Much appreciated.
  20. Offline


    One of those plugins is bugged. /version is built into Bukkit itself. And yes, HotSwap has been merged into this plugin.
  21. Offline


    I should try and update them all and update Bukkit then?
  22. Offline


    Thank you for your quick reply, but /tell doesn't seem to work for me (no response either) and I have full permissions?
  23. Offline


    Not sure what's causing this but um, I did /setspawn, but now my compass points to what is essentially a random spot on the map (neither the old spawn or the new one)
  24. Offline


    I can't use any commands (or atleast not /time day) Do you know why and how I can fix it?
  25. Offline


    Ok, I've redownloaded and installed ALL my plugins....
    /version still crashes my game. wth?

    I feel like my server is a little bit broken right now >.>

    I know this is going to sound like a total rip from General, but can you implement a /afk setting?
  26. Offline


    @ikkyblob You probably aren't in ops.txt

    @Nate204 Process of elimination: disable half your plugins, then half of the half that still breaks it, etc. Once you get a name, I'll talk to the plugin developer.

    @Digit Thanks for the heads up. I'll get that fixed shortly.

    @lawina It's part of Minecraft, not Bukkit/Essentials, so it doesn't give you any feedback. It still works, though.
  27. Offline


    Ahh didn't know that, thanks a ton Zenexer. Maybe you can add a /msg with feedback tho :))
  28. Offline


    Good idea: I think I will! ;)

    @Nate204 What exactly does /afk do? I've never used it. xD
  29. Offline



    version: 36
    #command-prefix: 'g'
    nickname-prefix: ''
    default-stack-size: 64
    - '&cWelcome, {PLAYER}!'
    - '&cPlease go <Website lol> for the full server rules'
    - '&cEnjoy your Stay!'

    disable-tp: false
    disable-tele: false
    disable-tphere: false
    disable-telehere: false

    For some reason imageshack isn't working, so i can't create a screenie D:. Do you see anything wrong with the config?
  30. Offline


    Wow, 5 min later.... WorldEdit and/or WorldGuard is causing the CTD (if you want to call it that) when typing /version.

    I say it's one or the other, because to use world guard, you MUST have world edit..... and Once I take one or the other off, it screws up. I'll try and fully remove them both (folders and all), and then manually install them again.
Thread Status:
Not open for further replies.

Share This Page