Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Ok iv been using this for a while and thought i would share with you all how to get the new build working.

    Got to your plugins folder and remove the plugin EssentialsProtect.jar this is giving most folk errors when starting the server. The file will need to be fixed and/or updated as it cant run propperly.

    Now since the new essentials build uses a plugin file for its /spawn and /setspawn comands you will need to add -'essentials.spawn' to the user group you want to allow /spawn command.

    if you do the above then you will find most of your problems will be fixed.

    if you need any help with anything dont be scared to ask.

    Waves - TM
    tremor likes this.
  3. Offline


    Okay I deleted the home co ords for everyone and now it works. But for some reason when I do /home or /spawn, it doesn't move me exactly to where I was standing. It's offset by a block to the back-right of where you were standing when you used /sethome or /setspawn. Is there any way to make it place me EXACTLY where I was standing? I have OCD when it comes to symmetry and with this bug, I can't spawn directly in the middle of the doorway.
  4. Offline


    Hey, do you know how to give my groups different colors? The plugin i was using for that hasnt been updated and probably wont be. Thank for any help =)
  5. Offline


    Like many others, I can't get my users to have access to the /spawn command. It tells them they don't have permission. I am using the latest Essentials that has the separate EssentialsSpawn.jar plugin file. I have tried using both Permissions and GroupManager.jar with FakePermissions.jar (after deleting my Permissions.jar and keeping my Permissions folder,) but it still doesn't work. I tried to use the /manuaddp command to manually add permissions to a user in the default group, but it said the user didn't exist... so I added the user to the Default group in my config file. The user still couldn't /spawn, so I tried /manuaddp to give him access to spawn again, but it still says the user doesn't exist.

    I know the config file is being read because if I /manulistp on myself, it tells me I'm in the Admin group and have permissions on '*' which is exactly how I wrote the file.

    Before Essentials split apart into a bunch of different plugins, I never had any of these problems. People could spawn and sethome just fine without the server telling them they don't have permissions... does anyone know how to get this to work again?

  6. Offline


    I can actually answer this one! Use EssentialsChat.jar and remove your old plugin for chat (especially if it was iChat). Then in your permissions configuaration give your different levels a color "prefix"....

    that's if your still on permissions... not sure whats going on with group manager as far as this goes
  7. Offline


    hmm I switched to group manager this morning lol =) damn it. what to do
  8. Offline


    There is your problem.
  9. Offline


    Anyone else having their whole server go down if they type in /spawn?
    I'm sure it's a conflicting plugin or something. I've got essentials.jar and essentialsspawn.jar with permissions 2.1, craftbukkit 424.
  10. Offline


    so it doesnt support colors in prefix?
  11. Offline


    bwl doesn't seem to know what he's talking about. If you're using iChat and the GroupManager wrapper, you should have the colors.

    Correction: iChat hasn't been updated for 1.3, so... yeah.
  12. Offline


    In a bit of a hurry cause people are waiting for me to set it all up.. um. This is great, just one little question that has probablöy been answered before, but I'd appreciate an answer :)
    The GroupBridge.jar is basically what the "Fake Permissions" is in the pure GroupManager? I downloaded the latter first, but I guess it's fully integrated here so all I need is the Essentials pack?
  13. Offline


    Yes, exactly.
  14. Offline


  15. Offline


    Great, thanks. Working good so far.

    I found only a little bit of documentation about EssentialsChat which is supposed to support the colored chat tags as well, i.e. [Admin] zankioh: blahblah. Now the documentation said to do this in the config, but I strongly assume it has to be data.yml
    So I can see that I could set a prefix/suffix per group, but what if I wanted to do this per user?
    I tried utilizing the same style permissions had, which would then look like this for example:
    permissions: []
    group: Admins
    prefix: '&4'

    But it doesn't work, so I guess that either they can only be set at group level or there is a different syntax that I didn't find?
    tl,dr: I want to have one guy shown like this: [VIP]User1 while another one might be [VIP]User2, despite both belonging to the same group. Ty in advance :)
  16. Offline


    Why it's prepering spawn location for nether, since I had updated the essentials.jar? Can I turn it off? I don't want to have nether. I would like to have nether with MultiVerse, and WorldGuard doesn't supports it yet
  17. Offline


    Well... actually it already works.
    The only trouble I am having is with /item and /time commands. The spawn and home commands have shown me no errors on the recommended build of bukkit (432) and Essentials 231 (most recent build as of yesterday.) Also permissions works just fine, unless the item and time commands are somehow tied to things (in which case i'm simply being treated as a default group, rather than an admin, no big deal as long as players can't abuse admin commands.)
  18. Offline


    "Breaking News: Essentials Sucks?
    It has come to my attention that several notable plugin authors have egos a bit too large for their shoes, and are thus badmouthing Essentials because they can. I despise plugin politics, and will not be getting involved in this nonsensical argument."

    I use essentials and think it's great, but posting this doesn't help anything, and is in fact in contradiction with what it says.
    fitofinsanity likes this.
  19. Offline

    Soul Reaper

    everything is working fine for me, latest build of essentials and craftbukkit. I loaded the fake permission plugin from groupmanager for myhome.

    only nitpick i have is that the data.yml file changes from what permission uses to a strange format. I tried editing it but server keeps coming up with null errors. In the end I just recopied a backup and changed what i needed.
  20. Offline


    Personally.. i wasn't even aware of this problem until you told me about it... Do yourself a favor and remove it.

  21. Offline


    I am also experiencing a similar issue with the /setspawn command and dying. Running build 231 on CB 432. I can set the spawn area just fine, but when I die, I end up in a completely different area. I have to do the /spawn command to actually go back to the area that I set. Correct me if I am wrong here, but isn't the /setspawn command supposed to mark the area where you spawn when you die? Also, I noticed that if you set a spawn area where there is a roof above you, you end up on the roof above the spawn point you mark.
  22. Offline


    Signs don't seem to work.
    This is the error I get when making a [Protection] sign next to a chest.
    CB 439
    Essentials 515-517
    2011-02-24 21:59:56 [SEVERE] Could not pass event PLAYER_ITEM to EssentialsProtect
        at com.earth2me.essentials.protect.EssentialsProtectPlayerListener.onPlayerItem(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.ItemSign.a(
        at net.minecraft.server.ItemStack.a(
        at net.minecraft.server.ItemInWorldManager.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
  23. Offline


    I disabled some outdated plugins to test out a separate issue, and essentials now works PERFECTLY with every single command I use on CB 432 and Essentials 231. Great work guys, seems it was me all along with the minor issues I was having!

    Woops, spoke to soon, /time day and /time night doesn't work... no biggie though.
  24. Offline


    Can't wait to get out of work and start the update / catch up game!!!

    On another note, Could we have EssentialsSpawn add a feature? I love the spawn by group level... now, what I'd like to see is..... MULTI-SPAWN by Group Level. I want to drop someone into a set of random (pre-selected) locations when they spawn. Especially the default group.. reason: my spawn area is just getting overcrowded, overgriefed.. etc... on a busy, popular server, it helps to spread the map out a bit. So.. ty plz look into it :)
  25. Offline


    How would I get this to work with Permissions?
    I've never used the Permissions plug-in and I've no idea how to enter it in there.

    Thanks in advance.
  26. Offline


    Can you please explain if the new essentials can allow people to visit the server but not have any access unless you add them? And could you explain or show me an example how to add the group or setting.
  27. Offline


    Has the issue of default stack size with the /item command been fixed? Or does anyone know of a workaround?
  28. Offline


    Does this still work with permissions 2.0 or do I need 2.1?
  29. Offline


    Last I checked, 2.1 doesn't work. However, if you keep your config.yml file for 2.0 in place, and just delete the Permissions.jar, and then include the two "group" plugins from Essentials, it will import your Permissions settings.

    The group plugins provided by Essentials works perfectly fine for me.
  30. Offline


    Can you give me a run through on how to install essentials? I seem to be getting errors everytime I do it :(
  31. Offline


    Essentials 515 got that fixed.
Thread Status:
Not open for further replies.

Share This Page