Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Can someone please tell me which build works with which essentials?
    Meaning... correct permissions using "Permisions" and working /home, /spawn, /sethome

    I notice the last "recommended" stable build of bukkit is a version NOBODY is using (53)... so I would love to know what the REAL stable build is that people are able to make work with permissions and essentials. The other plugins I use are all secondary to these.

    Edit: I am on 345 right now, and everything works... so anything above this would be great (especially those that work with 1.3)

    Edit again: I just found an answer to my question, here is the thread if anyone else has the same question!
  3. Offline


  4. Offline


    No sir, this is on 227 now, op hasn't updated. Go check it out!
  5. Offline


    Only the dev build works with 1.3 and they locked those up

    Sooo either they release them or i make the switch to something else :(
  6. Offline


    hey i have a problem. when i run permissions v2.1 it says permissions has been enabled and mcmmo recognizes it and it says its all running however when i try the modgrp command it says "Eroor: this server is not using permissions." what do i do to fix this? it also did it with permissions 1.9. i should also add that i have done nothing to the permissions config file. I just put the mods in and tried to run the server.
  7. Offline


    I'm having the exact same issue.

    The IRC room isn't very helpful either. I just get things like "update your craftbukkit" even though I am on the latest build offered :/

    No clue how to solve this, and I don't think anyone else does yet either.
  8. Offline


    i fixed it and man do i feel retarded... the config file isn't named config.yml its remame-me.yml so you rename it to config and it works LOL GOD i feel dumb!
  9. Offline


    Edit : nope still just spams my console with errors and cmds not working.
    build 432 now..

    Edit : 2 located my issues..
    I was downloading the essentials group pack = buggy for me.
    however after removing all but the core and help which is most importent for me.
    it works fine..

    so one of the other builds from the pack is causing issues.
  10. Offline


    is there an essentials build that is compatible with minecraft 1.3? and if so, where can I download it?
  11. Offline


    I'm a little confused. What exactly is EssentialsGroupBridge.jar and EssentialsGroupManager.jar? Should I use them if I already have GroupManager installed?

    Also, what purpose does EssentialsServerlist.jar serve?
  12. Offline



    I am running Essentials 227, downloaded from the main website.

    Everything works but Teleport.

    The error I get is:

    2011-02-23 22:48:05 [SEVERE] java.lang.NoSuchMethodError: com.earth2me.essentials.Essentials.isPlayerAuthorized(Lcom/earth2me/essentials/User;Lcom/earth2me/essentials/commands/IEssentialsCommand;)Z
    2011-02-23 22:48:05 [SEVERE] at com.earth2me.essentials.tele.EssentialsTeleWorker.onCommand(
    2011-02-23 22:48:05 [SEVERE] at com.earth2me.essentials.tele.EssentialsTele.onCommand(
    2011-02-23 22:48:05 [SEVERE] at org.bukkit.command.PluginCommand.execute(
    2011-02-23 22:48:05 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(
    2011-02-23 22:48:05 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.NetServerHandler.c(
    2011-02-23 22:48:05 [SEVERE] at
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-02-23 22:48:05 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    2011-02-23 22:48:05 [SEVERE] at
    2011-02-23 22:48:05 [SEVERE] at
  13. Offline


    Everything seems to be working fine on 1.3 now, but I've got one problem: /home once again doesn't seem to work. I've transported my /userdata folder to the new server setup, but when trying /home, I get

    Cooldown: null.

    Anyone know what this is about? Not a huge prob from us though, as we can tell anyone on our server to prepare for their /homes lost, but still...
  14. Offline

    Nathan C

    I've always had problems with it's home function.

    Try using multiplehomes. I use that for weeks, no problems. Still works on latest build too!
  15. Offline


    I'm using essentials and the commands work fine but even though I made the default stack size 1, /item still gives me 64. This is the only thing the config doesn't read, I think.
  16. Offline


    I'd like to know the answers to these questions as well.
  17. Offline


    anyone know why it takes so long to TP? ? like I can sit there falling through void for awhile, relog fixes it.d
  18. how long till you update so that it works with 1.3 i know home and help dont work atm
  19. Offline


    I hate zenexer for forcing me to switch to group manager.
  20. Offline


    Is there any reason Teleport does not work on CB: 432?
  21. Offline


    Does Essentials work with the latest craftbukkit build? 433? I'm having problems..
  22. Offline


    tbh, a lot of plugin dev's on here seem to think they are 'oh so amazing'.
    Honestly, you'd probably make a better version of the plugins THEY make, without all the bull and stuff like
    'oh, my plugin is so amazing, I didn't bother to make it compatible with all the other popular plugins'.

    and fyi, i love their plugins, hate the attitude they have....what's with all this 'competition'? they seem to be trying to make a scene....

    Oh, as for a real question: This works with either Permissions or GroupManager? And is it updated for 1.3?

    - skawke
  23. Offline


    I'm using craftbukkit 432, Permissions 2.1, Essentials.jar (229), and EssentialsSpawn.jar (229)
    For the most part they are running good. I'm having trouble with my spawning location.
    I use the /setspawn command it successfully creates the spawn. When I type /spawn it takes me to the correct location. However, if I die out in the world somehow, it spawns me in some crazy location like 100 blocks up in mid air in the middle of nowhere. Why is this?

    Now for a completely different issue. After setting my spawn location. I go off exploring and get very far away from the spawn. Far enough away that the area is unloaded. Then when I type /spawn to go back to spawn location. It successfully takes me back to the spawn but it doesn't load the world at your location and expand out like it used to do. Instead it seems to load from one side to the other. This is kinda of annoying because you have to just sit there bouncing in nothingness until the loading world finally reaches you.

    Thanks in advance for any help.
  24. Offline


    Its an issue with something bukkit pout into the last build which Mojang was meant to include in the 1.3 update and didnt. So bukkit are probably adding it again at the moment :D. Relogging is the only way now :D
  25. Offline


    anybody figure out how to fix /item? it still gives me {ITEMSTACK COBBLESTONE x 0} or something like that when i try to spawn an item
  26. Offline


    Is this now packaged with a /search? I need to know so I can remove my other search plugin. Not sure where the new /search is coming from.
  27. Offline

    Amin Azman

    cant use /sethome /home /setspawn /spawn ...
  28. Offline


    Love essentials, can't figure out protect.

    running on dedicated linux (ubuntu 10.10)
    MC server 1.3
    Craftbukkit version git-Bukkit-0.0.0-453-g51b7cd8-b435jnks

    everytime I try to load essentials protect, it pukes. The server still runs, but I don't like the errors.

    here is the error I am getting:

    2011-02-23 21:26:22 [SEVERE] Could not load plugins/EssentialsProtect.jar in plugins: null
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
            at java.lang.reflect.Constructor.newInstance(
            ... 8 more
    Caused by: java.lang.NoClassDefFoundError: com/earth2me/essentials/Essentials
            at com.earth2me.essentials.protect.EssentialsProtect.<init>(
            ... 13 more
    Caused by: java.lang.ClassNotFoundException: com.earth2me.essentials.Essentials
            at Method)
            at java.lang.ClassLoader.loadClass(
            at java.lang.ClassLoader.loadClass(
            ... 14 more
    I have no idea what is wrong at this point.
  29. Offline


    im using essentials to add a nether world to my server. portals are active. when the nether portal was generated, it seems to have disallowed any editing of the chunk containing it. also, when going back through the nether portal, it did not return to the original portal in the regular world, but generated a new one, this chunk is also now uneditable.
    i disabled portals, and the chunk in the regular world is still uneditable. uneditable meaning: you break blocks and they come right back. restarted the server several times, problem still remains. to make matters worse, the chunk in the nether where the portal is, is walled in, so we cant even get anywhere in the nether since the blocks just come back.
  30. Offline


    Ok in my config file, i have it set as this:
    # The number of items given if the quantity parameter is left out in /item or /give.
    default-stack-size: 64
    But when i type in the command "Give <Name> <ID" instead of giving the person 64 of the item, a message shows "Giving 0 of <Item> to <Name>" and it will show 1 block, when trying to place that one block, it disappears from inventory, and does not place on the ground, only been like that since the update yesterday.
  31. Offline

    dark navi

    Stack sizes seem to be malfunctioning. It seems to always want to give out 64 of any items spawned. Not horrible, but a small nuisance.
Thread Status:
Not open for further replies.

Share This Page