Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    Has anybody got the dc.allowflight.<world> permission to work? I'm using the latest bukkit permissions as well as the latest dev build and wanted a usergroup to have access to flying in my world called 'world'.

    is that correct? My users still get kicked for flying. (zombes flymod)
  2. Offline


    Damn, I can't succeed in configuring your plugin correclty with PermissionBukkit...
    I've tried by detailing every single permission node and with dc.* but nothing works.

    I don't understand your choice of dropping Permissions support.
  3. Offline


    Hey, great plugin, I'll probably donate a small amount when I next get a small amount of cash left over. I really appreciate this plugin.

    I have a small feature suggestion: Public / private warps, so that players can set warps for themselves (say "mine" or "dungeon" or "base2") that don't conflict with other players' warps. I suggest you use a flag in whatever file you store the warps that declares them as such, i.e. no flag = public, flag = private. In which case you could also make it a Boolean, but that would cause compatibility problems so I recommend the flag.

    Anyway, I'm rambling :)
  4. Offline


    I asked for this previously, but he said that it's probably a bit too complex for him to add now. If you need more comprehensive warp support, there are probably decent plugins dedicated to just warps. I haven't tried it on a multiwarp server, but xWarp worked fine for me previously.
  5. Can any one tell what was the last version of dc that supported Permissons 3? I'm having such a hard time migrating...
  6. Offline


    Stable version 3.5 (not the dev build) was still supporting Permissions, I think.

    Else you can use PermissionsEx, I was having a hard time for that too, but PEX is very similar to permissions and it finally ended well.
  7. Offline



    Don't get me wrong i'm glad you now support bukkit permissions but i'm unsure where i can use the * in the permissions.

    Can i use it for the world names? portal names? where?

    Maybe you could bold the bits where it can be used?

    At those that are complaining about the no permissions 2/3 support Build a Bridge Bahhahaah.
    But srsly permissions bukkit is far better i have noticed far less lag on my server.
  8. Offline


    Error -

    Plugins - BetterShop, BigBrother, DeathMessagePlugin, DefaultComm
    ands, iConomy, PermissionsBukkit, Permissions, Tetris, WorldEdit

    CraftBukkit: #1060

  9. Offline

    Don Redhorse

    hi, would it possible that you implement command toggles for /dcgod, /dcignoremob etc?

    Atm everytime you reconnect you need to issue the command again.
  10. Offline


    Anywhere, * means every node.

    Use the dev build of PermissionsBukkit.
  11. Offline


    Is the dc.allowflight.<world> still a work in progress vildaberper? I still get kicked by the console for flying even though I applied the following permission:

    My world is called 'world' and other worlds have different names. The console notifies me that a user was kicked twice for whatever reason:

    20:50:50 [WARNING] techburn was kicked for floating too long!
    20:50:50 [INFO] true ''
    20:50:50 [WARNING] techburn was kicked for floating too long!
    20:50:50 [INFO] false ''
    Any insight on this would be appreciated. This plugin is by far the best / easiest to use, just need that flight restriction to work!

    Craftbukkit 1060
    Latest Dev version of DefaultCommands
  12. Offline


    still a great plugin, and getting better for every day;)

    i have a request you might wanna add;)

    zone pvp (easy markings, like setting the corners on cuboid and enable pvp only in that square, so we can fight in arenas, and arenas only. And you will automaticly get pvp flaged as you enter the arena)
  13. Offline


    hey vildaberper.
    love your plugin makes everything so easy.
    do you have any plans on adding some kind of zone protection.
  14. Offline


    Run into a NullPointer (Bukkit 1000 and latest
    2011-08-19 16:14:42 [SEVERE] Could not pass event ENTITY_DAMAGE to DefaultCommands
        at com.vildaberper.DefaultCommands.Listener.DCEntityListener.onEntityDamage(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.EntityArrow.m_(
        at net.minecraft.server.World.entityJoinedWorld(
        at net.minecraft.server.WorldServer.entityJoinedWorld(
        at net.minecraft.server.World.playerJoinedWorld(
        at net.minecraft.server.World.cleanUp(
        at net.minecraft.server.MinecraftServer.h(
    It made the server stop. I'll update to bukkit 1060 soon, maybe it'll fix ?
  15. Offline


    Thanks :D

    Do you have allow_flight in to false?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  16. Offline


    Of course I do, it wouldn't kick me for flying if I didn't have it set to false. Have you gotten this permission to work? I can't be the only one.... thanks for the reply tho.
  17. Offline


    haha i actually tried it after i replied, and it kicks me as well.
  18. Offline


    It seems to accept that the permission is true then it calls the permission again and defaults to false, making you get kicked from the server. I assume this permission / functionality is new and buggy. Any info from the developer would be helpful. I've got a multi-world server and want people to fly around to build pixelart but not fly around on our adventure worlds. This flying restriction permission is EXACTLY what I need.
  19. Offline


  20. Offline


    First: Where did the support for SkyLands dimension go? :confused: (/create [name] [normal/nether(/skylands)] <seed>)
    Second: Would it be possible to make a command, like /dcseed [world], which would show the seed of the inserted world name? :)
    Third: When "making own "combo-commands" " in the plugins\DefaultCommands\Commands.yml, it would be cool, if you could make some variables, like if you use things like these:
    dckill;dctell <everyone> &4!!!HACK!!!;dcban <self>:
    - hack
    (when a player use /dchack or /hack, they will be killed, tell everyone "!!!HACK!!!", and get banned) :p
  21. Offline


    It should still be there?

    Ill add /dcworldinfo (winfo from fCraft), which will show the seed (and other stuff). :)

    You can do that:
    dckill <player>;dcmessage * &4!!!!HACK!!!!;dcban <player>:
    - hack
    - dchack

    They will need the nodes 'dc.kill.self', 'dc.message.all', 'dc.ban'. They will be able to use /dcban though. xD
  22. Offline


    Do you plan te release a Recommended Build soon?

    Also, do you check your GitHub BugTracker?
  23. Offline


    Seeing as you have removed Permissions support in the latest dev build, a connector/bridge would be great. I don't like PEX, and I'm not planning on moving to Bukkit Permissions any time soon.

    However, as I've said multiple times, this is an awesome plugin. You do some great work @vildaberper.
  24. Offline


    Im having a little issue with another plugin (LogBlockQuestioner) and been pointed here/having a hunch its relating to DefaultCommands. Sayd plugin adds two commands, /yes and /no, but i get the error that these commands dont exist?

    Any idea what could be going on here (and if its even remotely possible to relate to DefaultCommands actually)
  25. Offline


    It does that because LogBLockQuestioner isnt registering /yes or /no. Disable unknown_command in DefaultCommands.yml. :)
  26. Offline


    Oh well i dont wanna disable unknown_command, removed the questioner part, thanks for clearing that up
  27. Offline


    When I have Default Commands installed no-OP players in my server can't pick up items or hurt mobs. I either have to give them OP or change op_permissions to false for them to be able to do anything.
  28. Offline


    I get a 'not in gzip format' error whenever I start the latest dev build, And now no one has permission to do anything(even if you have the *), heres the log

    Attached Files:

  29. Offline


    Give them<world>, or* for all worlds.
  30. Offline


    ok Fixed the gzip error however the perm error still remains

Share This Page