Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. I don't know if this is poste'd here, but i found a bug...

    When you type in-game the command /dccreative or /creative and then going to a tree, the game crashes
    when you try to delete the leaf's or just click on them...

    So i'm asking you, please fix this as soon as possible. Cause i'm using this creativity all the time, and i don't want to crash when i'm forgetting this bug.

    Thank you

    P.S.: I'm new to the forum.
  2. Offline


    every time i create a world with dccreate i get the same world. if i let the seed field empty or write somethign in it, it doesnt metter.
    e.g: /create worldbla NORMAL
    ... exploring
    /delworld worldbla
    stopping the server and deleting the worldbla folder
    starting the server
    /create worldbla NORMAL
    ... exploring and its exactly the same

    now i created a new world with singleplayer and put it on the server and got a totaly new one
    but after the first restart it seemed to change the seed back to the previous one, or its every restart a new seed, when i explore new chunks there are clearly visibly edges at the chunks.
  3. Offline


    when i type /undo my worldeit takes the command to should i ask the dev or could you try and make it override?

    maybe add the last location @ the /who command so i can tp to its location
  4. Offline


    how do i make it give kits for all the kits available in terms of permission format.

    is it just
    dc.kit.# ?

    or do i have to do it individually for each kit? like

  5. Offline


    if you have worldedit, why do u use the cuboid functions from dc ?

    you can rename the /undo to /undo1 or whatever (not /dcundo) in the commands.yml or just use dcundo
  6. Offline


    Sorry. I'm not very good at this. Should I add it in "permissions"? :) If not, where?

    I tested to add it in permissions (even if it might be wrong) and I still can't open doors & pick up stuff :O
  7. Offline


    ok thanks
  8. Offline


    Yup, a few people brought this to his attention, and he says he fixed it in the development version.
  9. Offline


    You must delete the world from DC with '/delworld <world> [remove/delete]', or the world will load with the saved config in Worlds/.
    So if you do '/delworld <world>', it will only delete the config file and unload the world.
    If you do 'delworld <world> remove', itll do the same, but also delete the world directory.

    # means self, other and all, so:
    'dc.kit.self.derp' would give the user permission to give him/herself the kit 'derp'. ('dc.kit.self.*')

    Do /dcundo or set another alias in Commands.yml.

    Yep, will add that (Worlds/<world>/Locations/<player>.data).
    Itll also teleport you to your last location in the target world when issueing /join. :)
  10. Offline


    ok thanks was just about to ask that to
  11. Offline


    ok, i didn't use the cmd, it was a mod, but i looked in the ftp and the config in worlds was deleted, but the world it self was still there, so i deleted it also and restarted the server.

    but i won't try it again, now we play on that world and every time we see a chunk that doesn't belong there we just cut it out and smooth the rest. we-brushes ftw :D
  12. Offline


    Is Dev Build compatible with Superperms?
  13. Offline


    It is supposed to be, yes. Check the Development Changelog in the original post; it is currently mentioned as the latest change.
  14. Offline


    with the kits.. is there anyway to put a delay timer on them??
  15. Offline


    Toggled creative mode in a world, every time a user tries to destroy a "leaf" block this error message happens:
    2011-08-14 00:07:12 [WARNING] Failed to handle packet: java.lang.NullPointerException
            at net.minecraft.server.ItemStack.a(
            at net.minecraft.server.InventoryPlayer.f(
            at net.minecraft.server.EntityHuman.v(
            at net.minecraft.server.EntityPlayer.v(
            at net.minecraft.server.EntityLiving.m_(
            at net.minecraft.server.EntityHuman.m_(
            at net.minecraft.server.EntityPlayer.a(
            at net.minecraft.server.NetServerHandler.a(
            at org.getspout.spout.SpoutNetServerHandler.a(
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(

    Craftbukkit version:
    Seems to be a confliction with Spout? (Using v1.0.1)
    It works fine when creative mode is off, however.

    As well, it's possible for a user to make a nether portal in a Creative world, go through it, and keep all of their items when teleporting even if separate inventories is checked in the creative world.
  16. Offline


    why did you remove permissions support at the dev build and why remove the prefix and suffix?
  17. Offline


    This is known and is fixed in the development version.
  18. Offline


    I encountered a problem with warps after deleting a world.
    after /delworld heaven remove and having a warp that i forgot about to that world the server i got the following error.
    2011-08-14 18:24:08 [SEVERE] Error occurred while enabling DefaultCommands v3.6.0 (Is it up to date?): null
        at com.vildaberper.DefaultCommands.Class.DCWarp.setLocation(
        at com.vildaberper.DefaultCommands.Class.DCWarp.<init>(
        at com.vildaberper.DefaultCommands.Misc.setWarp(
        at com.vildaberper.DefaultCommands.SaveLoad.loadWarps(
        at com.vildaberper.DefaultCommands.SaveLoad.loadAll(
        at com.vildaberper.DefaultCommands.DefaultCommands.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    the warp.yml file then did a kind of a reset with only 3 warp points. It after i removed the warps to heaven that DC accepted everything as normal.
    Normally you dont have warps to worlds you dont have :p .. but in case a similar situation appears in the future, perhaps the check in warps.yml only will read warps from existing worlds, if a warp world does not exist then ignore?
    no biggie .. just wanted to inform you ..
    Thanks a again for a freakin great plugin :) .. oh, and still no problems detected with the new permissions :D
  19. Offline


    I've looked in the files, but I'm not sure if there's a way to fix people getting kicked when using /fly with the feather, is that a bug that's caused by another plugin? or is there a file that lets you disable getting kicked when using /fly??
    to solve this, i had to allow flying on my server in #js :3
    Here's an example:
  20. Offline


    first of all im glad to say i LOVE your plugin, however is there a way to hide specific commands from specific people off the /help page? theres like 24 pages because of worldedit and worldguard that i don't want anyone else to see other than the admins.
  21. Offline


    Please make to i can teleport to another portal for for exelample: Portal1 to Portal2
  22. Offline


    Why????? nooooooo
    the bukkit-intern permissions aren't fully developed and not that good like permissions3
    i have many many old plugins that aren't under dev anymore and won't support the bukkit-intern permissions so i have to use permissions3
  23. Offline


    They should've made that known in the OP then, as it's not even stated in the issues of the github.

    Furthermore, i've been having weird errors where players become Notch in the development version whenever they teleport to home, through a portal, or if they "hover" when flying.
  24. Offline

    Don Redhorse

    if you use permissionsbukket, pex or bpermissions you normally also have a bridge with will emulate permission 2.x and 3.x


    I think if you use your alias function and change for example /dcwhatever to /whatever and generate an error you get back: /dcwhatever needs blabla... so it is not using the alias I created or did use to display the correct syntax.

    could this be change by this:

    Don Redhorse said:
    .. I hate it when I do a /myowncommand and get an error message /originalcommand does require a value…​
    Generally I think this is because the plugin didn't properly use the usage field; they put /originalcommand instead of /<command>. The latter is automatically replaced with the actual alias used.

    this is from the thread

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  25. Offline


    Vildaberper: Any chance you could implement PvP ocntrol per world?
    hmm .. or would that be the block-player-player-damage .. should get the correct effect ;) ... gonna try that one :p
  26. Offline


    the bridge is made to emulate p3 and use superperms, but couln't this be made the other way round to simulate the use of superperms and using p3 instead?

    i see ... converter for p2.7 and 3 are on the way

    but it would be nice to let the p3 support stay a little longer
  27. Offline


    I've had problems with people turning into Notch with the dev versions too. Also, the server console doesn't seem to show what's happening with individual players (speech, /give) when DC is loaded.

    I hope this is fixed quickly - I've had to stop using DC because of it. And I can't stand the inability to fly, let alone the unreasonable inconvenience of having to use the vanilla /give.
  28. Offline


    Note to myself .. that worked just splendid !!
  29. Offline


    how do you add a cooldown for the /kits?
  30. Offline


    Sorry if i sound like a noob but how do i set it so only op's can view what commands are available and not players without using other plugins

Share This Page