Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    Use /dcreset.

    Monster is actually a mob, not zombie, skeleton, creeper etc.

    Ill take a look at it today. :)

    There is another plugin for that.

    Thats why the commands start with dc, the others are just aliases. Edit Commands.yml.

    Are you serious? Read the OP.

    Use /dc load instead, DC saves on exit (and overwrites any changes made by you).

    When is what going to be ready?
  2. Offline


    Is there a way to remove certain features of the plugin? What I had in mind was the /give command because it doesn't interpret the items how I would like them too, like /give diamondshovel.
  3. Offline


    Add your aliases to Items.yml, it does support aliases. :)
  4. Offline


    The v3.6 or v3.5.1 or v4.0 ? The new version, the update. xD
  5. Offline


    Maybe tomorrow, but I might wait a bit and add some mroe features.
    The main thing is the new bukkit permissions, which has to be tested more before I can make the dev build an official release. :)
  6. Offline


    Vild, could you make '-1' an allowed item quantity? I enjoy having extremely large stacks with out a number.
  7. Offline


    @vildaberper - let me know if you need testing on the new bukkit permissions ..
  8. Offline


    Development build doesn't seem to like Permissions :\
  9. Offline


    Ill add it soon. :)

    It would be great of you could test it some more, I was in a hurry and I didnt get to test it properly.

    Nope, I dropped support for it since there is official permissions now.
    You can stay with the old version if you want to stick with Permissions. :)
  10. Offline


    Testing the dev-build:
    - The added support for the new permissionsbukkit seems to work very well, i have tried a number of combinations of dc nodes including * nodes. Though i havent tested all of the commands. Is there an updated list of permission nodes available?
    - With set to allow_flight=false and dc permission to fly > enable fly with /fly disconnects you from the server as flight is not allowed, i got the feeling that the fly command would suppress the setting and allow a player to fly .. correct?

    - when a command is not permitted such as warp, the chat feedback is:
    "you do not have permissions to do that
    [player] made [player] warp to [warp]"
    These two rows should perhaps be displayed as one row including the command that a player tried to perform?
    dc.warp.self example: "You dont have permission to warp in [world]"
    dc.warp.other example: "You dont have permission to warp other players in [world]"
    Q: do you plan to use the mchat api? so that your strings would use playername coloring etc?
  11. Offline


    Thank you for testing it! :D

    The nodes are the same, and the new ones are in the dev changelog. Basicly, if one works, everyone of the them works.
    I will add better support for this soon, there will be permissions to fly; 'dc.allowflight.<world>'.
    This means that allow_flight in should always be false.
    So in order to use /fly, the player must have 'dc.allowflight.<world>'-permission.

    I will change that to send only the string "not_permission" and not how to use the command aswell.
    It would require a lot more strings in Strings.yml, so I wont add it.

    What do you mean?
    DC supports coloring of the chat.
  12. Offline


    Hey. I downloaded this but no one the server can open doors & pickup blocks. :) Have I installed it wrong, or is this the permission issue? :O

    Edit: I wrote in my name in the permissions.yml and now it works. Is that the way to do it, or can i disable it to let everyone that joins get permission directly? :) My friend still cant open doors & such.
  13. Offline


    Add the node '*'. :)
  14. Offline


    Excellent :)
    Regarding coloring of the chat, the new permissionsbukkit doesnt have the 'info' part from what i know so i cant define the prefix as an example. I usually set the prefix depending on group membership .. how can that be done with DC chat?

    hmm .. just noticed you added support for HeroChat in dev build .. but that is not using permissionsbukkit .. will that work?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  15. Offline


    Not yet, but Ill add it. :)

  16. Offline


    Just downloaded the latest dev and tried the dc.allowflight .. updated to false ofcourse.
    with dc.* permissions i getkicked from the server as im not allowed to fly ...
    tested with /fly command to enable flying but wont help
    also tested to explicitly set dc.allowflight.*: true but didnt help
  17. Offline


    Whats the permission name which allows people to through portals but NOT make portals?
  18. Offline


    'dc.portal.<portal>', so it would be 'dc.portal.*'. :)
  19. Offline

    Don Redhorse

    any idea when you will implement seperate inventory for world pairs?

    eg. creative world and creative nether have ONE inventory and survival world and survival nether have an OTHER inventory.
  20. Offline

    Carlos Fuentes

    My DC files got messed up when my mom pulled the plug on my server computer (lol) and my kits.yml file was loooost.

    The new kits.yml file only has {} in it, and I forgot the syntax for making a kit. Can anyone give me an example of their kits.yml file?
  21. Offline


    Do '/dc reset kits' and then '/dc save', itll reset the file and show you the syntax. :)

    Not sure, but Ill implement it as soon as possible.
    Don Redhorse likes this.
  22. Offline

    Carlos Fuentes


    Now I'm having another problem. Now that my kits.yml file is all good, I try to start up the server, and on start-up the console gives me a severe error while DC is starting up. Once I stop the server, I see that the kits.yml file was once again wiped. What can I do to actually put kits.yml without DC deleting it?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  23. Offline


    default content in kits.yml is:
    - 268:0 1
    - 269:0 1
    - 270:0 1
    - 271:0 1
    either edit the file when the server is off .. or edit the file while server is running, save and then do /dc reload & /dc save .. hope that helps
  24. Offline


    Hey vildaberper,
    I am loving the new bukkitpermissions support, but can't for the life of me figure out how to add a superperms permission. I want a group to have access to all the commands without actually having to type out every single permission. Is there a way to do this yet, or do I have to set up a parent node for everything? Will you be adding already premade parent nodes for version 1000? Thanks.
  25. Offline


    So this node "*" means all?
    what does "#" mean then?

    hence " dc.portal.* " = All players can go through ANY portals made.
  26. Offline


    Add the node '*'.

    # = self, other, all
    dc.kill.self allows the player to kill himself.
    dc.kill.other allows the player to kill another player, but not himself.
    dc.kill.all allows the player to kill more than one player at a time.
  27. Offline


    Yeah that should have been obvious, all these permissions and permissionbridges get to be confusing. dc.* did the trick. I was also wondering if you were going to allow for DefaultCommands to work with Multiverse 2 in the future?
  28. Offline

    Don Redhorse

    looking forward to that.. I'm using an old version of a plugin which still works... will try to update to the newer version that could also probably wait till you get it integrated..
  29. Offline


    Sorry.. umm.. it doesn't work. this is part of my permission file.

        default: true
        - essentials.helpop
        - essentials.list
        - essentials.motd
        - essentials.rules
        - essentials.spawn
        - essentials.suicide
        - dc.portal.self
        inheritance: []
          prefix: '&e'
          build: true
          suffix: ''
    this was the error
    while scanning for the next token
    >found character '\t' that cannot start any token
    > in "<reader>", line 13, column 1:
    > -
  30. Offline

    Don Redhorse

    you have a TAB in that file... trust me...

Share This Page