Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    Someone else have a problem activating -'*'?
    i cant get it to work for any grps, just admins with - '*'

    using bukkit 803
    permission 2.7.4
    and defaultcommands 3.3.0
  2. Offline


    If you are on a seperate world than your default, you have to create another folder named 'your world here' and put a copy of users.yml and groups.yml in it. If this isn't the case, then i cant help, but i am using the same setup as you. You also have to edit the users.yml file and groups.yml file in Permissions\yourworldname. Again, that is only if you are playing on a seperate world. Hope i helped.
  3. Offline


    I have this exact same problem. Admins with '*' can use the dcweather command, but those with '*' cannot . Instead, they get "You do not have permission to do that" despite having the '*' node added to their group.

    Using bukkit 803
    Permission 2.7.4
    DefaultCommands 3.3.0
  4. Offline


    my commands.yml seems to be rewritten at every startup. i cant change any commands.
  5. Offline


    I've done exactly that... for some reason it worked fine on permissions 2.x , but not 3.x... All user and group files are the same for all worlds, and for the global users and global groups files. :/
    All permissions work except defaultcommands'..
  6. Offline

    Don Redhorse

    you can... just make sure the server is down when you make changes IIRC
  7. Offline


    All my player can do all commands..

    But i dont gave them permissions!!

    Pls help
  8. Offline


    could you please make your alias-system compatible with CommandHelper ?
    whenever i try to use one of the aliases from CommandHelper it just displays "unknown command"
    i write also to the dev of commandhelper in order to make these two plugins compatible to eachother

    look at your config in the "/plugins/defaultcommands/worlds/world/"
    if the op-permissions is true ... set it to false

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  9. Offline


    Dont work...
  10. Offline


  11. Offline


    Will be update for plugin on servers 1.6.6 ?
  12. Offline


    Yep, the only thing I need to update is /inventory and the permission stuff though. :)
  13. Offline

    Jared Ledvina

    My community and I are eagerly waiting for your 1.6.6 update. You plugin is the best.
  14. Offline


    I ran into a minor problem.
    When I do the /hide on myself, players without the "hide" permission see a "You don't have the permission to do that" .
  15. Offline


    the separate inventory dont seem to work in 1.6.6
    when i warp between worlds, it now brings all my items with me, back and forth.
    and that fucks up the survival world, as people tend to bring stuff home from creative world...
  16. Offline


    What version of Permissions do you have?

    Not updated to Minecraft 1.6.6 yet.
  17. Offline


    Version 2.7.4 .
  18. Offline


    Just a heads-up: The block_fire_spread has stopped working with the update to craftbukkit 818 (at least it has on my server, fires spread normally again despite it being set to 'true')
  19. Offline


    is there anyway currently to add(not create) and existing world? i cant seem to find the command for it

    EDIT: Nevermind i think i figured that out, but now i have another problem, it seems warps seem to warp up to 20 blocks away from the designated spot if you warp between worlds, this wouldnt be to bad of a problem if one of my worlds wasnt a sphere world(a huge map with giant floating spheres in it, its a cool mod look it up)
  20. Offline


    Any chance you could make it so that /dctime changes the time of the world you are currently in when you leave out [world]? Currently I'm not able to change the time in any of my worlds because the name of the world is more than one word. A simple /dctime when leaving out the world doesn't work, either.

    I also tried remapping the commands and using Essentials for both time and weather, but no matter how I remap the dctime and dcweather /time and /weather still appear as /dctime and /dcweather. This also conflicts with many other things such as /dcspawn's permissions. I cannot set permissions for other users to use /spawn because my world name has more than one word. Once again, I tried using Commands.yml so dcspawn wasn't /spawn, but it seems that Commands.yml does not work at all for most commands.
  21. Offline


    update today? :D
  22. Offline


    is there a way to get my old world files into a multiworld thing? like i started a new world file, but i want to go back and play on different worlds. Help please?

    nvm figured it out

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  23. Offline


    Update soon?
  24. Offline


    Just right click>open with>notepad I also suggest getting notepad++ it has syntax and a setting to make tab do 4 spaces instead of just a tab
  25. Offline


    Is their no kick or ban anymore? It's not listed at all on the original post.
  26. Offline


    I recommend mcbans, its a bit more extensive in these cases.
  27. Offline


    I have a Multiplay server and i have put Default Commands(v3.3.0) on the server. I also have permissions(v3.0 +mp) on there and when i put in permissions that a group can not use a Default Command command it still lets them to use the command. It won't let them use the Weather Plugin commands but it will let them use the god command and the give commands.
            system: default
            group: Admin
                prefix: ''
                suffix: ''
            Default: true
                prefix: ''
                suffix: ''
                build: true
                - ''
                - 'lwc.protect'
                - 'jail.usercmd.jailstatus'
                - 'pvptoggle.command.status'
                - 'pvptoggle.command.toggle'
                - 'tpp.mod.*'
                - 'tpp.jump.*'
                - 'tpp.request'
                - 'ecoCreature.Creature.*'
                - 'deathmessageplugin.sendmessagev '
                - 'deathmessageplugin.getmessage'
                - '-dc.god.all'
                - '-dc.give.all'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
  28. Offline


    Wait, so you don't want players to be able to use god, pvptoggle and give in the game? With permissions, you state which nodes you do want players in the group to be able to use. Here, you've set it so default players can use '/god', remove the
    - '-dc.god.all'
    line, reload permissions, and then they won't be able to.
  29. Offline


    I may sound like a noob, but I have a question! When I try to create worlds and warps, they won't save. I have tried /save-all and /save-on but they still won't save. I think the save commands are level saving ONLY. But is there a way to make them actually save? Or do I really have to put them in manually? Also, two warps was created and saved, but none else... Eh?
  30. Offline


    You'll want to change the node to disallow any usage of those commands:

    - '-dc.god.*'
    - '-dc.give.*'
    The .all simply means "everyone". eg /god all

Share This Page