Inactive [FUN] SpoutEssentials v3.9.2 [SPLASH SCREENS, GUI commands, Music, Capes, Sky, and more!] [1.2.3-R0]

Discussion in 'Inactive/Unsupported Plugins' started by skawke, Aug 7, 2011.

  1. Offline


    @rediem's Banner :)
    Version: v3.9.2
    Go here for download, commands, permission nodes, and more!

    (If you would like to get a small taste, join my server @, and press ~)

    Splash Screens:

    Uses Spout's various features for a whole ton of fun!
    • Notifies when people join
    • Notifies when people leave
    • Displays a notification when people join the server
    • Allows the playing of music, both to themselves AND serverwide
    • A simple 'poke' feature
    • and TONS more! (Full list @ bukkitdev page)
    SpoutEssentials includes optimizations for these plugins:
    Want to test out the features before using it? Join my server @

    I work quite hard to make the plugin, and I try to put everyone's requested feature into SpoutEssentials. Donate to help me buy food a better server :(:(!


    · @rediem for the banner :D:D:D:D:D:D
    · @tips48 for helping me with the poking feature (basic messaging)
    · @SwearWord from #bukkitdev for helping me with config stuff
    · #spout for helping me with SpoutCraftEnabledEvent
    · @Ninja Grinch for pointing out bugs in 2.7.2
    GameFAQsRolo, Kiste, Hopium and 8 others like this.
  2. Offline


    it doesn't make the folder :(
  3. Offline


    Version of Bukkit? And what?
  4. Offline



    the splashscreen won't work i've used a png file on a host immage

    and can you add the support for iconomy 6 like bose economy ???
  5. Offline


    Just so you know, reverting to 3.7.1 DID fix my problems. I'm not sure what happened with 3.7.4, but keep up the good work on the plugin! :)
  6. Offline


    @Slawke: Not really, i tryed a lot. What about just an update with a config line for ~ editing? What about in the next Version, this plugin is USELESS until the key is: ~, or 50% about the plugin :-P
  7. Offline


    I don't know what's happening to you guys.
    In my test server (CF #1340 / Spout #465 / SpoutCraft #601 and everything in SpouEssentials v3.7.4 is working but the splash screen.
  8. Offline


    you can edit the buttons in the gui?
  9. Offline


    Yes, I can.
    I've used strings in my language as an example:
  10. Offline


    It will be niceof you can change ur skin on your site
  11. Offline


    Version is released!
    you MUST use RB 1317+, or else it won't work!
  12. Offline


    Configurable GUI-hotkey would be really nice.
  13. Offline


    with RB 1317 i cant edit the gui buttons. But with Build #1340 and Spout #465 it works for me :D
  14. Offline


    Anyone else lost OGG sounds after the 3.7.4 update? I no longer get the welcome ogg or region music I had placed. Config files haven't changed...

    I reverted back to 3.7.1 and everything is up and running again. I'll guess I'll starting working on perhaps redoing my config files sometime.

    Fantastic pluggin!!! Truly deserving of its title :-D
  15. Offline


    Version of bukkit?
  16. Offline


    1317 (MC: 1.8.1)
  17. Offline


    Try using bukkit 1320.
  18. Offline


    I'm running 1317 and this plugin appears to do nothing.

    I tried playing an ogg file, but it simply prints the URL and doesn't play the song.
    Changing my cape shows no difference; it doesn't show me wearing one.
    Changing my title is the same. It says it's changed, but no difference.
    I don't see any of the welcome messages when I join.
    I can't access the GUI using '~'.

    I have enabled all of these things in the configs, but nothing happens.

    Just tried CB1340 and nothing.
    Also tried 3.7.4 and 3.7.1 and neither work.
    Is there a tutorial for setting this up?
    I checked out the FAQ, but it wasn't of much help.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  19. Offline


    I really hope you're using the SpoutCraft client.
  20. Offline


    I'm getting an error when trying to use commands with SpoutCraft. I'm using the Client and when I type /spe help I get this error in the server console:

    16:23:21 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'spe'
     in plugin SpoutEssentials v3.7.4.1
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at org.getspout.spout.SpoutNetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
            at me.skawke.spoutessentials.SpoutEssentialsCommandManager.onCommand(Spo
            at org.bukkit.command.PluginCommand.execute(
            ... 13 more
    I have Essentials but I didn't enable the plugins so it was just SpoutCraft and SpoutCraft Essentials running and still had this error.
  21. Offline


    Hmmm... This is the exact same as MY error!
  22. Offline


    Read the post next time. Use CB build 1317+

    Check if you have Spout. Then check if you're using build 1317+
  23. Offline


    I decided to try out the plugin today and could not get capes to persist through a server restart and skins to load at all. There were no errors in my testing.

    CB #1318
    Spout 449
    SpoutCraft 564

    My server automatically restarts every 8 hours and after a restart, capes no longer load. Using the cape command to reload the cape only lasts for that server session. Skins I could not get to work at all. I tried restarting the server, restarting the server with no plugins except Spout/SpoutEssentials/PermissionsBukkit, different links for the skins, and deleting the info in the configs to generate fresh data. I might give it a try again later after updating to the new RB #1337.
  24. Offline


    Do you like my avatar?
    i know this is off topic. xD
  25. Offline


    Try RB 1320, apparently there are some problems with certain RB's not reading config files properly.
  26. Offline


    You are correct. Running perfectly on RB #1337 now. Great plugin, thanks.
  27. Offline


    Yes to both. Just updated both and still no luck. 1337 still doesn't do it for me.
  28. The GUI doesn't work for me. I added all permissions to my group. All other commands work. But when I press the GUI-Button (~ or h both don't work) nothing happens. :(
    Bukkit: 1337
    PermissionsEX: 1.15
  29. Offline


    I have latest spout and essentials and 1317 bukkit. Yes for some reason, worldguard music regions dont work, they used to, now they dont, i deleted the cache and it wont re-download not, only the playonjoin music downloads. Also I am op and have bukkitperms. Latest

    Ok so i have made an entirly new server with 1317, and latest spout client. And latest essentials and spout plugin with latest world edit and guard. Made a region called music put my music in the config, all set up, and it wont even dl it or even play it. New everything, no errors on console, no worky. I know the link works because it plays on /spe playmusic link. So the issue is...idk what it is. I have all the essential plugins running, nothing else, so something is wrong. I am missing nothing, ive done this before.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  30. Offline


    Whenever my freind joins the server after I set up sounds for when he joins, and a texturepack, he gets this error, any help?
    03:26 PM [INFO] Twitch [/] logged in with entity id 1164 at ([world] -163.0625, 64.0, 881.21875)
    03:26 PM [INFO] Reading data
    03:26 PM [INFO] [Spout] Successfully authenticated Twitch's Spoutcraft client. Running client version:
    03:27 PM [SEVERE] Read timed out
    03:27 PM [SEVERE] at org.getspout.spout.packet.CustomPacket.a(
    03:27 PM [SEVERE] at net.minecraft.server.Packet.a(
    03:27 PM [SEVERE] at net.minecraft.server.NetworkManager.h(
    03:27 PM [SEVERE] at net.minecraft.server.NetworkManager.c(
    03:27 PM [SEVERE] at
    03:27 PM [SEVERE] Caused by: Read timed out
    03:27 PM [SEVERE] at Method)
    03:27 PM [SEVERE] at Source)
    03:27 PM [SEVERE] at Source)
    03:27 PM [SEVERE] at Source)
    03:27 PM [SEVERE] at Source)
    03:27 PM [SEVERE] at org.getspout.spoutapi.packet.PacketCacheHashUpdate.readData(
    03:27 PM [SEVERE] at org.getspout.spout.packet.CustomPacket.a(
    03:27 PM [SEVERE] ... 4 more
  31. Offline


    Did you enable it in modules.yml?

    Try using the latest Bukkit.

    Open a support ticket.

Share This Page