[FUN/MECH] BookWorm v1.14 - Read and write books[BukkitDev]

Discussion in 'Archived: Plugin Releases' started by nisovin, Jun 19, 2011.

  1. Offline


    Yeah that is pretty cool. Though we can't find a way to prevent a stranger from copying someone elses book or making a copy of it.
  2. Offline


    Set bookworm.copy.others to false.
  3. Offline


    Ahh are you using the new permissions system? I noticed a lot of plugins must add plugin.*: false then permissions since a lot them now assume true unless you state false.
  4. Offline


    This plugin supports both. What matters is whether you are using the new permission system or not. I assumed you are, since you list "true" values in your permissions.
  5. Offline


    Think I know what it is now.. Seams like superbridge causing issues.

    bookworm.*: false
    bookworm.write.own: true
    bookworm.copy.own: true
    bookworm.destroy.own: true
    bookworm.remove.own: true
    bookworm.destroy.others: true

    I assume bookworm.destroy.others: true
    Lets me break other peoples bookshelfs correct? I think I found out that it's not reading my permissions at all but using the default settings hehe.
  6. Offline


    I was wondering if somehow you could make it where you could sell books using iConomy? or any economy plugin really..
  7. Offline


    Epic plugin but something goes wrong and every time I try to use any of the Bookworm commands I get a message saying : An internal error occurred while attempting to perform this command.
    Please do you have any idea of what is the reason of this?? Also in my server I don't use permissions, iConomy, e.t.c. If this works it would be awesome!!
  8. Offline


    What is the error on the console?
  9. i've got a serveur restart when the first time a player read a book (bukkit 1060 / spout 0.2):

    i think is because of this :" Notification titles can not be greater than 26 chars + 26 colors" but i don't no where is the notification line in the .yml
  10. Offline


    Set book-info-achievement to false. I'll fix the bug in the next version.
  11. Offline


    ok i just updated to th1.6.1 from 1.5 and i just get this every time i select a book in my quickbar or try to use any bookworm command. "16:02:50 [INFO] Failed to load book (file not found): 3"

    i cant write, or even see the bookworm help any more. i deleted all my configs before installing the new version. i am using the server plugin for spout but not the launcher (i have tried uninstalling that too but the result was the same). any ideas? i am on 1060, with and without the latest spout server plugin. if there is any other info you need just let me know.

    edit - sorry i am a noob. i was holding a book i previously made with bookworm. i guess after deleting the configs it lost track of the book i had in my inventory and that was causing the problem. i threw out that one and made a new one and its all good now. warning to anyone else: old bookworm books do not work after deleting your cfg and updating the plugin...my bookshelf seems to be unaffected. it was just the one i had in my inventory. thanks for this awesome plugin <3
  12. Offline

    Celtic Minstrel

    You probably shouldn't've deleted all your configs, then. :p Normally config files are supposed to persist across upgrades; you shouldn't just delete them unless there's a problem.
  13. Offline


    Not lettin me write books for some reason, and im op on my server.
  14. Offline


    Much like what fonkfader is saying, I'm getting the error in console, at net.minecraft.server.Packet102WindowClick.a(SourceFile:28).

    Once this is fixed, our server would LOVE this plugin! Thank you for your hard work.
  15. Offline


    this is true, but occasionally i have run into trouble trying to keep configs when the plugin adds features to them or changes them so i tend to shoot for 'clean' installs just in case :) i am just running this test server on my pc right now so its not like i wiped out a bunch of peoples novels or journals or anything :p
  16. Offline


    Just do the same thing I told him to do.
  17. Offline

    Celtic Minstrel

    If you really want to go for clean installs, I would suggest that you do it a different way. Instead of deleting old configs, move them to a safe place; then, once all your plugins have generated a new, default config, you can copy any settings you want to retain from the old configs before you delete them.

    Well, fair enough.
  18. Offline


    I was reading through the posts, and I just had a quick question before I install this plugins for my players to use.

    If I were to uninstall the plugin at some point -- for whatever reason -- would this have any game breaking effects? I assume it would not be an issue, and players would be left with useless books with durability values assigned to them?

    I only ask because it's very important to me that plugins can be installed and uninstalled easily in case something were to break.
  19. Offline

    Celtic Minstrel

    Pretty much. They'd even get the contents of their books back if you reinstalled later without deleting the old config files.
  20. Offline


    Alright, great :) Thanks for the reply and help!

    Also, one more question. How much ram should I have dedicated to BookWorm, per player, potentially? Is it a relatively light weight plugin? Or does it require more resources than average as far as plugins go?
  21. Two bugs I've encountered:

    Dropping a book and picking it back up again (how I gave someone a book) retained the book reference, but rendered it unreadable until I logged out and back in again.

    If I pick up a specific book with a stack of generic books in the inventory, the book still gets added to the stack of generic books and the generic books become a stack of copies of the book I picked up.
  22. Offline


    Neither of those things should be happening. What CraftBukkit version are you running? Do you have any plugins that might be interfering? Are you using Spout? Have you changed the config at all?
  23. I'm using the latest builds of Craftbukkit and Spout. The plugins I'm using are Autosave, Biomesound, Bookworm, Cenotaph, JukeBukkit, Lockette, mcMMO, Permissions, Spout, Tradecraft, and Transporter. All of which I've updated to the latest available versions today.
  24. Offline


    ill try to verify this tonight on my test setup and report back.
  25. Offline


    I dont know why but none of my default users can pick a book from bookshelf (they can only read from bookshelves). What should i do?;/ For sure added nodes to permissions for default group.

    Also wanted to ask if that shape of book is possible Line after line (and i wanted to edit it in notepad xD...)
    -----------------------------Line 1
    -----------------------------Line 2
    -----------------------------Line 3 etc etc...
    I know thats possible ingame, but i wanted to write rules and useful commands there :p...
  26. Offline

    Celtic Minstrel

    If I recall correctly, a double colon is a line break, so just separate your lines with double colons.
  27. Offline


    Thanks man :) , i was confused a bit and had no idea what to do :p
  28. Offline


    Well that was odd, tried to post and bukkit went down. xD Anyway... I think this would be a neat idea since you have now added a spout version. I don't know how possible it is but it would be very nice. No the font isn't part of the idea, it's just awesome and my permanent default font.
    I hope you enjoyed the example. I loaded up my snow world as it's the least laggy with my browser open. Needed the window for size reference.
  29. Offline


    Does not work with 1060 please make it work!
    2011-08-20 17:24:35 [SEVERE] Error occurred while enabling BookWorm v1.6.1 (Is it up to date?): tried to access method com.nisovin.bookworm.PermissionManager.<init>()V from class com.nisovin.bookworm.BookWorm java.lang.IllegalAccessError: tried to access method com.nisovin.bookworm.PermissionManager.<init>()V from class com.nisovin.bookworm.BookWorm at com.nisovin.bookworm.BookWorm.onEnable(BookWorm.java:110) at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126) at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:885) at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278) at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:178) at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:161) at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:452) at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:281) at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129) at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:344) at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:489) at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:468) at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363) at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Running Craftbukkit 1060 with Spout(up to date)
  30. Offline


    Has been working fine on my server.

Share This Page