[FUN/MECH] BookWorm v1.14 - Read and write books[BukkitDev]

Discussion in 'Archived: Plugin Releases' started by nisovin, Jun 19, 2011.

  1. Offline


    Can you add ability to create infinite books stacks? That would be awesomely helpful in creating books with rules or server tutorials :).
  2. Offline


    If you were to move a world to another control panel (TCADMIN --> MyMcAdmin) by downloading it from the panel and uploading it to the new panel would it save the books in the bookshelves? And the stuff in the books?
  3. Offline


    As long as the name of the world is the same and you move the plugins too i don't see why not. Its just xyz coordinates in a text file.
  4. Offline


    Will this be updating to 953? It is an amazing plugin and makes great use for quests!
  5. Offline


    I'm using 953, no issues here.
  6. Offline


    The "special 1.7 version" linked in the first post should work. I haven't tested it though. I'll get an official tested version out once the RB is released.
  7. Offline


    Sorry not quite sure how the -replace command works. For example if I had the following entries:
    "/w This is my first book."
    "/w I hope you will enroy it!"
    Clearly I have misspelled the word 'enjoy' and so I could use the -erase command as follows:
    "/w -erase enroy"
    But then the problem is I can't just throw in the correctly spelled work between will and it and I will be stuck with:
    "This is my first book. I hope you will<space><where 'enroy' used to be><space>it!"
    This is messy and I want to avoid having two spaces between words but I don't understand how the -replace command is operated. Do you type the string you want to replace and what to replace it with? If so how does the console distinguish between the two? Thank you for any clarification.
  8. Offline


    It separates it on the arrow, as can be seen in the example and in the in-game help info.

    /write -replace enroy -> enjoy
  9. Offline


    i love this plugin. i am setting up my first bukkit test server to learn my way around and i am finding tons of uses for this (its an rpg setup). its perfect for me and my buddies and i have a feeling it will be heavily used.

    one thing i would love to see in this is the ability for a book to enter a console command upon being read from the players hand (not a bookshelf though). like if you use a specific title (like 'scroll' or 'magic tome' or whatever) it would enter the contents of the book into the console (also having an option to have the book consumed when used or be re-useable, maybe based on what title is used). this could make for books that did anything from /give %player 354 1, to multiverse teleports, to permiconomy transactions (like buying permission to use magic carpet or blink plugins)...they could be sold in shops or placed as rewards...people (especially admins) could use re-useable ones to quickly use common commands etc.

    anyway, thanks for the great plugin.
  10. Offline


    @nisovin Thanks very much! Didn't notice the arrow. This plugin is awesome though! It runs really smoothly and it very handy! Maybe in a future update you could incorporate an import command to import a text file much like ShelfSpeak, that'd be very useful... Good luck with the developing!

    **Edit: I realize now that your plugin exports the documents to an external .txt anyways and so I'm assuming I can just edit that for simplicity sake. Should have figured you'd be one step ahead :D**
  11. Offline


    There seems to be some kind of incompatability with worldguard. When inside a protected zone that allows use of objects you can read from a shelf but cannot take a book. Any idea if this is fixable or is there something other then use i have to allow in worldguard?
  12. Offline


    "check-worldguard: If this is true, the plugin will only allow a player to place a book in a bookshelf if they have build rights in that location."
    Taken right from the instructions on the plugin page. Learn to read before posting questions. Open the folder for BookWorm in your plugins folder and edit the config file. Go down to the bottom of the file and change 'check-worldguard:' to false. Should work to my knowledge.
  13. Offline

    Celtic Minstrel

    This looks like a nice plugin, and it's good how you've made most of the actions not require commands, but I'd like to elminate the basic /write command as well. Perhaps have all chat be funnelled into a book if a named one is selected.

    Also, your opening post claims that books are unstackable. I've heard that Minecraft allows items with different data values to be stacked since about 1.5, unless it knows that the item normally distinguishes based on data values, and that was apparently causing problems in the creaturebox plugin. So, if you managed to make books unstackable and that feature still works, and you didn't use BukkitContrib for it, I'm curious how you managed it.

    This. The chest GUI might be nice, but even just right-clicking to see a list of books on the shelf or something like that would be fine. I'm not sure how you'd select which book to copy without a chest GUI, though...
  14. Offline


    Ok i should of mentioned that it is already set to false. The problem is exlusively with COPYING a book. everything else works fine. i have tested it. They can read books. place books. etc. However copying a book from my bookshelf inside of a worldguard region is the problem as far as i can tell its set up properly for both plugins.
  15. Offline

    Celtic Minstrel

    Found a bug... when you use an interactable block such as a chest while holding a book, you read the book. Not sure how easy it would be to fix either since other plugins can make blocks interactable that normally aren't (signs being a common one).

    I'm still rather bewildered about the stacking. I dunno if it's something you did or just a strange quirk of Minecraft, but I had a regular book and two copies of a BookWorm book. Trying to stack the normal book onto the BookWorm book worked, and when unstacked one was still a BookWorm book and the other was still empty... yet when I stacked the two BookWorm books, separating them still retained their non-emptiness.
  16. Offline


    Okay, but you have all the permissions set though? Because there is a specific permission to allow others to copy their own book and another to copy another person's book. Did you look at all the permissions?
  17. Offline


    Really nice plug-in, used it because signs are too small, and documentation plugins are too 'virtual', also all my users can share text now, without the use of signs. Well done!

    And I got an idea for copying books:
    You put a sample book in a dispenser, and some paper or empty books, then books will be printed on redstone input.
  18. Offline


    One word: Epic.

    I've been waiting forever for a book plugin, and this by FAR exceeds my expectations! :D

    -The commands are simple and easy to use.
    -More to it than just typing text. You can create titles and make paragraphs.
    -Extremely fun to use. (Most important)

    -If you have any there's a problem.

    Currently I'm making a journal, (acting like I'm in SSP,) explaining everything from waking up on the island to discovering pistons. (That's a LOT of writing. :)

    I can't even describe how awesome this plugin is. Thanks for making it!

    P.S. - Make moar plugins this awesome!:D
    P.S.S - Unset's idea of making a dispenser a printing press is something to consider. :D (Read post above this one.)
  19. Offline


    Yeah everything was set up perfectly. More testing revealed it was not anything to do with worldguard. But the chunk. Once i moved out of that 16x16 area. it worked flawlessly. Weird... My bad on blaming worldguard. However its kinda odd. Any reason why it dose not work in the spawn chunk?
  20. Offline


    I originally had it so you could only read by clicking in air, but that ended up being confusing. I guess I could ignore right clicks on containers. As for the stacking glitches, it has to do with the fact that your client thinks it stacked, but the server thinks it didn't. In the end, the server wins out, and attempting to do anything with the stacked items will unstack them, but it does cause funny glitches.

    Also, there's a boolean in the Item class that tells the server to stack items by data value rather than by item type. That's the flag I'm setting to prevent stacking.

    This is true of many plugins. The spawn protection prevents any information from being passed to a plugin, so there's no way to react there. If you want to have stuff in the spawn area, remove the spawn protection from the server config and just add a worldguard zone.
  21. Offline

    Celtic Minstrel

    Since right-clicking on containers and workbenches tends to bring up a window that hides the book anyway, I think that would be a good idea.
  22. Offline


    books eat each other so if you give someone a book and they have a book in there inv. then the book you gave him is becomes the same book in his inv PLEASE FIX
  23. Offline


    Make sure you're using the correct version. If you're on 1.7, use the 1.7 version.
  24. Offline

    Celtic Minstrel

    Wouldn't books not stack at all if he was using the wrong version?
  25. Offline


    Hi, I'll bet this question is answered somewhere, and I'm just overlooking something, but I'll ask because I haven't found it.

    I've added the permissions to the groups, so users should be able to write books. However, I'm an OP, so shouldn't even need permission to write books, yet I cannot. I do the /w command, and it tells me to fill in the title. I do /w Test and it says that I don't have permission to write in the book.

    I have no idea what that problem would be, to be honest. How do I fix it, if you know what's wrong?
  26. Offline


    It sounds like your permissions aren't set up correctly. If you have Permissions, being an op won't give you everything, you'll need the permission node.
  27. Offline


    i hate this plugin now ever since i updated the books stack and i just writ a huge book and then it got droped and when i picked it u it turn into the other book and stacked. plz fix this
  28. Offline

    Celtic Minstrel

    You might be able to get it back with a /give command if you know the book's ID. I know it won't work with General until I update to 3.5, though, so no guarantees.
  29. Offline


    One thing goes wrong and you suddenly hate the plugin? How about you just read the first post and notice that there's a new 1.7 version? Or read the thread and notice that people have already posted this problem, and I've responded. Before asking for fixes, maybe you should check if there's already a fix first.
  30. Offline


    Im sorry:(

Share This Page