Inactive [FUN/ECON/DEV] uQuest v1.50 - Overly customizable quest system [793 - 602]

Discussion in 'Inactive/Unsupported Plugins' started by Hawox, Mar 4, 2011.

  1. Offline


    As most of you can guess I have not worked on this plugin in a long time. I'm working full time at a grocery store as well as going to college. I literally have no time for sleep let alone Minecraft. Recently someone has contacted me saying they are working on my plugin. I appreciate his work and effort while I am away. This is a link to his topic. His download can be found at
    uQuest - Overly customizable quest system!
    German Questlist 5/16/11
    Coming Soon!
    Gui Questmaker (Heres a beta build!)
    Upload/download area for quests!
    mcMMO extension!

    Laxlux - New German quest list maintainer
    HiMyNameIsAJ - Creating a uQuest website
    Looking for:
    • Someone to make a nice looking website for uquest (Not my cup of java).
    • Someone to add MySql support.
    • Plugin attachment devs!
    • Someone with ideas on different quest types!
    • People to write some random quests to be thrown in the defaults!

    -----------------------Plugin summery below this point-----------------------
    ~Comes preloaded with 53 quests!~

    Support for: (You don't NEED any of these for the plugin to work.)
    Permissions (but not needed!)
      -"uQuest.CanQuest.*" - Allows all these sub permissions
      -"uQuest.CanReloadQuests" - Allows the use of /reloadquests
      -"uQuest.CanReloadQuestConfig" - Allows the use of /reloadquestconfig
     iConomy (but not needed!)
     BOSEconomy (Again, not needed!)
     Essentials! (Again, not needed!)
    Alright here goes, theres a lot to cover so I may miss something on this first go threw! Want a better way to get money into your server economy that selling items to the server or random lottery's? Do you like QUESTS?!?! Do you want your users to compete to see who is a better quester? Then uQuest might be for you!

    uQuest offers your users a simple way to quest! No need to walk miles and miles to a random NPC or click on some block at spawn. All they need to do is type '/uquest give' and uQuest will give them a random quest from it's database! A yml file is provided where you type out each quest for your users. That's right. YOU can decide how many quests there are, what they are, and how you want your users to do them (creating and editing this file are explained on the wiki). You can broadcast every x quests someone finishes to the server as well as give out rewards for x amount of quests. I'll leave the rest for the features section, just thought I'd get you hooked with that :3 If you grab the .zip (which you need to if you want to store your users in a SQLite database!) I have included 53 quests inside!

    All of that not enough? Well theres an API! Other plugin authors can use this as a base for their own plugins!

    Here's a quick screenshot of what the text looks like:

    (I may miss a few, there's quite a bit)

    ~Quest Types~
    All of these can have specific locations set to them! (Can only do in this area etc)
    (More to come I promise!!)

    (More to come I promise!!)

    ~Watch out~
    With great power (of customization)... Come's great responsibility.... There is a lot that can go wrong if you don't pay attention when your changing files. Thankfully, I've tried to have the plugin spew out as many warnings as it could on the servers start. Always give it a check to make sure the plugin loaded all of your work!!!

    ~Plugin Attachments~
    (These plugins add new features to the basic uQuest system)
    Just started this as an example of what people can do. All it currently has is /qadmin givequest
    OP's and people with the permissions (not required for this either) node 'uQuest.MoreModCommands' can use it.
    Simply shows someones progress on a quest everytime they do something for it. IE. I punch a log as part of my quest (grey text)Log Punches 7/10.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Support for uQuest levels
    Completes quests automagicly! Works with the same methods as showtracker so it has the same flaws. There is this weird bug when running both at the same time that spams some weird extra text. Try to ignore it for now.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Unknown status on working with quest levels. | Odd text bug with showtracker/this mix.

    ~Plugins using the API~
    (These plugins use the uQuest API to shape their own plugin)

    Since people don't read the above, I'll post this again here so I don't have to write the reply back to this anymore.
  2. Offline


    The best plugin I could ever have hoped for. So glad I found it. Can't wait for more quest types!
  3. Offline


    Can you add an option so quests can't be repeated?
  4. Offline


    Gah, the tread is getting to the lenght where people dont' read the whole thing and ask the same questions :< Not yet. I will add another plugin, using this as a basis, for that once I get quests reformated. However I put it on hold because I was told this:

    Since I'm shooting for making this open ended, that takes away support from a large group of people >: I'm trying to figure something out.

    EDIT: Well apparently THOSE char's are supported but wide char's may not be... Although if the current system does not support wide char's theres no reason it would be a problem to convert over. I'm off to get some work done on this. I have a busy day and weekend so I may not finish this until Monday >:
  5. Everytime I use any accent in a YML file (between single quotes), the plugin crashes :s It's working fine on txt or cfg files.
    Like so :
    - 'Ramenez moi du blé'
    I experienced this in the Essentials config file (especialy for the motd) and much more other plugins that i tried to translate in the yml files.

    Take your time to relase some badass new functionalities :D
  6. Offline


    That's your editors fault. Are you using the same text editor for both files?
  7. Offline


    Are there any plugins that you know are not compatible with this?
  8. Offline


    umm the hole thing.... i typed /uquest /quest /u and i get an internal error in game and thats it nothing in consol
    java 6, CB#544, permissons, ubunto 10_04 x84-64 (server)
  9. Offline


     /* Quests:
     *    #:
     *      Name
     *      Start Info
     *      Finish Info
     *      Rewards
     *          money -
     *          item -
     *          item -
     *          etc~
     *      Objectives
     *          gather
     *            display name
     *            item id
     *            amount
     *            amount to take away
     *            location
     *                where at
     *                  x
     *                  y
     *                  z
     *                give range
     *                  x
     *                  y
     *                  z
     *          kill
     *            display name
     *            monster id name
     *            amount
     *            location
     *                where at
     *                  x
     *                  y
     *                  z
     *                give range
     *                  x
     *                  y
     *                  z
     *          etc!
  10. Offline


    This plugin is great, thank you!

    Now for my suggestion.. Keep up the good work!
  11. Offline


    Thanks! Posts like that make me smile and actually keep the work up! xD <3
  12. Offline


    I get the following error during my startup.

    [SEVERE] [Hawox's uQuest] iConomy is not loaded. Turning iConomy support off.

    This happens AFTER the following displays
    [INFO] [Hawox's uQuest] Loaded with Flatfile!
    [INFO] Hawox's uQuest v0.974 enabled!

    This makes no sense since iConomy works for all other plugins.
  13. Yep, Notepad++, always.
    I'm using UTF-8 Encoding type, is it right ?
  14. Offline


    @dslip I can't help with that little of information. iCon worked fine for me. I don't know.

    @Arno00 I think so. Was busy all day today so i didn't get any work done. I hope to finish it up by tomorrow but I'm shooting for Monday. Hopefully a GUI Quest Maker by Tuesday.
  15. Offline


    i'm using iConomy. when i complete a quest it says: you have been rewarded with (for example) 1000 coins!
    your new balance is 30.0 coins <--- ?
    i'm using build 531
  16. Offline


    That's very odd. I'll look into it tomorrow. Heading to bed for now. Too late at night to get anything done. >:
  17. Offline


    great work thats a good plugin but
    i have the same problem like jamiro24. i get no money when the quests ends.
    build 556
  18. Offline


    Hawox: how about a go to location quest type? Keep up the good work ;)
  19. Offline


    thank you for this godlike plugin :p
  20. Offline


  21. Offline


    So if I'm running iConomy with MySQL, does this mean I cannot link this plugin to iConomy?
  22. Offline


    Odd. Location I am adding for each quest objective. Each quest can have more than one objective when I am done with the update. Sadly I cant fix anything until then. I did a huge code over-hull (API did not change MUCH thankfully) and nothings the same. I can't get a sample build out until I fix quest loading. The new system is in place but I have having issues trying to load a class with Yaml. I'm doing my best. I tried to get it out by today >: Hope to have it out soon...
  23. Offline


    I cant wait to use this addon..... Im going to have so much fun with this haha.

    A request though
    Make it so you can do a pvp kill quest. We use arenas in our server so it would be nice to give rewards for pvp. If it would be posable (idk how) make it so they its harder to cheat the pvp. Maybe so that the player has to take some sort of damage when in the fight.
  24. Offline


    Been trying for awhile now and cant get this to work. /uquest simply gives me a messaging saying type /uquest for detailed quest information or something along those lines.
  25. Offline


    I currently can't help as my above post states >: I'm really sorry. I'm getting frustrated to all hell trying to update this. Not working the way I want it to... I hope that it's amazing when it's finished though. I'm trying my best.

    EDIT: Here's a sneak peak of what I'm working on. Quest's will look something like this when I am done. I still have more features to add once I get it to cast correctly.

      Finish_Info: The Finish Info
      Name: The Name
      Start_Info: The Start Info
      objectives: {}
      rewards: {Money: '512'}
      Finish_Info: The Finish Info
      Name: The Name
      Start_Info: The Start Info
      objectives: {}
        Money: '512'
        item: {Item_ID: '17', Amount: '10', Durability: '0'}
  26. How about the quest scaling ? My server's member are begging me to add quest scaling (becaseu people reached the 200 quests cap, aka lvl 1), but i can't do anything x)
  27. Offline


    I know. That's being changed completely when I get this updated. It will be fixed in a few updates.

    Near sleep an idea ticked in my head. I've fixed most of the problems. A few more touch ups and I should have quests being loaded in again. Then I need to bug fix away and I'll get an update out! Sorry it took so long. I had a busy weekend and I've only had a few hours a day to work on this.
  28. Offline


    Any idea on why it keeps giving me the same quest over and over? The Quest_0 default one that came with the installation. I also have iconomy set to true and it gives me 0 iconomy even though the quest is set to 20.

    I'm using the default files.

    Addon list, just add in uquest at the bottom.
  29. Offline


    It's a problem with your quest file. Can you post it?
  30. Offline


    I am getting the same issue. I have tried setting the quest file to only have 5 quests and it still gives me the gather wood quest. Any help here would be great.

    Current quest file:

    Quest_0=Get Wood:gather:Go gather me a few planks please!:Thank you very much!:5:40:40:20:Planks:0:0
    Quest_1=Rocky:gather:Go gather me alot of cobblestone!:That was easy enough!:4:150:150:150:Cobblestone:0:0
    Quest_2=GetRedstone:gather:Please gather me a bunch of redstone!:Its electric!:331:25:25:1000:Redstone:0:0
    Quest_3=DoorThief:gather:dayls stole my doors! Craft me replacements!:Can you hold the door open please?:324:1:1:15:Wooden Door:0:0
    Quest_4=RichMan:gather:Please gather me some shiny diamonds!:Now I have the diamonds!:264:5:5:10000:Diamond:0:0
    Quest_5=Boom:gather:Get me lots of gunpowder! Be careful though!:Wow, Thanks!:289:10:10:3000:Gunpowder:0:0
    Current Config File:

    questRewards=87,Netherrack Blocks,10~88,Soul Sand Blocks,10~89,Glowstone Blocks,10~18,Leaf Blocks,10~344,Eggs,10~348,Glowstone Dust,10
  31. Offline


    i have the same problem with my server and my server is also hosted by multiplay but i think its a problem on the hosting side not with the mod, there a bit slow to add the correct config files and not on top of coompatability problems just yet, hope they will be soon, there are serveral mods still missing files or not working, also i noticed the mission says go get me some wood but the config says go get me some planks which seems weird, also were do you set the iconomy coin reward becuase i get 0 for the same mission over and over.

    "computer repairs made easy"

    i think that the hosting company has put the config file in wrong because when i type /q amount it says only one quest is loaded, ill raise a support ticket with them

    "computer repairs made easy"

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016

Share This Page