[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Hey there! I have this error when I attempt to make my guard.
    6:11:07 [WARNING] Task of 'Citizens' generated an exception
    ava.lang.UnsupportedOperationException: SuperPerms no group permissions.
    at net.milkbowl.vault.permission.plugins.Permission_SuperPerms.getPlayer
    at net.milkbowl.vault.permission.Permission.getPlayerGroups(Permission.j
    at net.citizensnpcs.permissions.PermissionManager.getGroups(PermissionMa
    at net.citizensnpcs.guards.flags.FlagSorter$6.apply(FlagSorter.java:99)
    at net.citizensnpcs.guards.flags.FlagSorter$6.apply(FlagSorter.java:76)
    at com.google.common.collect.Iterators$7.computeNext(Iterators.java:645)
    at com.google.common.collect.AbstractIterator.tryToComputeNext(AbstractI
    at com.google.common.collect.AbstractIterator.hasNext(AbstractIterator.j
    at net.citizensnpcs.guards.flags.FlagSorter.getPossible(FlagSorter.java:
    at net.citizensnpcs.guards.flags.FlagList.process(FlagList.java:33)
    at net.citizensnpcs.guards.flags.FlagList.processEntities(FlagList.java:
    at net.citizensnpcs.guards.Targeter.findTarget(Targeter.java:14)
    at net.citizensnpcs.guards.types.Bouncer.findTarget(Bouncer.java:24)
    at net.citizensnpcs.guards.types.Bouncer.updateStatus(Bouncer.java:64)
    at net.citizensnpcs.guards.Guard.updateStatus(Guard.java:135)
    at net.citizensnpcs.guards.GuardTask.run(GuardTask.java:23)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:533)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

    Please help thanks! I cannot make my guard attack anything I have tried enabling disabling economy and have vault in the server
  3. Offline


  4. Offline


  5. Offline


    every time i stop my server and start it agian the npc's are gone!?
  6. Offline

    Jeff Avery

    I'm having similar issue in that half of the room the armour (AND sword) work and the other half they do not. By not work I mean I am able to give it to the NPC but it does not show up even after I log off/on. If I try to give the armour to the NPC again it lets me know he/she already has that particular armour part....strange.

    Thank in advance for any suggestions.
  7. Offline


    I have a few suggestions that I am sure can be implimented into Citzens very easily. so here goes...

    1. Character Skins based on Citizen Group
    - I think it would be awesome if we could use skins downloaded from places like minecraftskins.com or skins we made ourselves on our citizens, but I think it should be done so that the skin on the citizen is randomly selected from its group folder. For example if I have the skins 1, 2 and 3 inside the citizen skin folder when I /npc create citizen it will select one of them skins randomly and when I /toggle guard on that citizen it then changes the skin to skins in the guard folder and when I /guard bouncer it chooses a skin in the bouncer folder. I also think that it should ignore names like Notch and Conan and use the skins that usually come with those names.

    2. Citizen Homes/Bed
    - Owner should be able to designate a citizens home or bed and the citizen will travel between its shop and home based on game time. Day time citizen is in the shop and night time it is in the home sleeping.

    3. Citizens port to Owner
    - A Citizens should be able to port to its owner if the owner owns a wizard.

    What do you guys think about these ideas???
  8. Offline


    iv instaled, carnt create any npcs

    i just get told to report this error

    error java.lang.NullPointerException: null
  9. Offline


    Every time I update citizens all my npc's are gone.
    Does anyone know why this is? I still have the npc_profiles in the citizens folder under plugins :/

    Important Edit: I fixed my own problem by downloading a plugin called Vault,
    now all the npc's are back and working normally :3
  10. Offline



    Great Plugin!!!
    But I saw on the Wiki that you can make a certain mob type like a Creeper
    And I tried some commands because it isn't explained very well on the wiki plzz give me the command to spawn an
    NPC Creeper :)
  11. Offline


    As fullwall mentioned, try the latest build. I'm just a recent user of Citizens so I've never noticed the theft issue even after trying to reproduce it. I can have an item show up in my inventory but is really just a client side glitch as doing anything with the item will make it vanish and the NPC never actually loses it.
  12. Offline


    I'll try the latest but I thought I had that one already. I'll let U know if the issue still happens. Would I need to update just the trader.jar or the citizens.jar as well?
  13. Offline


    kitty8 - update both since the latest build contains some other fixes as well.
  14. Offline


    so far nothing has been stolen and the equip durability glitch is fine now. Thanx
  15. Offline


    Getting this with 1.2 build 65 (latest) and CB build 2222 (latest RB):

    20:35:01 [SEVERE] Could not pass event PlayerQuitEvent to Citizens
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:304)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:460)
            at net.minecraft.server.ServerConfigurationManager.disconnect(ServerConfigurationManager.java:179)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:698)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:234)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113)
            at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:567)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.util.ConcurrentModificationException
            at java.util.HashMap$HashIterator.nextEntry(Unknown Source)
            at java.util.HashMap$EntryIterator.next(Unknown Source)
            at java.util.HashMap$EntryIterator.next(Unknown Source)
            at com.google.common.collect.AbstractMultimap$KeySet$1.next(AbstractMultimap.java:904)
            at net.citizensnpcs.TickTask.clearActions(TickTask.java:124)
            at net.citizensnpcs.listeners.PlayerListen.onPlayerQuit(PlayerListen.java:32)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302)
            ... 10 more
  16. Offline


  17. Offline


  18. Offline


    Tanite - there's a new build coming through... could you please try that one out?
  19. Offline


    Ok, I will. Thanks :)
  20. Offline


    I was about to post up the exact same error
  21. Offline


    fullwall Error messages appear to be fixed now, but one thing I have had an issue with lately is that colours for the names no longer work, and also when I try to allow colour text it is fine until a restart is done then the message has a ?a (for green) instead of the text being green from using &a at the beginning

    For whatever reasons, I can see when it saves to the npc_profiles file it replaces the '&' with a '?' so when the restart occurs, that is what happens
  22. Offline


    i am not able to let the npc wear armor, i can give it to him but i can't let him wear it
    i did what the plugin sad (hold sneak + RMB) but it doesn't work
    if someone could help me with this, i would appreciate it :)

    --sorry if this already came up in the previous 361 pages
  23. Offline


    hold sneak? type /npc equip and hand him the gear
  24. Offline


    doesn't work when i just hand him over the gear it ends up in his hand instead on his body
    the screen "help" shows:
    Sneak to set the item-in-hand to armor
    but everytime i do as sad above (shift(sneak)+RMB) the item ends up in his hand
  25. Offline


    My main problem is that the traders doesn't work. They all have the same skin, they have "eh15" or "??15" infront of their actual name, i cant select any of the npc's for editing, i cant use them as they are (Wont open traders "chest" to buy things). However, the talking function is working. All of them are talking as they should when i pass them or look at them.

    I am running Citizens Beta 2.0 (Yes, i know that it is an unstable build) since it was the only build that was able to at all show my NPC's. At the "1.2 Build" the NPC's won't even show up. And i only get the: "java.lang.classcastexception java.lang.string cannot be cast to java.lang.boolean" error when i try to create a new one. I have been using google for a solution for days without luck. My Bukkit build is 1.2.5 i think.

    So, guys. Any solutions?

    Please post answers there!
  26. Offline


    K Yes I Did The Lastest Build But This Citizens Plugin I Have It Working But I Cant Use Vault With It Vault Crashes Guards And They Dont Work??? Can You Fix That
  27. Offline


    kitty8 - what OS are you using? Have you updated your bukkit version recently?
  28. Offline


    fullwall The host is Linux based and I have updated to the new bukkit update but was happening before that too. This issue may have occurred since I changed to the Linux host though. Not sure though. The colours work fine for the text until a restart. But Names Still do not work but used to one apon a time.
  29. Offline


    kitty8 - it could be that your YAML does not support the section sign used to indicate colour codes. Not sure if it needs UTF-8 or not...
  30. Offline


    I'm not having NPCs disappear, but I am having trouble with getting them to talk like they used to. They will say their message once and that's it unless I log off and back on. I have "talk-when-close: true" set both in the citizens.yml and for the NPCs in question in npc-profiles.yml. They used to talk every time you entered the 5-block range and you could get chatter by walking in and out of that range repeatedly. I saw someone talking about a possible Vault issue but I loaded the server with that off and it still behaves this way.

    I'm on build 67 of Citizens (the latest as of this writing).

  31. Offline


    Tanite i tested your issue on my server and it works fine
    they keep repeating there msg

    Version: 1.2

Share This Page