[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Is there a way to make NPCs attack a specific group or attack everything besides a specific group? I want to make it so that players on my server can create their own guard NPCs and have them protect their base from intruding players.
  3. Offline



    You have to make your NPC a Guard, add flags to your Guard that correspond to the mob/player/group you want it to attack, choose if you want a bouncer or bodyguard and finally set it aggro. (Although it seems to me that whitelisting doesn't work as described)

  4. Offline


    I got it now. Thanks Sheba, biggest issue was that last night after I added PermissionsPlus, all my NPCs vanished. Anyone know what this is about?
  5. Offline


    hey if ur having trouble downloading it click CITIZENS IS NOW ON BUKKIT DEV
  6. Offline


    For some reason whenever a Trader NPC is double right clicked quickly, anyone can access whatever said NPC is holding, for free, and put in/take out items for free.
  7. Offline


    I use it, and it shows up as a standardized person. So yes, you can see it.
  8. Offline


    Hi !

    I found a bug in citizens 1.2

    When you click 2 times (double click) very quickly on a trader, you can modify the inventory without any permission or without to be the owner of the NPC : you can take all his inventory or place items in the NPC's inventory...
    Can you fix that plz ? It breaks my server economy.

    EDIT : It seems to be fixed with the latest development build
  9. Offline


    how long it will takes to develop the first recomended build of citizens2
    i want zombie npc's for my dungeons ;)
    all in all a very nice plugin but with zombies it will be the best :D

    mfg rarebit
  10. Offline


    can you update your plugin for the new version 1.2.5-R4.0????
  11. Offline


    how come when i make npc and i stop the server and turn it back on, the npcs dispear someone pz help..
  12. Offline



    this seems to be a common problem with some versions. You can find several answers to this question in the forum here and on bukkit dev. For me: installing Vault plugin fixed the issue.
  13. Offline


    can someone help me? i have a small problem with citizens :mad:
    there is a problem.... when i create an npc ... he dose not look at me and those not talk. and when i reload the server he desepears and he those not apear back
    P.S: Sorry for my english (i'am from romania)
  14. Offline


  15. Offline


    Hey ! I've made a french tutorial for Citizens, and people commented it by talking about bugs they've got, and I can't really answer... help ! The principal problem is that the guards can't attack mobs without a permissions system installed on the server. An other problem someone has got is that if the NPC hasn't got an official version name, you can't hit him.
    You can find the tutorial here. If someone knows Citizens better than me and can speak some french, that would be nice from him to help me, otherwise could you answer me there please ? :)

    EDIT : Anton, try installing Vault on your server or disable Citizen's economy. On the first line of your screen I can see it hasn't found the Vault classes, so that made me think about that.
  16. Offline


    I have a small problem can someone help me?

    Attached Files:

  17. Offline


    hello. I just recently got citizens again. i used citizens back when minecraft was in beta 1.8.
    anyway. i have a problem with the guards. i'm not entire sure i'm entering in the correct command. it's at least not giving me a major error. i'm trying to get the guard to attack a specific permissionsEX group. this is what i input: /guard addflag 1 member -g
    and it spits out at me: Group flags require a Permissions backend.
    i've given my member permission group the permission: citizens.attack
    am i missing a permission node or something? or am i simply not entering in the correct command?

    also i have a problem with the economy. when ever i have it enabled the whole plugin breaks. no NPCs show up and nothing citizens related works. since if have to disable the economy for citizens i can't use the trader npcs. they all say economy has be disabled.
  18. Tried with BOSEconomy? Works for me. Don't know about attacking groups thought, but I believe I've read a long time ago that it was bugged/didn't work with groups. Don't know if they've fixed that now thought.
  19. Offline


    maybe add nicknames to the citizens so we are able to use skins but have them named "guard".
  20. Offline


    This plugin hasn't been working correctly for me, as hard as I try I can't seem to get the, for example, Guards to attack mobs, it will only attack a player if it is attacked, the flags just don't seem to do anything (and yes aggro, radius, everything is on/set)

    To add to that, and as a possible reason for why it is not working, on load/reload the console gives the following errors:

    29.06 17:49:15 [Server] INFO at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    29.06 17:49:15 [Server] INFO at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
    29.06 17:49:15 [Server] INFO at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:533)
    29.06 17:49:15 [Server] INFO at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:126)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.GuardTask.run(GuardTask.java:23)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.Guard.updateStatus(Guard.java:135)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.types.Bouncer.updateStatus(Bouncer.java:64)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.types.Bouncer.findTarget(Bouncer.java:24)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.Targeter.findTarget(Targeter.java:14)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.flags.FlagList.processEntities(FlagList.java:59)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.flags.FlagList.process(FlagList.java:35)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.flags.FlagSorter.getPossible(FlagSorter.java:150)
    29.06 17:49:15 [Server] INFO at com.google.common.collect.AbstractIterator.hasNext(AbstractIterator.java:136)
    29.06 17:49:15 [Server] INFO at com.google.common.collect.AbstractIterator.tryToComputeNext(AbstractIterator.java:141)
    29.06 17:49:15 [Server] INFO at com.google.common.collect.Iterators$7.computeNext(Iterators.java:645)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.flags.FlagSorter$6.apply(FlagSorter.java:1)
    29.06 17:49:15 [Server] INFO at net.citizensnpcs.guards.flags.FlagSorter$6.apply(FlagSorter.java:122)
    29.06 17:49:15 [Server] INFO java.lang.NoSuchMethodError: net.citizensnpcs.utils.EntityUtils.getMonsterName(Lorg/bukkit/entity/Entity;)Ljava/lang/String;
    29.06 17:49:15 [Server] WARNING Task of 'Citizens' generated an exception
    29.06 17:49:15 [Connect] User JBL, IP ***.**.**.***
    29.06 17:48:58 [Server] INFO [Citizens] Loaded 0 quests.
    29.06 17:48:58 [Server] INFO [Citizens] Loaded 4 NPCs.
    29.06 17:48:58 [Server] INFO [Citizens] Unable to fetch player map from CraftEntity: players. Conflicting names will do funny things.
    29.06 17:48:58 [Server] Startup Done (5.136s)! For help, type "help" or "?"
    29.06 17:48:58 [Server] INFO Server permissions file permissions.yml is empty, ignoring it
    29.06 17:48:57 [Server] INFO [EssentialsSpawn] Enabling EssentialsSpawn v2.9.1
    29.06 17:48:57 [Server] INFO [Citizens] version [1.2] loaded.
    29.06 17:48:56 [Server] INFO [Citizens] NPC types loaded: quester, wizard, trader, blacksmith, healer, guard
    29.06 17:48:56 [Server] INFO [Citizens] Enabling Citizens v1.2
    Any help would be GREATLY appreciated!

    Plugins I am currently running:
    Vault (just added this as I heard it fixed a lot of problems for Citizens, but no changes for me, does it require any more config other than install to plugins and reload? Because that's all I did. Help!)

    EDIT!: I seem to have fixed this. I completely deleted the plugin, went to this location: http://ci.citizensnpcs.net/job/Citizens/lastSuccessfulBuild/artifact/
    clicked "all files in ZIP" which downloads the latest successful build of Citizens, stopped the server, installed the plugin, restarted the server let the Citizens load once, then stopped it again, installed the Guard character type, restarted server and hey presto he works perfectly, killing zombies like I tell him and everything! Hopefully this helps someone else!
  21. Offline


    You need to make sure you do a /citizen save to force a save of all the current NPC info/data, then you can safely reload/restart the server. If you are already doing this and it is still not working then sorry, that's as far as I know, it was where I was going wrong for a while.
  22. Offline


    Hi, can you make a Update for
    Bukkit [diamond][1.2.5-R4.0][diamond] ? PLEASE :oops:
  23. Offline


    [email protected]:~$ 06:18:49 [SEVERE] org.bukkit.configuration.InvalidConfigurationException: unacceptable character '�' (0xFFFD) special characters are not allowed
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ in "<string>", position 41
    -bash: Syntaxfehler beim unerwarteten Wort `in'
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:55)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:138)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:105)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.citizensnpcs.properties.ConfigurationHandler.load(ConfigurationHandler.java:37)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.citizensnpcs.questers.data.QuestProperties.initialize(QuestProperties.java:13)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.citizensnpcs.questers.QuesterCommands.reloadQuests(QuesterCommands.java:175)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at java.lang.reflect.Method.invoke(Method.java:616)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:500)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:392)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.citizensnpcs.Citizens.onCommand(Citizens.java:208)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:166)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:479)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:821)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:781)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:764)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:34)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:229)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:567)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] Caused by: unacceptable character '�' (0xFFFD) special characters are not allowed
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ in "<string>", position 41
    -bash: Syntaxfehler beim unerwarteten Wort `in'
    [email protected]:~$ 06:18:49 [SEVERE] at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:70)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:50)
    06:18:49 [SEVERE] at org.yaml.snakeyaml.Yaml.load(Yaml.java:399)
    06:18:49 [SEVERE] at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:53)
    06:18:49 [SEVERE] ... 25 more-bash: init/dev/fd/62: Datei oder Verzeichnis nicht gefunden
    -bash: StreamReader.java:50: Kommando nicht gefunden.
    -bash: StreamReader.java:50: Kommando nicht gefunden.
    [email protected]:~$ 06:18:49 [SEVERE] at org.yaml.snakeyaml.Yaml.load(Yaml.java:399)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:53)
    -bash: Syntaxfehler beim unerwarteten Wort `('
    [email protected]:~$ 06:18:49 [SEVERE] ... 25 more
  24. Offline


    please help
  25. Offline


    I am having an issue with the trader. It is set to unlimited stock. a player can "steal" from a trader. they drag the item into their inventory and exit from the trader. then when u click on the trader again the item is gone but the player has kept the item without payment. its seems to only work when the player has some lag. is there anything i can do to fix this?
  26. Offline


    I Have one problem. Everytime i save my server then reload it, the npc's go away. Can you fix that?[arrow]
  27. Offline


  28. Is there any way to make it so that once an NPC(guard) dies from a mob or player that the NPC just STAYS dead? i am getting sick of them respawning
  29. Offline


    For some reason all my npc's do not die... you can hit them and they get pushed back but they never die... do you know why?
  30. Offline


    I have a problem my npc do not do as I tell them to do and they do not look at players or say nothing
  31. Offline


    Is there any way I can disable the /t command? It conflicts with towny's /t

Share This Page