[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    How Can You Change The Range That The Npc's Talk From, At The Moment Every Npc Talks At The Same Time As They Are So Close Together, Is It In The Config?
  3. Oh my. The amount of people quoting my post now... I wish you guys would read the date of that and notice it's on the first page xD. I posted that on the 5th of March, 2011. At this time NPCs didn't talk when close and required you to punch them with, I think, a book.
  4. 2012-04-08 13:19:52 [SEVERE] Error occurred while enabling Citizens v1.2 (Is it up to date?)
    java.lang.NoClassDefFoundError: net/milkbowl/vault/economy/Economy
    at net.citizensnpcs.Economy.init(Economy.java:21)
    at net.citizensnpcs.Citizens.onEnable(Citizens.java:122)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:336)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:250)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:232)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:371)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:358)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.ClassNotFoundException: net.milkbowl.vault.economy.Economy
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    ... 12 more

    i get this when trying to start the plugin.
    can any1 help plz?
    i updated it many times but it keeps appearing.
    i use iconomy.
  5. Offline


    mid_kid - you need to install Vault.
  6. Offline


    Hello. In earlier versions of Citizens it works. And when i updated server and Citizens it doesn't work =.= My quest:
    description: "&cJointoRed."
    completion: "<g>Gratulations!Youarejoining&cRed!<br><y>Nowwrite/rules."
    acceptance: "<g>DoubleclickRPMtoconfirmyourchoise.<br>&c(Red)<g>orwrite/questabort,whenyouchangedyourmind."
    repeats: -1
    '0': #double click on NPC will end the quest (the quest is only choise of fraction)
    type: delivery
    materialid: 0
    amount: 0
    npcdestination: 1
    optional: False
    finishhere: true
    '0': #gives rank "rchlop"
    type: rank
    rank: rchlop
    '1': #takes rank "default"
    type: rank
    rank: default
    take: true
    It doesn't give rank... And I don't know why.. -,-
    Sorry for my bad English, I'm from Poland. ;p.
  7. Offline


    It was vault. Now, it seems to work except that when I click to accept the quest it complains that I am missing a requirement, the requirement being that I be in group 'default' which I had assigned myself to, as the only group I belong to. I'm guessing that it is probably PermissionsBukkit (it hasn't been updated since 1.1-R5.).
  8. waiting for answer
  9. Offline


    Hi, I have a problem. When I click on the blacksmith, write me "You do not have permission on that"
    What I have do ?
  10. Offline


    We have been very busy with the development of Citizens2, so we haven't had time to read posts in this thread or anywhere else. The best place to contact us is in IRC, where either fullwall or I are almost 24/7. If we're both not around, there are a few other helpful people that would be glad to assist you.

    As for the disappearing issue - we still have very little knowledge of why it is happening. This has been a bug in Citizens since very early in development. We're working on fixing it for Citizens2.
    diannetea likes this.
  11. Offline


    Hey im Fairly new to minecraft only been around since 1.8 so i dont know a lot about the plugins but i cant get my citzens to link to my essentials-economy can anyone help me figure out how to link them? my chest shop and town auto linked and citizens should too much every time i try to set a traders prices it says my server doesnt have a economy plugin... please help me =D
  12. Offline


    Anyone else's guard not following them? I set mine to bodyguard, turned aggro on, set appropriate mob flags to target, and it doesn't follow me. Before I updated they were working fine.

    Also.... for citizens2... could you have an option to not create a log entry when saving?
  13. oh right ok.
    what about citizens 2.0.
    When is this exactly coming out? i tried it once from your homepage and it only gave me error, didnt work at all.:D
  14. Offline


    Me again! I just upgraded to the 1.2.5 compatible version of citizens and... I can't transfer my npcs/quests to the new version! I can get the new version running just fine, but as soon as I try to copy in my old npc files, citizens stop working (every command I try tells me "The command was not recognized" and no NPCs are loaded)

    Do I have to rewrite my citizens and quests EVERY TIME that there is an update?
  15. Offline


    I seem to be having this issue too and also the guards seem to not be attacking anything. Would really like for this mod to work. Has a lot of cool features.
  16. Offline


    Please help me somebody. Ive been trying to do the /toggle guard command and it says its an unrecognized command and to do /help for further details. Does anyone know why this isnt working? All of the other commands are.
  17. Offline


    The reason it is not working is because the 'type' folder in the 'Citizens' folder is blank and none of the types are in there.
    What I had to do to fix this is go into the plugins folder and move the 'types' folder into the 'Citizens' folder and then Choose to copy & replace. That should fix it for you. Let me know if that doesn't help.
  18. Offline


    Well that probably explains it, but no Types folder was ever created. Im using the latest 2.0 download that was posted today, and no types were created at all. Thats most likely my problem.
  19. Offline


    Yeah, I haven't gotten the 2.0 to work but the types folder that I found was out of place was for the 1.2 for CB 1.2.5-R1 update from a few days ago.
  20. Offline


    Ya i tried downloading a different types folder and putting it in...no luck.
  21. Offline


    If you are using 2.0 then that may be why it's not working. This was in the wiki:
    "First off, NPC types are now called "characters". These are no longer built-in JARs that you place in the /plugins/Citizens/types directory. You must download each individual character and place it in the /plugins folder. You can find out more about many characters on the Characters page."
  22. Offline


    The same thing for me.
  23. Offline


    unfortunately those extra jar's don't seem to be available yet
  24. Offline


    I want to ask if Citizens raise CPU use. I wanted to use it on my 2-3 player server so when me and my friends find one of those small towns we wont see it full of npcs that do nothing. But if this plugin is not designed for small server I guess I will skip it. I would like to use it along an economy plugin just to add merchants and feel liek the npc world is more alive.
  25. Offline


    easy way to stop this, is if you don't use economy just go into the config file and set that option to false
  26. Offline


    Okay so my new error is every time i try to reload the quests, i get a null pointer error in the console. However, the YAML parser online says that my quest file check out just fine. This seems to be an issue where citizens can't process the quests file?
  27. Offline


    How can I reduce the range of /npc talkclose please :/??
  28. Offline


    Ok. So I Create An NPC. Then I Turn Of My Server. And The NPC Is Gone! Any Help?
  29. Offline


  30. Offline


    Hi, pls how to set about selling potions Trader?
    ID is a potion for example 373:8265 (ID:data)
    command /trader sell 373:8265:1 50
    does not work

  31. Offline


Share This Page