[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    I have a problem with the plugin I put everything right but for the command on the server I get (The command Was Not Recognized see / npc help for list of commands), then I put / npc help and comes out the same, Help!
  3. Offline


  4. Offline


    Can you make it so that when this comes out for 1.2.3 that NPC's will look at you and talk to you automatically rather
    then having to click on them and make it so that anything you put in a traders inventory can be bought and sold
    rather then having to set it and can you make it compatible with the plugin called SimpleGold
  5. Offline


    you can do that by doin
    you just need to rightclick the npc and type /npc talkclose or /npc speakclose soming like that and it will do what you are asking for
  6. Offline


    Let me start buy saying i love this plugin been using it since it came out. I ran into a problem i can make a npc i named him bob k then i did toggle trader it worked but now when i click him to stock his inv it says opening inv closing inv just like that no chest opens im using 1.2 minecraft with bukket server why does this happen everything else seems fine but cant access his inv please let me know what im doing wrong
  7. Offline


    ok i am sorry i fixed it just download the npc types again were good no worrys thanks
  8. Offline


    Hello! I'd like ot first say how awesome this plugin has always been! I'd now like to say how I'm having an issue.

    I am using the 1.2 dev build. My npcs work the first couple of times that players use them, but then the NPCs suddenly stop responding altogether. I cannot click on them or select them for any purpose. After disconnecting and reconnecting, the NPCs will work- but only once or twice. EVERY user has this same issue.
  9. Offline

    funky man

    This is a common and well known fault with bukkit 1.2.3, unfortunattly it is not a problem with citizens but a vanilla problem and we are awaiting a fix from bukkit/mojang, a short term fix would be to get your players to relog whilst infront of the npc they're trying to interact with.
  10. Offline


    im on 1.2.3 and it write to me "Not useing econmy plugin"
    but i have the newest iconmy plugin in my server... what to do?
  11. Offline


    could someone please do an updated full tutorial on how to make quests and quest npc's in ENGLISH please, only found german ones, why is it so hard for you guys to do english ones, seriously
  12. Offline


    Newest Dev.Citizens 1.1.6 dont work at 1.2.3 ;P

    #2083 here.
  13. Offline


    forgot to add that i'm using the citizens 2.0 beta, it works for 1.2.3, just some features that needs to be added i guess like just remove, now you're FORCED to remove all, or you can maybe do a workaround by going in to the yml save and remove them but yeah
  14. Offline


    I've had a problem with selecting citizens.. I wouldn't be able to right click them until I move them onto an area and it's happens every time I reload. I do use /citizens save and /citizens reload. Some Npcs work but others do not. There are no console errors.
    Edit -- all npcs do not work, I'd have to move them to the area to get to use them. *i can still use them if I move them back* I have 32 Citizens and moving them all is not very convenient
  15. Offline


    Q 1= will there be guards in citizens 2 (and questers?)
    Q 2= if so can you make it so we can ahve certian npcs fight others ^.^ i want to have a huge npc war... between two of my servers factions
    Thanks :D
  16. Offline


    My NPC's wont talk! :mad:
  17. Offline


    First of all, be sure to put /npc talkclose so that they talk when somebody comes close. If you want to make them say something specific, type /npc set typewordhere to make them say that phrase.
  18. Offline


    You can select them by reloading :) use /reload
  19. Offline


    Having a issue where I cannot assign jobs to npcs. whenever I do /toggle, it says "Invalid NPC Type"
    The right click issue was fixed through updating to build 47 but nothing for this issue
  20. Offline


    I want to translate in italian :)
  21. Offline

    Merrick King

    I like all of the built in skins, but i don't really want to call all of the NPCs in my Orc City 'Goblin'! Maybe something like /npc skin <skin> would make more sense? That way i could give them more orc-ish names, the just go /npc skin goblin !

    Also, i tried to give all of my wizards enchanted armour and weapons ect, but when I equip it, the enchantment is removed :( Could you do something about this please?
  22. Offline


    Alright so everyone of my friends who host servers them self say get this plugin it is a good NPC plugin but I am getting very angry with this d*mn plugin nothing I do the server claims not to recognize my command /npc help doesn't work /npc create doesn't exist nothing I do is a command according to this stupid plugin in no where can I find help for this problem but I am getting tired of no one else having an NPC plugin that actually works cause so far I HATE THIS ONE. So I don't know what is going on but please fix it cause this is annoying seeing youtube video after youtube video of oh this is such a good plugin in easy and simple and then they do it perfectly fine. At one point I made an npc but he stood there motionless and every time I tried to do anything it said select npc and apparently I can't do that either cause the way everyone else does it is easy and they say it automatically selects the created npc....bullsh*t.... please just either help me out cause either I am doing something completely wrong or this plugin is crap.
  23. Offline


    Merrick King there are no skins built in. Goblin looks like a Goblin because there is a player called Goblin with the skin of an Goblin. Citizens uses the same skins as Minecraft. thats why your npcs look like you if you give them your name.
  24. Ok nothing works for me on this plugin why. When i type /npc set Hello and shit he will not talk and i type /npc talkclose and still does not do a thing. PLZ HELP ME!
  25. Offline


    LOL! i tried to get that quest running a whole day. and just had enough and took a bath. and now i come back and it works.... and i don't even know why xD

    fullwall and aPunch, in your wiki under objective nodes. @ the location example is one important part missing that is written in the first lines... there are the coordinates and so on but the World part is missing but it won't work without it

    also i have a question regarding the global trade price list. how to i set it up? i don't see any examples on how that would look like but what i found is a statement of you that it works :p
  26. i still keep getting v1.1.5 from the place where it reads to get 1.2.3 version v1.1.6... wtf. where i can get the damn 1.1.6 version so it would FINALLY work?


    found somewhere citizens 2.0 , its not compatible with freaking 1.2.3... wtf , where the fudge i get the darn 1.2.3 working citizens!?
  27. Offline


    hey its on here i was having problems too but after you start server type reload tworks you just have to reload everytime you log back in hopefully they fix that
  28. Offline


    i fixed it for some reason its not loading the plugin on server startup so i do reload after i login in and it reloads citizens and now it works so i think there is a loading bug ive even tried loading only that plugin still the sane and i updated vault so there reload it in server if it doesnt work i had no problems after that
  29. yah great i removed it already and i cannot find it anymore. FUKKK! XD


    i found 2.0 again, i downloaded , i set it into plugins, updated also my vault -> in game i type /plugins <- CITIZENS is RED which means its not working.
    I reload -> still red
    I reload -> STILL RED
    I realod -> STILL RED
  30. Offline


    yea im back at 1.1 bro this new update gave my 8gig pc bluescreen while playing so im gback at what i trust and now sorry bro
  31. Offline


    im running minecraft 1.1 now i think they have better plugins too

Share This Page